[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline

    Citizens

    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
     
  2. Offline

    Sharpie-o

    @fullwall

    any idea about the permissions? Your wiki doesn't have much, and citizens.admin doesn't work AT ALL on my server. I'm starting to think that I may have something wrong with my permissions or another plug. Is it ok if I upload my plugins folder and you can check the error? Because I don't have permission to use the npc commands, even when I'm the administrator
     
  3. Offline

    Todeshügel

    After that it worked! Many thanks!
    But now i've got another problem.. i'm experimenting with every npc and at the moment i try the wizard.. everything works fine but after restarting the server (even if i saved) the wizards are just normal npcs and no wizrad anymore!
    What can I do?

    And besides another question.. is there any way to fill up the mana? And is there an admin command?
     
  4. Offline

    Chris Herbert

  5. Offline

    dddbliss

    No problem, thanks for the great plugin. Any ideas about only some of the npc's randomly despawning. They also don't show up on /npc list. A server restart will fix, but I don't want to have to restart everytime they do this.
     
  6. Offline

    efstajas

    This morning my players startet to report an NPC nobody really created (nobody instad of me has rights to make one btw): http://cl.ly/8K20
    It has no name (empty name tag) and when I right click it, nothing happens, however after rightclicking /npc id shows 5. When I type /npc remove, it says "This is not your NPC."
    How can I get rid of him?
    I am running the bukkit- Build Dinnerbone tweeted for 1.7.3 and Cititens version 1.0.9.
     
  7. Offline

    Rilly

    We have noticed that anyone can take the money off of any NPC trader.. doesn't have to be just the owner.. Is this a setup error on my part?
    we have 3 NPCs
    Player1 owns NPC1
    Player2 owns NPC2
    Player3 owns NPC3

    Player2 walked up to NPC1 with /trader money take 10 and it took 10$ from NPC1
     
  8. Offline

    ohmydoddtv

    Set yourself as the owner and remove him, /npc setowner [yourname]
     
  9. Offline

    ArtyomSh

    Plz can u give list of comands that i shoul put in permision to made uzers use traders and create them !
     
  10. Offline

    Digi

    First make SURE you're actually selecting THAT npc and you're not giving commands to your last selected NPC.
     
  11. Offline

    TEM Vogelwurst

    Hi, i would really love to install this plugin on my server, but everytime i put it on my server, my server works for about 5 minutes, and keeps crashing every 2 min after restarting when citizens is still on the Server. After I remove it, the Server works fine again. Is Citizens incompatible with another plugins ?

    Well, thx for any help

    greetz Vogelwurst
     
  12. Offline

    Fatalisslayer22

    i have the same thing i can toggle classes of npc but when i try to make the npc better like /guard help or anything it tells me
    " The Command was not recognised. was it typed in correctly?
    see /guard help for a list of commands."
    and this happens for every type
    and i know you said dont report guards i know they arnt done but this happens with all npc help's is there new permissions or something?
     
  13. Offline

    efstajas

    Thanks, that worked! However, 2 other NPCs showed up after the first one, completely different location and even a different name. I took a look into the Citizens- Files and the NPC had no things specified, only the location. Every other NPC had things like Name, color etc... but this one not... :confused:
     
  14. Offline

    morizuki

    ok found the error that i was talking about

    Code:
    2011-07-09 04:36:08 [WARNING] Task of 'Citizens' generated an exception
    java.lang.NullPointerException
        at com.citizens.Utils.MessageUtils.getStackString(MessageUtils.java:161)
        at com.citizens.Economy.ItemInterface.getCurrency(ItemInterface.java:145)
        at com.citizens.Economy.EconomyHandler.getCurrency(EconomyHandler.java:368)
        at com.citizens.Utils.MessageUtils.getPriceMessage(MessageUtils.java:143)
        at com.citizens.Utils.MessageUtils.getStockableMessage(MessageUtils.java:157)
        at com.citizens.NPCTypes.Traders.TraderTask.sendStockableMessage(TraderTask.java:300)
        at com.citizens.NPCTypes.Traders.TraderTask.handlePlayerClick(TraderTask.java:209)
        at com.citizens.NPCTypes.Traders.TraderTask.run(TraderTask.java:104)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    it seems that when two to three players are right clicking the same NPC it gives that error then they can get the items for free.. when they close the inventory of the NPC.. and right clicked by another person or the same person it will say one at a time..
     
  15. Offline

    Sharpie-o

    Yeah, but I don't have permission for ANY command. Not /npc, /toggle, not even the /npc help or /basic help.
     
  16. Offline

    TEM Vogelwurst

    is there a stable version of this plugin, because it seems like everyone got a problem...for me, the Server is crashing every time i try to play minecraft with this plugin installed...will there be a bugfix or do i have to wait until the next update of minecraft and therewith a update of this plugin ?

    thx for any reply, i hope my post will be noticed this time...

    greetz Vogelwurst
     
  17. Offline

    strontkever

    probably a massive memleak in citizens since 1.7
     
  18. Offline

    dinusocol

    you will have to wait till then if you have to make shops just make the surroundings and wait till the fixed release of the plugin this is an opinion of mine so feel free to spam me :p
     
  19. Offline

    Fatalisslayer22

    i dont mean to bug but idk why it doesnt let me toggle anything even without teh permitions it doesnt work
     
  20. Offline

    Sharpie-o

    Yeah, me too. No permissions, and still, can't use commands.
     
  21. Offline

    d00ba

    I'd wait for the next version to be released. 1.0.9b has a lot of problems.
     
  22. Offline

    aimbotxx

    Mob Npcs cannot be killed.
     
  23. Offline

    Sharpie-o

    I think I found the problem... MAYBE.

    GroupManager.jar gives "1.0(alpha-5) [Zombie-Version, please switch to Permissions 3]", but I already have the Permissions 3.x... :S so, WTF?
     
  24. Offline

    Chris Herbert

    Do you mean you have the Permissions 3.x plugin installed? If so you shouldn't be using GroupManager.
     
  25. Offline

    Sharpie-o

    Let's try.
     
  26. Offline

    Sharpie-o

    Nope, I deleted it, and STILL "You don't have permission to use that command"
     
  27. Offline

    nick331999

    i have found a few bugs I'm not sure if anybody else haves these bugs but
    1 if a make an NPC and make a path for it it will follow the way points but sometimes it will copy its self I think it might be when the server reloads and then i can't target it and I can run through it it's nothing but a skin and name
    2 if I attack a NPC a few times it might copy its self and again it is just a skin and name i cant target it.
    3 I made a healer and set the owner to some random guy it could heal me but the next day it didn't it still said it was a healer everything was normal but it didn't heal me the same happens with traders
    4 are there any permissions I need cause regular players can't buy from traders
    5 When I make an NPC it will disappear if I log out I have to wait about 20 mins before logging out and just wondering is there like a 'npc save' command or something?


    and since player names as NPC names give the NPC the players skin I was wondering if a few people could post their IGN (in gamer name) and skin if possible Also Could the names be cool ones with out numbers (unlike mine)
    Thanks:D
     
  28. Offline

    ohmydoddtv

    I had an issue with that once, even when I deleted the Configs they remained there... It seems some of the Citizens data is being stored somewhere else. Try backing up the configs somewhere else, restart the server and see what happens. If they remain there when your old configs aren't installed you will have to reinstall the entire thing :(
     
  29. Offline

    ferretlegs

    This has been a long standing issue with all versions of citizens for a few months now. Fullwall at one point did mention they were going to look at their chunk unload code and I think there has been some attempts to address this. Unfortunately I have to report that npcs are still despawning for me with the latest build though I did note the following in the logs which looks like a possible attempt to detect and reload disappearing npcs:
    2011-07-09 12:23:55 [INFO] [Citizens] Despawned at 3 0
    2011-07-09 12:23:55 [INFO] [Citizens] Despawned at 3 0
    2011-07-09 12:23:56 [INFO] [Citizens] Despawned at 4 0
    2011-07-09 12:23:56 [INFO] [Citizens] at
    2011-07-09 12:23:56 [INFO] [Citizens] exists
    2011-07-09 12:23:56 [INFO] [Citizens] is
    2011-07-09 12:24:20 [INFO] [Citizens] Reloaded at 4 0
    2011-07-09 12:24:43 [INFO] [Citizens] Reloaded at 3 0
    2011-07-09 12:24:43 [INFO] [Citizens] Reloaded at 3 0
    Although these messages have perhaps caught some of the despawning, when I checked the server this morning a number of npcs were gone again - a server restart immediately fixed. The interesting thing is that it is always the same culprits, I always know which ones are most likely to disappear and which ones are always there regardless. I cannot see any pattern why those particular npcs would despawn though.
    Now this may be coincidence, but I do not recall any NPC's disappearing during the troubled 1.09 builds that were creating excess chunks, but this may be because the server needed to be restarted so regularly because of the memory leak that the npcs did not have time to despawn.
    On a seperate topic, would like to report a couple of observations with guards that I have discovered during early testing of this feature - I have setup one bouncer patrolling the town border using waypoints:
    1. Guard does not attack mobs on the blacklist, nor do mobs notice the guard as he walks past
    2. When set to agressive, if you attack the guard he permanently abandons his patrol route. Even if you get out of his range he will just stand there. Also, regardless of whether you kill him or vice versa he continues to hold a grudge and you can never approach that guard again ever without repeating above.
    3. Dead guards drop their equipped items, which has the potential to be farmed. Any chance this can be an option to turn off.
    4. I also like the previous suggestions of having a guard pause at certain points of the patrol rather than continuously marching like a toy soldier automaton.
    Hope this helps.
     
  30. Offline

    Fatalisslayer22

    um well its fine ill have to wait intel the next update but i think the cuz of this is the new update how npc's have there own folder it could of made a bug that affects npc help
     
  31. Offline

    pilipino93

    Yeah I'm getting a few bugs, running on latest cbukkit build 1.7.2. For some reason my text I set ingame and in the files manually keep getting reset, and the npc, at time, choose not to talk to me whether I reset server etc.
     

Share This Page