Friends can't connect.

Discussion in 'Bukkit Help' started by Lemony_Lime, Apr 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I properly forwarded my ports, and can now connect from my other computers, using the server ip. My friends can't connect to the server though. Any idea why?

    I'm using latest bukkit, with only a few plugins, Windows 7 64bit, and have tried both minecraft 1.3 and 1.4. In fact, they couldn't connect to a vanilla server either.
  2. Offline


    Ok, what is your ip?
    could you paste you file and how are you running your server?
    However, im assuming you are using your internal ip.
  3. Offline



    #Minecraft server properties
    #Thu Mar 31 18:19:27 PDT 2011
    I'm not using any extra software to run the server, if that's what you meant. Is there something more that I should download?
  4. Offline


  5. Offline


    okay, I've got the right IP now... but can't connect to it.

    I also tried putting it in under the server-ip= part of the file, and now I can't start the server. It says failed to bind to port. (And I made sure there are no other Java processes running.)
  6. Offline


    use run - cmd - ipconfig, use your IPV4 or IPV6 or IPVwhatever IP there, put that onto the server-ip=, Now then, go to, give that to all your friends. Give them YourExternalIp:25565, then for you to connect use your internal IP (ipconfig IP).

    Let me rephrase that into an easier way to understand.

    1. Go to Start. Type in CMD if you're on Vista or Windows 7, if you're on XP or what not hit run and type in CMD.
    2. in CMD type in ipconfig, it should give you IPv4 or IPv6 or what not, use that IP and put it into your Server.Properties file under Server-ip=.
    3. Go to, get your IP. Give your IP and port to your friends, Example: www.whatismyip.comIP:25565, or as another example,
    4. To log into your actual server use your IPv4 or IPv6 or IPvWhatever.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  7. Offline


    Okay. I followed that exactly... and the server is running again, but my friend still can't connect. Could it be something on his end?

    He says he's connected to plenty of other servers no problem, as have I.
  8. Offline


    It can't be his end if he can connect to others check open port on your server pc, have server running, then from same pc open browser and go to and enter only your 25565 port number, then hit the Check button. If it says Successful in green, your ports are open for outside people to connect to you. If it says Error in red, then your 25565 port still appears as closed to the outside world, hence why friend can't connect. This might mean either router settings aren't correctly configured for portforward, or some firewall/antivirus can possibly still be blocking that port on that pc.
  9. Offline


    I have a simmilar problem ..... I'm using LogMeIn Hamachi to run the server........ i have the paid version of it, but have tried the free to.....

    I have had the problem since Beta 1.2.6 have tried many guides frm various forums but none of them works..... Help

    My friend is also using Hamachi i can connect to it, he also have the same router system so thats not the problem.

    I can connect to my server but no one else...... it did not even work when we had a Dataperty at my place :S

    I Have W7 64bit
    Minecraft 1.4
    latest recommended build of Bukkit (2 april 2011) Latest of hamachi to.

    java version "1.6.0_23"
    Java(TM) SE Runtime Environment (build 1.6.0_23-b05)
    Java HotSpot(TM) 64-Bit Server VM (build 19.0-b09, mixed mode)
  10. Offline


  11. Offline


    It couldn't see me. What other settings are there that I need to change though?

    I don't really know anything about it. lol
  12. Offline


    Should 25565 be forwarded on UDP, TCP or both?
  13. Offline


    Ah, I finally got it. I think I had a lot of other problems, that you guys helped fix as well, so thank you... unfortunately... I just put the IP for the wrong computer in when I forwarded the port. D: Simple fix. lol

    I have it set to TCP.
  14. Offline


    Haha. At least you fixed it ^^.
Thread Status:
Not open for further replies.

Share This Page