Problem/Bug Friends can't connect to server

Discussion in 'Bukkit Help' started by robertlit, Jul 29, 2019.

  1. Offline

    robertlit

    So, my friends can't connect to the server.. I can access it via my local IP aswell as my public IP.
    Here are some pictures that may help you undertstand the problem:
    Fire wall settings:[​IMG] [​IMG] [​IMG] [​IMG]
    Public IP and port forwarding settings: [​IMG] [​IMG][​IMG] [​IMG]
    Server properties: [​IMG][​IMG]
     
  2. Offline

    Machine Maker

    Try restarting your router (if you haven't already).

    Also, if you have access to a different device (e.g. a mobile phone NOT on your wifi), try using https://canyouseeme.org to see if the port is visible to the outside world.
     
  3. Offline

    robertlit

    My router auto restarts everyt night at 2:40 AM and I have this problem over a month already.
    https://canyouseeme.org says that port 25565 isn't open (if viewed on the wi-fi, if my phone isn't on the wi-fi it doesn't let me change the IP to check on it just shows my phone's IP).
    @X1machinemaker1X
     
  4. Offline

    Machine Maker

    And just to double check, you went to https://canyouseeme.org from a device NOT connected to the same network as the device hosting the server?

    If so, then the issue is with the port-forwarding. Did you assign your machine (aka the computer hosting the server) a static IP address in your router settings?

    Try running the command "ipconfig" in the Command Prompt and post what your LOCAL IPv4 address is.
     
  5. Offline

    robertlit

    @X1machinemaker1X https://canyouseeme.org doesn't let me check any IP that isn't the device's IP, therefore, if I disconnect from the wi-fi it just fixes in place the phone's IP and doesn't let me check the host machine's IP. I used another site (https://www.yougetsignal.com/tools/open-ports/) that doesn't do that (on my phone that is currently disconnected from the wi-fi) and it said the port 25565 on my public machine's IP is closed. It said the same for port 80 which is pretty wierd..
    Here is what it says when I run ipconfig: [​IMG]
    (You can see above how I did the port forwarding)

    Also I tried using NO-IP and it worked for me but not for my friend..
     
    Last edited: Jul 29, 2019
  6. Offline

    JackRyan404

    If you tried NO-IP and it worked for you, it should ideally also work for your friend. As it is your friend's consequence shouldn't matter. I will try to replicate the similarities of your problem and comment my findings. Meanwhile if your problem gets solved do post it here.
     
  7. Offline

    Kars

    You could always use ngrok TCP as a temporary solution. Sounds like your router is fucked, to me.
     

Share This Page