[FIX] Minecraft Version Changer v18.0 - Changes Minecraft Client to Different Versions

Discussion in 'Bukkit Tools' started by flippit, Apr 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    flippit

    Minecraft Version Changer - Changes your Minecraft client to different versions
    Version: v18.0

    Ever had problems connecting to your favorite Bukkit server after a Minecraft update? Minecraft Version Changer allows you to easily change your Minecraft client to a different version, to match the version that is supported by the server you wish to connect to.

    Features:
    • Simply select the version you wish to change to from a list and its done!
    • Option to download the latest version so you can always restore your client to the latest release
    [​IMG]


    Download:
    http://flippit.ath.cx

    Changelog:

    Version 18.0
    • Added support for Minecraft version 1.3.1
    Version 17.0
    • Added support for Minecraft version 1.2.5
    Version 16.0
    • Added support for Minecraft version 1.2.4
    Version 15.0
    • Added support for Minecraft version 1.2.3
    Version 14.0
    • Supports Minecraft versions up to 1.1
    Version 13.0
    • Supports Minecraft versions up to 1.0.0
    Version 12.0
    • Supports Minecraft versions up to Beta 1.8.1
    Version 11.0
    • Supports Minecraft versions up to Beta 1.7.3
    Version 10.0
    • Supports Minecraft versions up to Beta 1.7.2
    Version 9.0
    • Supports Minecraft versions up to Beta 1.7_01
    Version 8.0
    • Supports Minecraft versions up to Beta 1.6.6
    Version 7.0
    • Supports Minecraft versions up to Beta 1.6.5
    Version 6.0
    • First public release
    • Supports Minecraft versions up to Beta 1.5_01
    Version 5.0 and earlier
    • Pre-public release versions
     
  2. Offline

    Baummann

    Nothing is working with Wine or mono except Gimp
     
  3. Offline

    LouiseLindell

    Arg, i really need help!
    I installed the program, and it is working, BUT!
    when I choose version 1.7.3, i runs 1.8. How do I fix it?
    I miss playing multiplayer :s
     
  4. Offline

    tips48

    1.8. NOW! :D
     
  5. Offline

    Celeixen

    Sadly, i haven't been able to contact flippit in ages, i think he has lost interest in this project :(
     
  6. Offline

    flippit

    Greetings all, a long time between Minecraft updates but finally version 1.8 is here. And now available is an update for Minecraft Version Changer, with support for Minecraft versions up to version 1.8.1

    Get it here: http://flippit.ath.cx

    Screenshot:
    [​IMG]

    Hi LouiseLindell,

    Minecraft version information changed with version 1.8 and you need the latest version of the Minecraft Version Changer which is version 12.0 to solve your problem. Please download MVC v12.0 from http://flippit.ath.cx

    Regards,

    flippit.

    Thanks for the tip Celeixen, I'll change it for the next version.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  7. Offline

    jasonsj10

    Wow, this is a nice project. Thanks for taking your time and making this. Now all we need is a client that can connect to all server updates xD Like one client is able to connect to a 1.7.3 and able to connect to a 1.8 with out transfering the jars.
     
  8. Offline

    danieledward

    Same problem here, I select version 1.7.3 and it still loads 1.8.1......what's the deal? Ionly thing I did was restart my computer after playing 1.7.3 after I initially ran this program and everything was working fine.
     
  9. Offline

    flippit

    Hi danieledward,

    Please check that you are using the latest version of Minecraft Version Changer (MVC) which is version 12.0. Updating should resolve this issue. Mojang changed the way version information is stored in Minecraft version 1.8 - the latest version of MVC will work correctly but people using earlier versions of MVC will experience the issue you are describing.

    flippit
     
  10. Offline

    ChumChum

    I have a bad feeling about this.

    [​IMG]
     
  11. Offline

    Celeixen

    OMG the webpage is gonna get you :p
     
  12. Offline

    iffa

    I have a feeling someone should decompile this and look for anything that is related to lastlogin and e-mail.
     
  13. Offline

    flippit

    Hello iffa,

    Your suggestion to decompile MVC to confirm there are no security issues is a good idea. If anyone would like to take the time to do it, then report back in this forum to confirm that MVC is safe, I would be happy to credit them for their work on the official MVC website.

    Regards to all,

    flippit.
     
  14. Offline

    iffa

    You donkey can't even share the source yourself.

    [​IMG]
     
  15. Offline

    flippit

    Me releasing the source code would achieve nothing - who's to say that source code I release is the actual source code from the published versions? If there is any doubt about the security of MVC then what is needed is an independent person to decompile MVC and examine it, then report back. Someone who is a respected member of the Bukkit community, with a history of good, constructive and helpful posts in the Bukkit forums.

    flippit.
     
  16. Offline

    flippit

    Minecraft Version Changer v13.0 is now available, includes support for Minecraft v1.0.0

    Get it here: http://flippit.ath.cx

    [​IMG]
     
  17. Offline

    Xyphien

    This looks very promising, Will be sure to test it out when I get back home. Would love to play more than vanilla, or glitchy 1.0.0 bukkit servers :3
     
  18. Offline

    Abrupt

    we could compile said source code and check the hashes of that compiled program to see if it matches the one that you are distributing.
     
  19. Offline

    tips48

    Your back! :D Please add 1.0.1 ;)
     
  20. Offline

    FooBarFooBar

    Great idea, downloading this for sure.
     
  21. Offline

    flippit

    Minecraft Version Changer - Version 14.0 is now available, adding support for Minecraft v1.1

    Get it here: http://flippit.ath.cx

    [​IMG]
     
  22. Offline

    Lolmewn Retired Staff

    Nice one. :)
     
  23. Offline

    thatgamergirl11

  24. Offline

    PikachuEevee

    Why exacly would it be illegal. I can see why selling the jar would be but giving it for free? Have you not noticed that on the mojang website, they give the snapshots which are pretty much pre-released jars? And they're free. So whats wrong with giving jars?
     
  25. Offline

    tyzoid

    They are unsupported, probably buggy, and don't work well with the servers. You actually need an account to get the stable supported versions.
     
  26. Offline

    Darq

  27. Offline

    Samoumiel

    1. is a special minecraft server site.why you post this on this site?

    2.why a windows packtage all .msi take long time to download and instal
     
  28. Offline

    flippit

    Minecraft Version Changer - Version 15.0 is now available, adding support for Minecraft v1.2.3

    Get it here: http://flippit.ath.cx

    [​IMG]
     
  29. Offline

    HappyPikachu

    I've just read through every post thus far, and I can't believe how many people are so quick to call this illegal. It's sad, considering there's no evidence behind those accusations... plus, a lot of people here suddenly seem to think they have a degree in law.

    What's beautiful about this thread is how professional flippet is taking all of this. At this point, he's got every right to tell you guys off, but nah - he's keeping it cool. Nice job, @flippet. I think I'll be switching over from MCNostaliga very soon.
     
    KawaiiNeko and itsMEE like this.
  30. Offline

    Jemjem787

    Thanks for the Download! When will 1.2.4 be supported? and Nostalgia is outdated so this is the better alternative.
     
  31. Offline

    itsMEE

    It was great if you'd use java to publish this (Baummann said it before I think) ;)

    I thought the sense of those programs is, to bring old versions back oO

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
Thread Status:
Not open for further replies.

Share This Page