[FIX/MECH] NoFloatingTrees v0.4.1 - Automatically Remove Floating Leaves [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Jacek, Aug 22, 2011.

  1. Offline


    Yeah the list is lost after a restart, on shutdown the trees left over should be cleared though.

    Can you try updating to 0.4.1, I think I fixed it :D
  2. Offline


    k will try
  3. Offline


  4. Offline


  5. Offline


    Hey i was wondering after the plugin remove the logs and disable leaves drop in that area. I just like to reduce lag as much as possable.
  6. Offline


    Projected datafolder: 'plugins/NoFloatingTrees' for exists and is not a directory

    that does not sound like something I can control. Remove that file.

    The pluign does not disable leaf decay, it just removes the logs.
  7. Offline


    Wow after reading my post i complety fail at explaing. But thanks for this awesome plugin.
  8. Offline


    No problem :D
  9. Offline


    The debug jar looks good! I assume the amount of messages is because it's a debug version?

  10. Offline


    Yeah I hoped it would give some idea of what was going wrong.

    EDIT: Irritatingly that means it worked perfectly. You say the latest version does not work at all ?
  11. Offline


    No, but your debug version works just fine. Sorry for the late reply :(
  12. Offline


    What ?! That makes no sense. I will have another look tomorrow though, its 01:30 now :(
    Vettexl likes this.
  13. Offline


    This plugin works some times but the others I get this in my black box
    2011-08-28 18:47:06 [SEVERE] Could not pass event BLOCK_BREAK to NoFloatingTrees
    at uk.co.jacekk.bukkit.NoFloatingTreesBlockListener.onBlockBreak(NoFloatingTreesBlockListener.java:30)
    at org.bukkit.plugin.java.JavaPluginLoader$37.execute(JavaPluginLoader.java:497)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    at net.minecraft.server.ItemInWorldManager.c(ItemInWorldManager.java:157)
    at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:121)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:481)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:140)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:478)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422) 
  14. Offline


    Try the latest version, you can get it here http://dev.bukkit.org/server-mods/nofloatingtrees/files/

    That has nothing to do with spout... which version are you using ?

    Which version number do you have ?

    This is nothing to do with spout, learn to read a stack trace before you argue about it.

    Fill out a ticket on bukkitdev and make sure you provide information under each of the headings.

    I'm not getting into a flame war with you, and you can post the full report here if you like.

    What do I need to do reproduce this error ? I run the plugin on my server and it has never come up.

    did you create a new world, did you teleport ? What did you do ?

    The error you posted is related to the block break event so that makes no sense :s

    Also, I checked the line number and you must be using 0.4.1 because line 30 is blank.

    Update to 0.4.2 and see if that fixes it.

    Can you post a pastebin of your full server.log ?

    Are you sure you broke part of a tree that would trigger the removal ? It needs to have dirt below it and 2 logs above.

    Since you are both apparently having the same problem, can you both try this version http://bukkit.jacekk.co.uk/NoFloatingTrees/NoFloatingTrees_debug.jar

    Break one log, use the command, and then post what ever you get in he log file back here.

    Well all I did was add those messages... so the other version should also work.

    Maybe you were.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  15. Offline


    It now says 'Removing floating trees, Done!' etc. in game but it still doesn't do anything.
  16. Offline


    What do you get in the log file ?

    You are using 0.4.1.

    Which download link did you use ? You need to get the file from BukkitDev.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  17. Sorry but I do not see how you dare even enter these forums and call our developers SHITTY.

    If it wasnt for the DEVELOPERS who like my self put ALOT of our own time and effort, for no real reward, Bukkit wouldnt be what it is.

    I know I shouldnt be getting involved, but calling someone shitty is kinda harsh put it that way. Anyways im off, just thought id have my say.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  18. Offline


    Well that is just not possible that you would get that error with 0.4.2, line 30 is blank as I said before. Can you post your full server.log ?

    I am trying to help you and have tried to overlook your insulting comments up to this point but if you continue I don't see why I should put the time into helping you.

    You can report bugs, that's good but all the name calling is just being childish and there is only so much of that I am willing to put up with.

    When you first said you were using 0.4.2 I downloaded the jar to check the line and it was blank. I want you to post the full server.log so I can check the version number. To be honest I am starting to think you are just trolling.

    Which download link are you using ?

    Can you post the link ? Or your server.log ? Or somethign that I can use to verify you have the right version ?

    Right, well line 30 of NoFloatingTreesBlockListener is

    package uk.co.jacekk.bukkit;
    import java.util.ArrayList;
    import java.util.UUID;
    import org.bukkit.block.Block;
    import org.bukkit.event.block.BlockBreakEvent;
    import org.bukkit.event.block.BlockListener;
    public class NoFloatingTreesBlockListener extends BlockListener {
        NoFloatingTrees plugin;
        public NoFloatingTreesBlockListener(NoFloatingTrees instance){
            this.plugin = instance;
        public void onBlockBreak(BlockBreakEvent event){
            if (event.isCancelled()) return;
            Block block = event.getBlock();
            UUID worldId = block.getWorld().getUID();
            ArrayList<int[]> coordList;
            if (plugin.coordList.containsKey(worldId)){
                coordList = plugin.coordList.get(worldId);
                coordList = new ArrayList<int[]>();
    // THIS LINE HERE, IS 30
            if (plugin.looksLikeTrunk(block)){
                int[] coords = new int[2];
                coords[0] = block.getX();
                coords[1] = block.getZ();
                plugin.coordList.put(worldId, coordList);
    There is no way that could cause the error you posted, in fact the exact same error was reported here http://forums.bukkit.org/threads/fi...floating-leaves-1060.32952/page-2#post-629782 and from the changelog of 0.4.2 http://dev.bukkit.org/server-mods/nofloatingtrees/files/2-version_0-4-2/ the above fix was added to work around it.

    Are you sure the error hasn't changed since you started using the most recent version, more specifically the line number ? Look carefully it might be very similar.

    Right, I just downloaded 0.4.2 from http://dev.bukkit.org/server-mods/nofloatingtrees/files/2-version_0-4-2/ and replaced my local dev version. There is no error when breaking a block, and the removal works as expected.

    Unless you can tell me how to reproduce the error there is nothing I can do unfortunately.

    Thanks for the feedback, I will work on that.

    Just want to quote that before you edit it.

    Well it has to be their for the mods to see when they review my report of your posts.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  19. Offline


    This is A great plugin. it works and it keeps the server a little bit cleaner [diamond]
  20. Offline


    Thanks, I was surprised it didn't exist already tbh. Those damn leaves are a bit of a pet hate on mine and removing them manually was becoming impossible,
  21. Offline


    Nevermind, I got it to work now without error. Thanks for your support! :)

    Also, does this operate in a fixed radius or in all active/loaded chunks?

    EDIT: Another question :) Is there a version for CB 1000? (I can't remember if I asked this question before)
  22. Offline


    :D Out of interest what was the problem ?

    When you break a block that looks like a tree that location is saved, every 30 minutes all of these locations are check to see if a tree is there. So it works in all chunks all over :D

    Not specifically, but I imagine the latest one for 1060 would work since it only makes use of the block break event and the scheduler and both of those things have been in Bukkit since day 1 (maybe, at least for a while)
  23. Offline


    Honestly, I'm not sure. I just started the server and it worked just fine xD

    Okay, sounds good. :)

    I think I tried it on 1000 and got some errors, I'll try again now and post anything that comes up.

    EDIT: Using 1000, errors ahoy! http://pastebin.com/3ft62ETH, http://pastebin.com/8mM258HN
    Why does Line #12 mention Spout?
  24. Offline


    Ah, well I won't be supporting an older version, you should just upgrade anyway :D

    Each line of the error is essentially a function call, it tells you where the error happened and then what called that method and then what called that method, etc, etc...

    So the fact that spout is there is not significant at all, all it means is that it has been involved in that particular execution.
  25. Offline


    ime 1060 and NON of my floating trees are gone :confused::'(
  26. Offline


    It will only work for ones cut down after this was installed.
  27. Offline


    THX for telling me that
    but it would be cool if it worked after it was installed too :)
  28. Offline


    Not possible without scanning every chunk in the map, which would take a very long time !
  29. Offline


    LOL well i understand how hard it is
  30. @Jacek , the plugin is not working! (o.4.2, CB1060)
    Tree woodblocks break, drop a wood block and the treeblock gets respawned!
    Ignore it - was a plugin conflict

Share This Page