First time Bukkit user... I can't get it to run.

Discussion in 'Bukkit Help' started by TheTennessee, Jun 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    TheTennessee

    I should say, I can't get it to run in any state that is playable. This is my big switch to Bukkit, the one I've been waiting for since like 1.4, but I was finally able to convince my players to do it.

    So, now I have finally installed Bukkit, followed all the instructions, and I can't actually -do- anything in it. I log in, but then nothing loads. My minimap doesn't load (Client Mod), I can't move, I can't see anything, and for the first few minutes, I am falling infinitely. Then once I stop, I am either in a strange place with only a single chunk loaded, or I am in a wall somewhere, and I don't suffocate, but whenever I try to dig my way out, the blocks just respawn. Then when I disconnect, the server gets this error:

    [SEVERE] Exception in thread "Connect #0 write thread"
    [SEVERE] java.lang.NullPointerException
    [SEVERE] at net.minecraft.server.NetworkWriterThread.run[SourceFi (Can't read any more due to bleed over)

    Now... I am using Build 818, because my players updated instead of waiting like I told them to in 1.5_01, so I was forced to wait until a stable 1.6.6 build. My world works fine with the vanilla Minecraft_server.exe, even after running it in Bukkit, I go back and it still works. In fact, everything works fine in Minecraft_server.exe, and I've even tried to run it as a .jar before, which worked alright, but I got no benefit from.

    Can anyone help me out here? I tried searching your forums for the error codes and stuff, but I get pages of unrelated material. I would like to get this working for my players soon, along with all the cool plugins we found.

    P.S. One of my players with no client mods tried to log in, and got the same thing.

    P.P.S. I got the world to load a -little- bit more for me, but eventually it stops loading anything, it is extremely laggy while it is running (compared to 0 lag in Minecraft_server.exe), and after a few minutes it disconnects me and gives "Internal exception: java.net.SocketException: Software cause connection abort: recv failed." That is client side. Server side, I just get the same errors as above.

    Nevermind, downloading a fresh .jar of Bukkit seems to have fixed the issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  2. Offline

    EvilSeph Retired Staff

    Sorry to hear you had issues the first time. I imagine your download was incomplete or corrupted. Glad it works now though and welcome to Bukkit! :)
     
Thread Status:
Not open for further replies.

Share This Page