Solved First Join Plus - Need help

Discussion in 'Bukkit Help' started by kiracookie, Jul 26, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    kiracookie

    We used to use First Join Plus with zero problems in the past. Now I just watched a brand new user join the server, but the new player sound didn't play, and they didn't get the starter kit I had set.

    This is my config:

    Code:
    # FirstJoinPlus v1.8 Configuration -- Please see https://github.com/chaseoes/FirstJoinPlus/wiki/Configuration #
    settings:
      first-join-message: '&d%player-name has joined the game for the first time (%unique-players
        total players have joined)!'
      teleport-delay: 0
      notify-sound: LEVEL_UP
      update-checking: true
      debug: false
    on-first-join:
      show-first-join-message: true
      teleport: false
      show-smoke: false
      play-notify-sound: true
      launch-firework: false
      give-xp: 5
      set-invincible: 0
      give-items:
        enabled: true
        items:
        - STONE_PICKAXE
        - STONE_SWORD
        - STONE_AXE
        - STONE SHOVEL
        - GOLD_SHOVEL
        - COOKED_STEAK:5
      give-written-books:
        enabled: true
        book-files:
        - rules.txt
      send-motd:
        enabled: false
        delay: 20
        messages:
        - '&2Welcome to our server, %player-name! Customize this message in the FirstJoinPlus
          configuration:'
        - '&6http://dev.bukkit.org/server-mods/firstjoinplus/'
      run-commands:
        enabled: false
        commands-to-run:
        - me just joined for the first time!
      run-console-commands:
        enabled: false
        commands-to-run:
        - promote %player-name
      apply-potion-effects:
        enabled: false
        effects:
        - SPEED:1:15
    other-messages:
      join-message:
        enabled: false
        message: '&e%player-name joined the game.'
      quit-message:
        enabled: false
        message: '&e%player-name left the game.'
      kick-message:
        enabled: false
        message: '%none'
    
    When I use /fjp items, I only get the stone sword, stone pickaxe, and stone shovel, and then I get a message saying "An internal error occurred while attempting to preform this command"

    I'm using version 1.8.2 which people on the original listing says indeed works.
     
  2. Offline

    SicanEric

  3. Offline

    kiracookie

    I rewrote steak to be it's ID instead of it's name to avoid confusion with a proper name, but I still only get the 3 items I previously listed.

    The level up sound used to play when we ran FJP on Minecraft 1.5, but for some reason it won't work again now on 1.6.
     
  4. Offline

    kiracookie

    I fixed the problem!
    I found out that I had named the shovels wrong, so that's where it stopped to prevent further error.
    I renamed it to STONE_SPADE and GOLD_SPADE respectively then it gave me items up until it found that I had named the steak wrong as well. I renamed it properly and then got all of the items.
     
  5. Offline

    SicanEric

    I knew it...
     
Thread Status:
Not open for further replies.

Share This Page