Failed to Bind to port?

Discussion in 'Bukkit Help' started by Cinnamonbun, Aug 15, 2012.

Thread Status:
Not open for further replies.
  1. First off, I have tried the solution in the FAQ, didn't work. Here's the Error.

    [INFO] Starting Minecraft Server version 1.3.1

    [INFO] Loading properties

    [INFO] Default game type: SURVIVAL

    [INFO] Starting Minecraft server on -:25565


    [WARNING] The exception was: Address already in use: JVM_Bind

    [WARNING] Perhaps a server is already running on that port?

    Also for some reason my IPv4 Address is now different, I think my ISP changed it. I dunno if that has anything to do with it. If anyone can help me I would be so happy! Thanks!

    EDIT: I notice everytime I try to run it I get a Crash report my OS Is Windows 7 Home Premium

    ---- Minecraft Crash Report ----
    // My bad.

    Time: 8/15/12 2:27 PM
    Description: Exception in server tick loop

    at net.minecraft.server.DedicatedServer.ah(
    at net.minecraft.server.DedicatedServer.a(

    Relevant Details:
    - Minecraft Version: 1.3.1
    - Operating System: Windows 7 (amd64) version 6.1
    - Java Version: 1.7.0_05, Oracle Corporation
    - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    - Memory: 991452616 bytes (945 MB) / 1029046272 bytes (981 MB) up to 1029046272 bytes (981 MB)
    - JVM Flags: 2 total; -Xmx1024M -Xms1024M
    - Type: Dedicated Server
    - Is Modded: Definitely; 'craftbukkit'
    - Profiler Position: N/A (disabled)


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  2. Offline


    It means that 25565 is already in use (so you can't forward your port on 25565).
    Did you run your server before? If you start your server, and close the window (without typing "stop" in the console), that error happens.

    The only way to fix it is to restart your computer.
  3. Offline


    your internal ip (IPv4) changes everytime you re start your computer unless if you static it
    check out my guide to portforwarding
  4. I ran this server for 2 1/2 months. I tried restarting my PC

    Can I not fix it?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  5. Offline


    have you portforwarded though?
  6. Yes.

    I get an error log when I try to use STOP. In OP .

    Alright something weird is happening, my server is running even though I haven't ran the RUN.bat???

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  7. Offline


    you probly double clicked on the craftbukkit.jar
    open task manager and close any java proccess. sometimes know as java.exe or javaw.exe
  8. Tried that, still running?
  9. Offline


    what do u mean still running? can u c the black window (cmd) with bukkit in it
  10. NO Only things that are running, Google Chrome, Skype, Steam. That's it! I went through the processess, Killed em, got onto MC and I still got onto my server!???
  11. Offline


    you need to leave the server ip blank in server properties
  12. I did that.....
  13. Offline


    Listen i have the same problem but if you leave the ip blank on server properties you then cannot connect to your server
  14. Alright for some reason the server just crashed, and now RUN.bat works, RESOLVED
  15. Offline


    If only that happened to me :(
  16. It runs without it for me.
  17. Offline


    Hmm weird
    -Some people have this port problem it needs to be fixed
  18. Offline


    It can't be fixed, nothing is broken :p
    It's simply telling you the port is already being used, so simply use something else, or ensure your server hasn't crashed and gotten frozen, check to see if java.exe is running, if so, kill it!

    When someone says to use task manager to close or kill a program(like jacklin213 said), it usually means the "Processes" tab.
    For example to kill "java.exe":


    Also do the same with "javaw.exe" if it's there.
  19. Offline


    Whenever you start your server (without the error), you have to type ' stop ' in the console. If you don't, and instead close the window (aka the red x), then your port will still run in the background. The only way to solve that (that I know of) is to restart your computer.

    When you get the 'Failed to Bind to Port' error, then type stop, it will give an error. Just type stop again.
  20. Offline


    When it says failed to bind to port that's when u click x cause sometimes typing stop will give off more errors
  21. Offline


    some other program is already bound to the port
  22. Offline


    Solved that bit already....
  23. Offline


    I didnt read replies....

    To check go to your router page>port

    then it lists what is bound to what port
    (portforwarding page)
    (I don't know much about it, I vaguely remember from when I did this for a friend)
  24. Offline


    solved that too.....
  25. Offline


    ah i see, not only solved in the post but solved by you......
  26. Offline


    lol np ur just trying to help :)
Thread Status:
Not open for further replies.

Share This Page