failed to bind to port

Discussion in 'Bukkit Help' started by baiumbg, Feb 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    baiumbg

    A friend gets the '[WARNING] **** FAILED TO BIND TO PORT!' error. I've tried using lan ip, public ip and blank ip in the server.properties
    There is no java.exe/javaw.exe running in the background and he isn't behind a router. He had a hamachi server before moving to bukkit, and the server was running fine. When I use my lan IP in server.properties I connect only through my LAN ip. When I leave it blank, no one can connect. When I use my own IP, it doesn't even start the server.

    (I did everything through TeamViewer)
     
  2. Offline

    Plague

    Blank is fine, run "nestat -a" to see processes running on ports and check if it really is not used.
     
  3. Offline

    The_Miester

    I have the same problem but im not sure what you mean by "run "nestat -a" to see processes running on ports"
     
  4. Offline

    speeddemon92

    Run a command prompt and type the command "netstat -a" and look for the TCP port 25565. If it is on the list try running the command "netstat -b" to determine what program is using the port so you can kill it then try running the server again.
     
  5. Offline

    The_Miester

    Port 25565 was not on the "netstat -a" list and when I tryed "netstat -b" it just said "The requested operation requires elevation"
     
  6. Offline

    Mikecom32

    What OS are you on? I'm assuming Windows 7 or Vista.

    You need to run the command prompt as an administrator, and then run the netstat commands.
     
  7. Offline

    The_Miester

    Port 25565 was not in either list.
     
  8. Offline

    Mikecom32

    I don't know if it'll make a difference, but is Windows firewall turned off?

    What OS are you running on?
    Antivirus?
     
  9. Offline

    ThePoopfish

    you need to end the java.exe or javaw.exe process that is already running...
     
  10. Offline

    Mikecom32

    If you had actually read the initial post, you would see that had already been covered.
     
  11. Offline

    ThePoopfish

    Sorry this is the 4-5th post today with this problem, sorry for the generic answer.
     
  12. Offline

    Mikecom32

    No worries, I know it gets annoying. It seems every 13 year old out there wants to run a minecraft server.

    (This is not a reference to OP)
     
  13. Offline

    RYB72

    When i type "netstat -a" or "netstat -b" nothing happens. just a bunch of errors pop up and they are the same errors that pop up when i type anything in.
     
  14. Offline

    joster222

    I have the same problem too, yesterday, everything worked fine, but now it also says that i couldnt bind to the port.
    When I putted the command netstat -a I also couldnt find TCP 25565, and when i putted netstat -b, it said that i didnt was admin, but i am admin of my computer... plz someone help me with this problem.
     
  15. Offline

    _EasyTiger_

    I did everything, there is no port running 25565! and I tried again still failed to bind and no java.exe is not running?
     
  16. Offline

    kosica5

    me to i have the same problem
     
  17. Offline

    Lolmewn Retired Staff

    You have to run CMD prompt as admin, type cmd into the search bar, right click, Run as Administrator. It doesn't automatically run in admin for security reasons.
     
  18. Offline

    ghastTrainer

    same problem
    [lava]
    [lava]

    [creeper]
     
  19. Offline

    masterdecs

    What you have to do is leave the field of ip pasava server.propietis to me the same problem as someone fix that omente save.
    PS I traducio with google chrom Spanish that i am not much English.
     
  20. Offline

    stoneminer02

    Same problem!
    Info (open)

    OS: Windows 7 Ultimate
    RAM: Server running with 512M
    Java: Version
    Port forwarded: Yes
    Port bind error: Yes
    Getting all the time: Yes

    Help me!
     
Thread Status:
Not open for further replies.

Share This Page