Problem/Bug Failed to bind port

Discussion in 'Bukkit Help' started by Batkiller, Jan 4, 2021.

  1. Offline

    Batkiller

    I have no idea what have I done wrong... I read some other's ppl threads but I can't find a solution that fits me...

    I have tried using this site: https://www.ipfingerprints.com/portscan.php
    and it says:
    Host is up.
    PORT STATE SERVICE
    25565/tcp filtered minecraft
    So I think the port is open (? not sure)

    There is no other Java process running at the same time (maybe it is not java related programs that is causing this this issue? how can I check?)

    Maybe it is firewall related? (cause in firewall I don't understand anything)

    Well, I am confused and again I have no idea what to do. Your help would be much appreciated.
     

    Attached Files:

  2. Offline

    timtower Administrator Administrator Moderator

    @Batkiller Remove the IP from the server.properties.
     
  3. Offline

    Batkiller

    @timtower There is no IP in the server properties...
     
  4. Offline

    timtower Administrator Administrator Moderator

    @Batkiller Then what is behind the blacked out part? There should be nothing there.
     
  5. Offline

    Batkiller

    Ok, I did that, it works, I am dumb...
    But I can join with localhost IP what ip does my friends use?
    I gave my friend the ipv4 from https://www.whatismyip.com/
    it says to him: failed to connect to the server
    @timtower
     
    Last edited: Jan 5, 2021
  6. Offline

    timtower Administrator Administrator Moderator

    @Batkiller Remove it, however you are adding it, start the server.
    If you need to black out an IP then you are doing it wrong.
     
  7. Offline

    Batkiller

    @timtower Ok, I did that, it works, I am dumb...
    But I can join with localhost IP what ip does my friends use?
    I gave my friend the ipv4 from https://www.whatismyip.com/
    it says to him: failed to connect to the server
     
  8. Offline

    timtower Administrator Administrator Moderator

    @Batkiller The ip you gave him is correct.
    Did you portforward the server? Opened up the firewall and router?
    Can you join with that same IP?
     

Share This Page