Question FactionMobs plugin and possible subtle version incompatibilities

Discussion in 'Bukkit Help' started by coltswalker, Jan 12, 2019 at 10:21 AM.

  1. Offline

    coltswalker

    Question regarding the plugin FactionMobs. If I am asking in the wrong place please advise. Questions specifics in regards to obtaining a clear and concise guide to all correct version of requirement components for Factions and FactionMobs for my server running a legacy version of spigot / craftbukkit.

    I have these plugins running, and core features functional, however, there are some glitches introduced after our upgrade from 1.10.2 to 1.11.2

    Current Versions:
    spigot 1.11.2 craftbukkit 1.11.2

    Factions and FactionMobs, both installed. The issue: although mostly working, it is very glitchy.

    Faction troops are “warpy” in that they appear to be teleporting all of the time even though they are set to stationary (just standing there.)

    1. warpy troops
    2. Naturally spawned iron golems are attacking my factionmob troops.

    Neither of these two items were a problem for me in 1.10.2 and are now plaguing me in 1.11.2

    I upgraded spigot, craftbukkit, factions, factionmobs, massive, etc.

    Also I did my best to locate all of these requirements from their various places of download however I ran into instances where files appearing to be the same version had different file properties such as size and date.

    I think perhaps it is possible I have slight version conflict as there are a number of options alone for FactionMobs related to 1.11.2 and of the three jar files two appear identical in file size.

    It is about as clear as mud exactly what versions of each necessary item are required to achieve symbiosis and exactly where to get them.

    Here are some relevant lines from the log showing versions.

    Please advise on what possible version discrepancies I may be experiencing.

    [20:06:52 INFO]: Starting minecraft server version 1.11.2
    [20:06:53 INFO]: This server is running CraftBukkit version git-Spigot-3fb9445-6e3cec8 (MC: 1.11.2) (Implementing API version 1.11.2-R0.1-SNAPSHOT)
    [20:06:54 INFO]: [PluginConstructorAPI] Loading PluginConstructorAPI v1.0.50
    [20:06:54 INFO]: [Vault] Loading Vault v1.6.6-b${env.TRAVIS_BUILD_NUMBER}
    [20:06:54 INFO]: [MassiveCore] Loading MassiveCore v2.11.0
    [20:06:54 INFO]: [ProtocolLib] Loading ProtocolLib v4.4.0-SNAPSHOT-b403
    [20:06:55 INFO]: [MassiveTickets] Loading MassiveTickets v2.11.0
    [20:06:55 INFO]: [LibsDisguises] Loading LibsDisguises v9.1.2
    [20:06:55 INFO]: [MassiveHat] Loading MassiveHat v2.11.0
    [20:06:55 INFO]: [Factions] Loading Factions v2.11.0
    [20:06:55 INFO]: [FactionMobs] Loading FactionMobs v3.2.1_1.11.2-R0.1
    [20:06:55 INFO]: [ProtectionLib] Loading ProtectionLib v0.9.3
    [20:06:55 INFO]: [MassiveBooks] Loading MassiveBooks v2.11.0
    [20:06:55 INFO]: [Vault] Enabling Vault v1.6.6-b${env.TRAVIS_BUILD_NUMBER}
    [20:06:55 INFO]: [Vault] [Permission] SuperPermissions loaded as backup permission system.
    [20:06:55 INFO]: [Vault] Enabled Version 1.6.6-b${env.TRAVIS_BUILD_NUMBER}
    [20:06:55 INFO]: [MassiveCore] Enabling MassiveCore v2.11.0
    [20:06:57 INFO]: [ProtocolLib] Enabling ProtocolLib v4.4.0-SNAPSHOT-b403
    [20:07:05 INFO]: [MassiveTickets] Enabling MassiveTickets v2.11.0
    [20:07:05 INFO]: [LibsDisguises] Enabling LibsDisguises v9.1.2
    [20:07:05 INFO]: [LibsDisguises] Discovered MC version: v1_11_R1

    To no avail I have spent hours on the Internet searching for an answer. Furthermore I have no interest in updating to 1.13. Finally, if I work all this out I am more than happy to invest my time into donating documentation in helping others with clearing up version conflicts, if that is in fact the source of my trouble.

    Kind regards.
     

Share This Page