Essentials' signs giving a ?4 when doing &4 instead of color!

Discussion in 'Plugin Development' started by foldagerdk, Apr 26, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    foldagerdk

    Sign colors doesn't work for me at the moment.

    Doing &4Test on a sign gives me ?4Test

    Color signs are on the list of enabled signs.

    Signs like [Buy], [Sell], [Disposal] and so on does have colors.

    Other Plugins: (See any conflicts?)
    Show Spoiler
    [​IMG]


    Any solution?
     
  2. Offline

    kumpelblase2

    You should probably ask at the essentials thread and/or bukkitdev page.
     
  3. Offline

    Father Of Time

    If you have recently updated your essentials there are now permission nodes for allowing color text in chat/on signs; I had this same issue when I upgraded my Essentials for 1.2.5.

    Backup your current essentials configuration file and then delete it, then restart the server to generate the newest config file and use your backup as a "template" to reconfigure the newly generated file.

    Hope this helps, good luck!
     
  4. Offline

    foldagerdk

    I did :/
    Still no answer :(

    I have the asterisk node in PEX.
    But I'll try and reset my config :)
     
  5. Offline

    dsmyth1915

    Lol @illish0704, copy paste much? I suggest doing as Father of Time said, if that fixes it good luck, if not just come on back.
     
  6. Offline

    foldagerdk

    I'll add a plugin list
     
  7. Offline

    polarisity

    Here's what you should do. Never give yourself * permissions. This messes up the plugin configurations.

    I had the same problem when i had * permissions. I set myself to default and only gave myself the essentials.signs.color permission. And this worked.

    I suggest you manually type in only the permissions you want. If you're unsure about anything, dont put it in. For example, you could always give yourself permissions like essentials.*, worldguard.*.

    Edit: It seems like its a conflict within essentials. I tried giving myself the essentials.* permission and it doesnt work either. Looks like you'll have to manually type out the essentials permission nodes. I'm trying to solve this problem too.
     
  8. Offline

    foldagerdk

    Damn :/
    I was hoping that wasn't the case :/
    Thanks anyways @polarisity :)
     
  9. Offline

    polarisity

    Oh i think your problem is deadbolt. Deadbolt has an inbuilt sign colour function. Try giving yourself all permissions for deadbolt except the sign colour node. It worked for me.
     
Thread Status:
Not open for further replies.

Share This Page