Solved Essentials Config.yml keeps resetting

Discussion in 'Bukkit Help' started by arourke0299, Sep 6, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hey guys, (sorry about all these posts :p) this is'nt too much of an urgent issue, but i'd really like tofix it, as i am setting up a server economy. I have the $ st up, and the other things, but the [Buy], [Sell], and [Trade] signs don't work. I believe this is because the Essentials Config.yml file keeps reverting to its previous state after i edit the file. I change the # in front of the sign so it isn't there, and go on my server. I set up a sign and it "works", until i reloa it, then it becomes reverted back to having the # in front of the signs. Any help? Again, this isn't a server threatening issue, but i still one that hinders a lot of potential in my server. Thanks so much! :)
  2. Offline


    It may be due to incorrect syntax. Make sure there are no tabs (replace with 4 spaces).
    Also are you using the /reload command? That's bad practice. Restart the server or have Essentials reload the config with /essentials reload.
  3. Offline


    Yes, if your config isn't correctly layed out, it will reset to its original state. Just use the new one config that one the way you like it and than when ever you decide to config it again, make a backup before hand so i something goes wrong.
  4. Offline


    Ok, I think I fixed it. Another plugging seemed to be messing something up. I looked through the startup log and it said [info] sign shop enabled, resetting essentials config file. I'm nit sure why this was happening, but I removed sign shop (lately I haven't been using it anyway) I'm not quite sure if this allows the use of the signs yet, but I'll know by the end of today. It is fixed! :D
  5. Offline


    Having this problem too. I don't want to remove sign shop but i might have to.
  6. Offline


    Yes, i'm not sure why it is resetting. The Essentials config file usually only resets when there is an error in it. I've seen sign shop working correctly before, my guess is that another plugin is conflicting with it. It is very helpful if you also list your plugins. That way, people may know what plugin causes the issue.
  7. Offline


    It seems that the "Sign Shop" plugin was somehow conflicting with the essentials signs. It said in the info that the sign shop was root resetting, but just disabling the signs used by essentials. I removed sign shop and now everything seems to be working fine.
  8. Offline


    My essentials config.yml file is messed up it says this


    I've tried alot of things but nothing works PLEASE HELP ME
Thread Status:
Not open for further replies.

Share This Page