Problem/Bug essential plugin not working (an internal error occurred while attempting to perform this command)

Discussion in 'Bukkit Help' started by shoter10, Dec 12, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    shoter10

    I played with the plugin essential but it seems that he doesn't work when I send a command like /gm it's said this (an internal error occurred while attempting to perform this command)
    in the console, it's said this

    [21:34:42] [Server thread/INFO]: Time elapsed: 1771 ms
    [21:34:42] [Server thread/INFO]: [PermissionsEx] Enabling PermissionsEx v1.23.4
    [21:34:42] [Server thread/INFO]: [PermissionsEx] Initializing file backend
    [21:34:42] [Server thread/INFO]: [PermissionsEx] Permissions file successfully reloaded
    [21:34:42] [Server thread/INFO]: [Vault][Permission] PermissionsEx hooked.
    [21:34:42] [Server thread/INFO]: [Vault] [Vault][Chat] PermissionsEx_Chat hooked.
    [21:34:42] [Server thread/INFO]: [Essentials] Enabling Essentials v2.9.5
    [21:34:42] [Server thread/INFO]: Le format de la version de Bukkit a ÚtÚ changÚ. La version n''a pas ÚtÚ vÚrifiÚe.
    [21:34:42] [Server thread/INFO]: git-Spigot-9de398a-9c887d4 (MC: 1.14.4)
    [21:34:42] [Server thread/INFO]: 1.14.4-R0.1-SNAPSHOT
    [21:34:42] [Server thread/ERROR]: Error occurred while enabling Essentials v2.9.5 (Is it up to date?)
    java.lang.NoSuchMethodError: com.google.common.cache.CacheBuilder.build(Lcom/google/common/cache/CacheLoader;)Lcom/google/common/cache/Cache;
    at com.earth2me.essentials.UserMap.<init>(UserMap.java:18) ~[?:?]
    at com.earth2me.essentials.Essentials.onEnable(Essentials.java:168) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:352) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:417) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugin(CraftServer.java:461) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugins(CraftServer.java:375) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:449) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:258) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:776) [spigot.jar:git-Spigot-9de398a-9c887d4]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_201]
    [21:34:42] [Server thread/INFO]: [Vault] [Vault][Economy] Essentials Economy hooked.
    [21:34:42] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [21:34:42] [Server thread/INFO]: Done (23.138s)! For help, type "help"
    [21:34:42] [Craft Scheduler Thread - 1/INFO]: [Vault] Checking for Updates ...
    [21:34:43] [Craft Scheduler Thread - 1/INFO]: [Vault] No new version available

    I don't know how to fix this I need help thank you
     
Thread Status:
Not open for further replies.

Share This Page