Error when exporting plugin on server

Discussion in 'Plugin Development' started by MiBB3L, Sep 10, 2020.

  1. Offline

    MiBB3L

    Can someone help me? I wanted to export a plugin on a server and this error code appears:
    Code:
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/mibbel/test/Main has been compiled by a more recent version of the Java Runtime (class file version 58.0), this version of the Java Runtime only recognizes class file versions up to 52.0
     
  2. Offline

    Kars

    Did you read the error? Update your Java.
     
  3. Offline

    Luckstern

    You could do what @Kars said or you could just use java 8 to compile the plugin. That’s what I use. I had the problem in the beginning, but once I degraded to Java 8 JDK, it worked perfectly.
     
  4. Offline

    JavaNoob

    You just have to update your jdk. I use 12, but anything below that will work too I believe.
    Or if you already have a compatible jdk downloaded, then make sure that the IDE that you are using has the right version selected to use.
     

Share This Page