error: unable to access Jarfile C:\users\user\document\CraftBukkit\craftbukkit.jar

Discussion in 'Bukkit Help' started by bigmac2130, Jun 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    bigmac2130

    whenever i try to runmy server it ccomes up with this
    error: unable to access Jarfile C:\users\user\document\CraftBukkit\craftbukkit.jar
    i have craftbukkit, im using windows 7, i also used the auto installer, help plz
    [pig] [creeper]
    thnx

    help help help plzzzzzzz

    :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 26, 2016
  2. Offline

    Liger_XT5

    Impatient a bit are you? This is not a chat room. This is a message board. Make a thread/post, wait an hour or two. Then check back.

    Good things come to people who wait.
     
  3. Offline

    bigmac2130

    kk thnx man
     
  4. Offline

    TboneBlack

    did some one end up helping you with this yet if so could you tell me because iam getting the same error
     
  5. Beside the fact that as far as I am aware that error is sort of self explanatory I will explain it for you.
    All that is saying is that it can't find the craftbukkit.jar file. To fix the issue:
    - right click on your .bat file, and open with notepad or notepad++ and see what the .jar file is being called in there. It should be craftbukkit.jar
    - Then look in the root of your server and see if you jar file is called that.
    So basically make sure the .jar file is in your server root and also make sure it is named correctly.
     
  6. also make sure that you actually have a craftbukkit jar file
     
  7. Offline

    TboneBlack

    ok i tried what you guys said but it is now just saying unable to access jarfile craftbukkit.jar do i need to have my port open or something like that
     
  8. no, it means it cant find craftbukkit.jar. So open up your server folder, and make sure your craftbukkit file is named craftbukkit.jar and not craftbukkit-1.2.5-R4.0.jar or something
     
  9. Offline

    TboneBlack

    ya it's named craftbukkit.jar iam really don't know whats wrong maby my computer can't run a server or at lest thats what iam thinking now thanks for your help but iam probly just going to give up on this thing now
     
  10. before you give up, do you normally see file extensions on your files?
    Do you see "worddocument.doc" or just "worddocument"
    If you see the second one, then rename "craftbukkit.jar" to just "craftbukkit"
     
  11. Offline

    callmederp

    Hey please help me out.. it does not seem to have a .jar file at all for me to work with.
     
  12. Screenshot the folder.
     
  13. Offline

    callmederp

    Hold on a second. Also I have a question.. would this server work with cracked versions that I have used to connect to normal servers before? And my Craftbukkit folder has 16 files in it. Not sure if I am missing some.

    View attachment 10010 This is what I have.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 26, 2016
  14. you're missing the damn craftbukkit file :p
    Why don't you go get that first??
    http://dl.bukkit.org
    download it and save it as "craftbukkit.jar"
     
  15. Offline

    callmederp

  16. do this get the craftbukkit.jar file and put it in a new folder.
    open notepad or notepad++ and put this in. make sure u have java 7
    Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
    PAUSE
     
  17. Offline

    callmederp

    I did name the file craftbukkit.jar so I will try out Jacklin's idea.
     
  18. Offline

    TnT Retired Staff

    Make sure, if you are naming the file craftbukkit.jar that you can SEE FILE EXTENSIONS.

    So many times people forget that they have file extensions hidden, and as a result have their file named craftbukkit.jar.jar.
     
  19. Offline

    SeraphMoonblade

    How would you go about enabling file extentions?
     
  20. go to control panel and go to Folder options then go to the view tab and find the one which says "hide extensions for know type files" and untick it
     
Thread Status:
Not open for further replies.

Share This Page