Solved Error: that kit is improperly defined. contact an administrator

Discussion in 'Bukkit Help' started by EliasEriksen, Jan 23, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    EliasEriksen

    I need help with essentials. I added a kit called "A" for my prison and I got this error: "that kit is improperly defined. contact an administrator" when I typed "/kit A" I made the kit with ingame commands. Since it didnt work I went in the kit.yml file and deleted the kit. After that it seems like nothing in kits are working. I cant even get the standard kits to work. (for example "/kit Dtools". I get the same error. Hope anyone have a solution for this.
     
  2. Offline

    timtower Moderator Moderator

  3. Offline

    EliasEriksen

    Last edited: Jan 23, 2019
  4. Offline

    timtower Moderator Moderator

    @EliasEriksen Line 12 tm 15, why do the item names have a d in front?
     
  5. Offline

    EliasEriksen

    @timtower I dont know. I think thats standard. Should I remove the "d"? I havent edited anyone of them
     
  6. Offline

    timtower Moderator Moderator

    Yes, the d's must go there, it is an item name, don't know any items like dpickaxe.
     
  7. Offline

    EliasEriksen

    @timtower I took away the d's and the "l" before helm. But still the same error

    What happens if I delete the kit file? Will it generate a new one or will essentials not work?
     
  8. Offline

    timtower Moderator Moderator

    Did you restart the server? Could you post the new kits and logs?
     
  9. Offline

    EliasEriksen

  10. Offline

    timtower Moderator Moderator

    @EliasEriksen 13:40:54] [Server thread/ERROR]: [Essentials] You are running an unsupported server version!
    I think that you need to fix that first.
     
  11. Offline

    EliasEriksen

    @timtower Which version do I need then? It says it supports 1.10...
     
  12. Offline

    timtower Moderator Moderator

    Don't know, I try to stay away from Essentials
     
  13. Offline

    EliasEriksen

    @timtower hmmm. Should I delete essentials and download another version? Because essentials is a really handy plugin...

    Which plugins are you using instead of essentials for stuff essentials do?

    @timtower Okay, I changed version to EssentialsX 2.0.1-b370. Now the kits are working. Thanks a lot!!

    I am a noob at minecraft server stuff. I want to make a server with some minigames and stuff. Do you have any tips for me on running a server? Is there any musthave plugins that every server should have? I want as much tips as possible :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jan 23, 2019
  14. Offline

    timtower Moderator Moderator

    @EliasEriksen I do have a couple.
    1. Start small, don't put in 50 plugins
    2. Finish configuring 1 plugin before you add the next one, especially regarding permissions
    3. Make a server that makes YOU happy when playing on it. After all it is your server.
     
  15. Offline

    EliasEriksen

    @timtower Okay, thanks! Thanks for the help and sorry for your time waste. I will keep those in mind!
     
  16. Offline

    timtower Moderator Moderator

    Time enjoyed wasting is not wasted time ;)
    Have fun with your server!
     
Thread Status:
Not open for further replies.

Share This Page