Solved Error occurred during initialization of VM

Discussion in 'Bukkit Help' started by T04ST3DMinecraft, Jan 30, 2014.

Thread Status:
Not open for further replies.
  1. Hi all, I decided to start a minecraft server on a relatively older computer. I'm running Windows XP service pack 3 with a 32 bit system and have 4GB of ram. My problem is that whenever I double click on the run.bat I get this error message:
    The code inside the run.bat is set to:
    If you need any other information, just let me know but make sure you tag me
  2. Offline


    Try running it like this:
    java -Xmx2000M -XX:permSize=256m -XX:MaxPermSize=512m -server -Xincgc -jar craftbukkit.jar -o true

    Are you sure your Java installation is up to date? Is your CPU 64 bit? In that case, you should install a 64 bit OS, because 32 bit Java can't use as much memory as 64 bit.
  3. darn it you got here before me :p
  4. what is supposed to go where it put the :p ?

    fafler what's supposed to go where the :p is?
  5. Offline


    Use this:

    java -Xms1536M -Xmx1536M -jar craftbukkit.jar -o true

    That's the best you can do with a 32-bit system.
  6. Offline


    One thing is that I'm thinking is that you need more ram or give the server more ram and also update your java if you can
  7. Offline


        java -Xmx2000M -XX:PermSize=256m -XX:MaxPermSize=512m -server -Xincgc -jar craftbukkit.jar -o true
    More RAM won't work. Windows XP 32 bit is only able to access around 3.5 gb out of the 4 he already has, without changing to a PAE kernel and even in that case, java wont be able to claim more than around 2.5 gb or something.
  8. Offline


    Just don't try to play on the same computer, or it will crash, with only 4 GB
  9. Bobcat00 fafler I tried both of your codes and Bobcat00 's stayed up for about a second and then crashed and fafler 's just crashed right away
  10. Offline


    Anything in the log file?
  11. Bobcat00 I don't have a log file, the only files that have loaded are the ones that I put in there
  12. I fixed the problem thanks for all your help and effort. The code I ended up using was straight off the bukkit wiki: (for those who have the same problem) or if you're feeling lazy:
    java -Xmx1024M -jar craftbukkit.jar -o true
Thread Status:
Not open for further replies.

Share This Page