Inactive [EDIT] NanoBot v1.39 - Edit Structures, Landscapes and more [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Moon_werewolf, Jul 11, 2011.

  1. Offline


    NanoBot - Edit Structures, Landscapes and more

    Version: 1.39
    craftbukkit: 1.2.5-R1.0


    NanoBot is a plugin that is able to change, copy, move, remove and rotate Structures and Landscapes. When someone uploads a structure by default, it will appear on this webpage:

    Test server: Offline, Waiting for new server computer. (2012-04-25)
    On the nanobot test server the latest build of nanobot is installed. there very one is allowed to test nanobot. the worlds resets every hour so do what you please. the server is off 3 - 4 minutes on every restart

    nanobot demonstration:

    nanobot tools

    Sumbitted Video or Others (open)




    Latest version
    NanoBot.jar (Alt)

    Ops the upload server is only for them that can code PHP and MySQL (alt)

    Here can you find older versions:

    1. Download
    2. put nanobots.jar in plugin folder
    3. Remove the old nanobots.jar file
    How to use:
    After the plugin is installed run the server or reload it, then got the nanobot folder that is the plugin and then open up the settings.yml file and under premission there are some settings for see how is allowed to use the mod

    op = minecraft own op system
    playerList = all users that going to beable to use the mod most be listed in allowPlayers.txt
    premission = if the server has some other permission plugin you can enable that setting to use that plugin instead

    then the permissions are sorted out restart or reload the server , Enter a command in the chat then hit a block with a empty hand

    nanobot.nanobot = allow the use of nanobot = allow download from a web server
    nanobot.upload = allow upload a structure to a web server
    nanobot.load = allow loading a structure from a file and place it

    The modes are
    Color = Edit only block with the same color (wool)
    Ground = Edit every block that the world generator can make (except bedrock)
    Normal = Edit block of the same type as the fist one you hit
    Structures = Edit structures
    All = Edit all blocks except air and bedrock
    • /nano remove [mode] [amount]
      • Remove blocks
    • /nano copy [mode] [amount]
      • Copy blocks
    • /nano move [mode] [amount]
      • Move blocks
    • /nano change <id> [mode] [amount]
      • Change blocks to something else (like dirt to grass)
    • /nano change <id>:<color> [mode] [amount]
      • Change block to something else but support color
      • /nano change 35:red (change something to red wool)
    • /nano fill <id> [amount]
      • Fill holes
    • /nano rotate <90|180|270>
      • allows the player to rotate structures or landscapes
    • /nano <save|load> <filename> [mode] [amount]
      • Save and load Structures or Landscapes from a file
    • /nano upload <filename> [mode] [amount]
      • Upload a structure to a public site where it can be downloaded
    • /nano download <filename> <id>
      • Download a structure from the public site (then use /nano load)
    • /nano tools [tool name]
      • See a list of all tools avaiable or see more info about one tool
    • /nano select [mode] [amount]
      • Selecting a structure or landscape
    • /nano <toss|info|cancel|undo>
      • Stand in water or lava and use Toss to use the nanobot on water
      • Info allows the player to see the information about the nano like then it is done
      • Cancel quits the operation the nanobot are assign to
      • Undo are just like it sound it undo that players last edit with he/she did with the nanobots
    Commands advance:

    now in a command can players use +<block id> to add and -<block id> to remove blocks that aren't on the scan list like
    /nano copy +1 s 1000 will now also copy smooth stone

    I want to thank @Flabaliki for helping with Bug testing the plugin

    Know bugs:
    • Stairs, Signs and other block don't rotate correctly

    full change list (open)

    Version 1.31
    * Select tool works with /nano change

    Version 1.3
    * Players get now the right amount of block edited
    * Color and All mode added
    * Snow layer are now ignored
    * Selection tool added (set id in tools.yml)
    * Some changes to scanning and editing codes
    * Permission bug fixed
    * Sand and Gravel that has been scanned don't fall
    * Config crash fix
    * The throw command now works on water and lava
    * Structures and landscape can now be rotate while move or copying
    * Support for the whole mode name
    * Fixed some bugs with the + and - system

    Version 1.25
    * Fixed a problem with item on walls fell of then they where loaded
    * Redstone torches now rotate correctly
    * Things on walls (torches, sign and more) do not change with the command change
    * Flowers and pistons now count as a on wall block

    Version 1.22 (Hotfix)
    * Fixed the special command -<block id> for real
    * Fixed torches and steps being rotated correctly
    * Fixed a bug that caused the tools to not work

    Version 1.2
    * Change .properties file to .yml
    * File being converted automatically
    * Small order now getting instantly completed
    * Added a blueprint tool
    * Fixed folder rename bug
    * Fixed the special command -<block id>
    * Changed Allowed blocks to disallowed blocks

    Version 1.1 (hotfix)
    * Permissions work as they should

    Version 1.0
    * Better scan code
    * Better edit code
    * Added nanobot tools
    * Added allowMaterial in options
    * Added command /nano select
    * Added progress messages
    * Changed /nano rotate
    * Fixed /nano move so it can now move things with out messing them up
    * Added /nano tools to see all tools

    Version 0.81 (hotfix)
    * Fixed the permissions
    * Fixed Save and upload functions
    * Added /nano fill in help

    Version 0.8
    * Added /nano fill
    * Added english number format
    * Added -diagonal
    * Added permissions
    * Change max number of block to edit every second from 250 to 2500
    * Some performance changes
    * Blocked some blocks in the commands
    * Remove the old nanobots.jar file
    Version 0.7
    * Fixed new scan code
    * Added -up and +down
    * Now can nanobot scan air (if +0 are used)

    Version 0.6
    * Fixed amount problem then saving
    * Change upload file location to temp folder

    Version 0.56
    * Fixed undo problem
    * Fixed load problem
    Version 0.55
    * Tried to fix the undo bug (i can't test it for i don't have that bug)
    * Fixed the nano rotate error
    * added new options needPermissionFile and needOp
    Version 0.5
    * Added a experimental setting that stops things from spreading while nanobots work
    * Fixed a loop issue
    * Fixed so - and + option works again
    * Fixed undo so it now should work correctly
    * Fixed so toss works again
    * Fixed some compatibility issues

    Version 0.45
    * Fixed for bukkit build 1000
    * Some performance issues fixed
    * Increased scan speed
    * Some new options added

    Version 0.41
    * Fixed a error that broke the hole plugin

    Version 0.4
    * Added upload function
    * Added download function
    * Added more advance options
    * Added setting file
    Version 0.3
    *Nanobot now logs in the server log
    * who, where and when someone uses the mod
    * Now do the undo file get created when the server shutdown
    Added some missing commands in /nano help
    Added leaves (18) in ground mode

    Version 0.2
    * First release
  2. Offline


    thx, I'm working on fixing those problems with models not sticking to walls, 1.25 should fix some but i think it is still some left

    I'm currently working on a program that i can use to approve or disapprove a structure and then i shows the next one but it will take some time to make
  3. Offline


    I am having 2 problems,
    1.When i download a building using the website, (in this case an Inn) I can place the building but i cannot rotate the building once i've put it down. i understand that i have to /nano move or copy, The Error i get is "You need to wait until the Nanobots are one." But, the building is complete.
    2.If you paste a building and use the /nano undo, and you try to undo the 2nd to last building you put down, it undo's your last undo. maybe a /nano redo is in order? Thanks!
  4. Offline


    Hey i noticed now that when filling an area, if torches are in the area to be filled, they turn to wood or sandstone

    Also, i have no idea why this is happening, but im filling in a long hallway floor, and it striped wood and stone at some points. i was using the double stone slab block (id 43) , there was nothing in the way of it (like torches) and ive never seen this before...

    it was like this:
    (Brick, Wood, Stone, Cobble)


    and no matter how many times i undid it and retried, the same happened.
    Edit: i just broke them to find out they are double wood slabs and double cobble slabs
    Edit2: and now when filling another floor area along side it but several blocks away, the exact same two "lines" were wood slabs and cobble slabs (z -55 wood, and z -46 cobble, incase its relevant).
    edit3: filling in 1 block higher and they were different lines (z -54 was wood, and -47 was cobble). and if any of the 3 were nano changed, they all changed, and if changed back to a slab or double slab, the wood and cobble reappeared.
  5. sorry I cant use this, i keep getting a message saying sorry i cant use this mod, perhaps its because of a typo? premission:
    op: false
    playerList: false
    premission: true
  6. Offline


    I love this Plugin, have been using it on my server for a few days now, I do have 1 issue I've found.

    I was attempting to create a rail system from 1 town to another and I found that the nanobot wasn't copy/pasting the powered rails or the detector rails, normal rails seem to copy without issue, I was wondering if this is intended or not and if there is a way around this.

    In the mean time great work!
  7. Offline


    i don't know, i think i just forgot to add the other rails in the scanning array, what you can test to do is add +27 +28 after /nano then just write the rest of the command like normal
  8. Offline


    Just wanted to say love the mod. Been using it a lot.
  9. Offline


    That work exceedingly well, thank you. :D
  10. Offline


    I love the concept of this plugin, it definitely seems wonderful just to be able to "copy/paste" buildings, modify the materials so easily, etcetera... But I can't get it to work. Every time I try, I simply get "sorry you can't use this mod! :(".

    Before you ask, yes, I'm in the allowPlayers.txt, I'm the only Op on the server, and I have Admin level permissions. I've tried every combination of tweaking the settings.yml for false/true on each requirement, and no matter how it's set up, it still gives me the same error. And I restart the server entirely after each change, so it's not that I'm not reloading it.

    Any ideas? Is it simply incompatible with Essentials, just like WorldEdit is?
  11. Offline


    i was rotating a building today when suddenly the undo part of nanobot stopped working. when i typed /nano undo just nothign would happen. after resetting the server it worked fine. the log showed this error:

    2011-09-03 08:55:23 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 4
    2011-09-03 08:55:23 [SEVERE] at
    2011-09-03 08:55:23 [SEVERE] at com.moon_werewolf.nanobot.NanoMemmory.setExtraData(
    2011-09-03 08:55:23 [SEVERE] at com.moon_werewolf.nanobot.NanoFamily.load(
    2011-09-03 08:55:23 [SEVERE] at
    2011-09-03 08:55:23 [SEVERE] at
    2011-09-03 08:55:23 [SEVERE] at com.moon_werewolf.nanobot.Nanobot.onCommand(
    2011-09-03 08:55:23 [SEVERE] at org.bukkit.command.PluginCommand.execute(
    2011-09-03 08:55:23 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-09-03 08:55:23 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(
    2011-09-03 08:55:23 [SEVERE] at
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.Packet3Chat.a(
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.NetworkManager.b(
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-09-03 08:55:23 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-09-03 08:55:23 [SEVERE] at
    2011-09-03 08:55:23 [SEVERE] at
  12. Offline


    i'm curious if there are ways to do a few things with nano.

    1) limit how far it goes. so for example i only want to clear 20 blocks in front of me, can i make it to do that? right now it will just clear from the block i hit up and until it hits the block limit i set (10k default).

    2) just replace blocks up, not in. example would be a cliff face. i'd like to change all the stone to soil without it scanning into the mountain to the other side. i'm familiar with the up/down command, i use it constantly to fill in creeper damage and other things, but trying left right foward front or any of those don't work.
  13. Offline


    (bukkit verson 1060)
    hmm when ever i do /nano i get this

    an internal error occurred...........................

    23:39:45 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'nano' in plugin Nanobot v1.25
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NoSuchMethodError: org.bukkit.entity.Player.hasPermission(Ljava/lang/String;)Z
    at com.moon_werewolf.nanobot.Nanobot.playerIsAllowed(
    at com.moon_werewolf.nanobot.Nanobot.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more
  14. Offline


    'sorry you are unable to use this mod :(' appears in chat..
  15. Offline


    are you op and write your usename in allowPlayers ?
  16. Offline


    'Sorry you can't use this mod :(' actually

    Oh, allowPlayers - ok thanks.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  17. Offline


    This time when undo crapped out on me i got:

    2011-09-04 21:28:01 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 1
    2011-09-04 21:28:01 [SEVERE] at
    2011-09-04 21:28:01 [SEVERE] at com.moon_werewolf.nanobot.NanoMemmory.setExtraData(
    2011-09-04 21:28:01 [SEVERE] at com.moon_werewolf.nanobot.NanoFamily.load(
    2011-09-04 21:28:01 [SEVERE] at
    2011-09-04 21:28:01 [SEVERE] at
    2011-09-04 21:28:01 [SEVERE] at com.moon_werewolf.nanobot.Nanobot.onCommand(
    2011-09-04 21:28:01 [SEVERE] at org.bukkit.command.PluginCommand.execute(
    2011-09-04 21:28:01 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-09-04 21:28:01 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(
    2011-09-04 21:28:01 [SEVERE] at
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.Packet3Chat.a(
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.NetworkManager.b(
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-09-04 21:28:01 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-09-04 21:28:01 [SEVERE] at
    2011-09-04 21:28:01 [SEVERE] at
  18. Offline


    Fixed the problem on my end. I retyped "premission" as "permission" in the settings.yml on both errors, and set all to true. Worked fine.

    However, I've found that if "allowPlayers" is set to false, it won't work at all, even if you're an op and Admin in permissions. Or at least, it won't for me. That's rather disappointing, and defeats the purpose of even needing permissions / op status in the first place.
  19. Offline


    Ops, glad that you said that, i going to fix on the next version
  20. Offline


    No problem at all. Once I got the plugin working, I've found it incredibly convenient. I haven't figured out how it works entirely -- the Structure mode is rather confusing and seems to only let me copy one single block -- but I've found several uses for it at the very least. I can build structures really fast just by copy/pasting parts at a time together.

    Definitely a useful plugin, one I'll be keeping on my server.
  21. Offline


    Structure mode is the block that only can be crafted (like planks, cobblestone, chests, and more) you can also use "/nano copy +18" and if you hit a log of a tree the leaves will also be copied
  22. Offline


    21:28:41 [SEVERE] Error occurred while enabling Nanobot v1.25 (Is it up to date?
    ): null
    at com.moon_werewolf.nanobot.Config.readStringList(
    at com.moon_werewolf.nanobot.NanoToolListener.loadAllTools(NanoToolListe
    at com.moon_werewolf.nanobot.Nanobot.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(

    hmm??? outdated?!?
  23. Offline


    i thought trees and leaves were already in that category? if not when did that change?

    Also: " Structures and landscape can now be rotate while move or copying"
    THANK YOU! i so missed that.
  24. Offline


    tree and leaves are but not in normal mode. np :) other has miss that to so i took some time and added it back in
  25. Offline


    how do i select a area and move it somewhere else. For example i want to copy my entire island and put it somewhere else. How do i do that?
  26. Offline


    you can use /nano move [mode] [amount] or use the select tool and use it to move a but structure or island

    how to use select tool
    1. use /nano move
    2 hit the lowest point
    3. hit the point on the other side of what you want to move
    4. hit the highest/lowest point of what you want to move
    5. hit the point you want to move it to (ps the "start" point is the first block you hited)
  27. Offline

    tha d0ctor

    I wish there was a way that you could view a preview image of the saved file on the website script u gave
  28. Offline


    i really want a 3D model viewer applet on the website but i can't nothing about 3D in java :(
  29. Offline

    tha d0ctor

  30. Offline


    For those using Nanobot, you don't have to upload your structure you can just save it normally it stores it under the nanobot plugin under build and you can then just load it from there with normal commands if you have a cool structure then you can upload it and the rest of the community can use it.

    If you upload half complete projects it will eventually become a job to sort through all the structures finding the ones that can actually be used and are in fact workable structures.

    Good tip on capturing structures /nano save name s for structure just dig all around and under your structure then stand in front of it and touch the lowest block with your hand this will capture structure nanobot does not capture blacks beneath the block you selected only works up and will capture anything that touches the block until max limit has been reached if you digged out around the structure then it will only select your structure this is just a sure way of making sure you get the whole structure

    When you want to place the structure /nano load name s then make sure you digged a block beneath or infont of you and touch the block below and will perfectly place your structure another tip clear the land before placing because it didn't capture air which means if there where objects in front of you those objects will be embedded into your new structure.

    Just thought I add this for those just starting out took me some time to figure it out and video does not really show or explain how the capturing really takes place.
  31. Offline


    Thx so much :D i finally took some time and reading some tutorials and finally a model viewer are being made, so far it is just wireframe but I'm working on it :)

Share This Page