[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. /beginrant
    First off, I appologize in advance for being a dick. If you have the same issue as another user, before replying with your most recent message, you should have read and noted that both myself and @Maxis010 have provided solutions to this problem(Fern Reply 1, Fern Reply 2, Maxis Reply). I would also like to note that this is, and has been determined not to be a MultiVerse issue. But I'll humor you.

    There is something wrong with one of your Permissions YML files, it could be spacing, it could be an invalid character.

    Please make posts much less ambiguous in the future, this thread gets almost 30 replies per day and keeping up with the order of threads is basically impossible. If you're going to post that you have the same error as another user, please tag them using the @, or quote the post that contains the same error.

    There are a bunch of people that are glad to help out in this thread, but no one likes wasting time.

    Thanks! One more request(should have asked the first time) could you post the console log with the errors?
    Also version numbers (CB, MultiVerse, Permissions)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. @fernferret and @Multiverse
    i think i just got the elusive player_move error logged at startup. let me edit the log and i'll pastebin it here :p
  4. kk... well, console is mainly following this post pattern in THIS topic. (I get errors for Hero chat, NoCheat, LWC, worldguard/edit, which is the majority of the mods i've got.
    CB is 740, multiverse is 1.6.3, permissions is 2.7.2, herochat is 4.10 (i keep everything up to date with recommended builds... or try to).

    Sorry for not posting the ifno with the first error XD rofl... i normally do>.>

    i have no idea why its not working.. permissions is just refusing to recognize any worlds that are created not-by the default generation of a world (so far, i've tested an OLD multiplayer map, which works, and a single player world, which doesn't work, as well as new worlds generated by multiverse--which dont work).

    To me, it sounds like something within the world property file that tells permissions what is actually a world.... and multiverse doesn't seem to tell permissions correctly when its generated.

    Also, other basic troubleshooting techniques:: i HAVE restarted the server, to try and get permissions to work.
    Secondly, (idk if i said this here yet), when i do /permissions -reload world3 , it says world3 doesn't exist.... >.>
  5. what is the output of your /mvlist? does it contain world3? Do you have a world3.yml file in your permissions directory?
  6. yes... it contains 'world3' ... and i have a world3.yml in my permissions directory.... however, when i do /permissions -reload world3 , it says [Permissions] world3 does not exist
  7. Offline


    Both times i got this plugin to work they stopped working after 1 tp , now i just get errors.
    'An internal error has occured while perform this command' or i cant get 'permissions not enabled'

    Tried CB733 + CB740 (I havnt managed to get 740 to work at all)
    Tried latest Permissions plugin and minimum plugins.

    Heres the internal error log...

    2011-05-04 19:11:53 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvtp' in plugin MultiVerse v1.6.3
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:675)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:638)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:632)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: while parsing a block collection
    in "<reader>", line 103, column 13:
    - 'essentials.tp'
    expected <block end>, but found Scalar
    in "<reader>", line 122, column 16:
    - 'multiverse.portal.create'

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(ParserImpl.java:520)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:203)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfiguration.java:58)
    at com.nijiko.permissions.Control.load(Control.java:140)
    at com.nijiko.permissions.Control.loadWorld(Control.java:105)
    at com.nijiko.permissions.Control.permission(Control.java:288)
    at com.nijiko.permissions.Control.has(Control.java:253)
    at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:244)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    Could i get the developer to setup it on my server cos ive wated enough time on it.
  8. Offline


    Thats an issue with your permissions .yml config. You need a space in there. Look at the part bolded.

    19:52:12 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    java.lang.NoClassDefFoundError: com/nijiko/coelho/iConomy/iConomy
            at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:298)
            at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:242)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:130)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    This seems to conflict with Iconomy 5.0. Can you take a look?


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  9. @fernferret

    idk if this has anything to do with anything, but if i am not in world3, it gives that world3 doesn't exist when i try to reload with /permissions -reload world3 .... however, if i am in the world, and i try to do /permissions -reload world3, it says an internal error occurred (in the pink text)
    I tried it with someone else standing in world3, and i did /permissions -reload world3 , and it says that world3 doesn't exist...

    I dont know how permissions works well enough to diagnose why me being in the world would screw it up... but meh
  10. Offline


    I feel stupid now lol. thanks. and i just make those in the same directory right?
  11. Offline


    I dont understand what you mean can you post a working world.yml file
  12. yep, they should all be in /plugins/Permissions/

    What does /permissions -reload all say. Also have you asked in the permissions thread about this? This is sounding more and more like a permissions issue and less of a MV issue.
  13. Offline

    Matt Phillips

    Hey, read through the forums as much as I can take, couldn't find any help really...
    Found a bunch of the same error just not at the same location as mine is occurring.

    null; mapping values are not allowed here
    in "<reader>", line 3, column 35:
    animals: true spawn: -89:75:-98:191.70795:33.75696
    the arrow is under the : next to spawn if that helps.
    absolutely everything i have, mods, mc and bukkit are all freshly updated

    any suggestions?
    please and thank you =D
            animals: true        spawn: -89:75:98:191.70795:33.75696
            price: 0.0
            mobs: false
            environment: NORMAL
            pvp: true
            alias: ''
            worldBlacklist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            animals: true        spawn: 1:69:-7:-354.25476:19.764212
            price: 0.0
            mobs: true
            environment: NETHER
            pvp: false
            alias: ''
            worldBlacklist: ''
            playerBlacklist: ''
            playerWhitelist: ''
  14. lol... yeah... i posted in permissions, and then 15 other people posted ahead of me XD ... the only problem i have is with worlds that THIS plugin creates. Any worlds created by minecraft works just fine :p

    When i do /permissions -reload all , it says [Permissions] World Reloads completed.... and the permissions still hasn't loaded properly for worlds created by MV (other worlds that i have imported are working fine)
  15. Offline


    go to your world file and find - 'multiverse.portal.create'
    Now check the spaces, and symbols for that line and the surrounding lines as permissions is reporting a format error
    If you can't work it out then send me your world.yml and I'll fix it
  16. Offline


    I'm having a problem with spawning on a missing chunk when tp between worlds. I know other people are having this problem, but I don't know if it is being looked into.

    It happens with portals and with mvtp.

    It happens about half of the attempts to tp between worlds, it fails to render the chunk below me. Usually this leaves me floating in space, but sometimes I seem to spawn in the void and disconnect.

    When I float, I am jerking up and down, like I'm falling and teleporting back to the same height in rapid succession. Also, any turning or motion happens in a jerky fashion and takes forever to accomplish. I can sometimes move to the edge of the chunk and jump onto land, but it takes a while. When I leave the chunk like that, it still doesn't render.

    It does not happen when tp in the same world, with portals or mvtp.

    It only happens when I run with multiverse.

    I'm on CB 740, multiverse 1.6.3, permissions 2.7.2. I use movecraft 0.6.8, but it happens when I remove it too. There is no console output when this happens, so I can't help with that. Sorry. I've tried restarting the server multiple times, rebooting the machine - it won't just sort itself out like that.

    Otherwise, I have no problems at all with the plug-in. I'm gonna keep using it anyway, since it's only my private server.

    Apologies if this has already been discussed, but I think I've read every post so far.
  17. Offline


    that something strange! in the first place has not been able to create a portal to hell. When I used the command /mvpc netherportal w:world and(/mvpc normalportal w:nether) in the response I received a message you do not choose the coordinates (how to choose??) Then miraculously created the first portal of it works and now I can not make a portal to hell! Help!
    my portal.yml
    price: 0.0
    destlocation: w:nether:spawn
    location: 159.0,109.0,-118.0:159.0,112.0,-117.0
    owner: ViZiT
    world: world
    price: 0.0
    destlocation: w:world:spawn
    location: -26.0,69.0,157.0:-29.0,73.0,157.0
    owner: ViZiT
    world: nether
    First works fine
    Second is't work! Why? First world is world second is nether
    I checked the coordinates of all correctly
  18. Offline


    Yeah can definitely disable it, but with some people coming from a single-world server and used to using /spawn, sometimes it helps, rather than having to educate people to use /mvspawn. Just an idea :)
  19. What is the line put in the. Yml permission for members to enter the portals?Because I put a group or "multiverse.portal .*" not enter any portals or those but I can not put anything ... Why?
  20. Offline


    Hello, I want to create a separated world where the players can use the give command and such. Now I want to know if I could prevent, that a player could teleport back in the normal with the cheated blocks. Or something like that every world has it's own inventory

  21. For some reason, my problem just went away. I made no modifications, no reloads, nothing.... but permissions is working perfectly now on new worlds >.>'
  22. Offline


    exscuse me if im asking something already answered i just dont have time to read through 97 pages but....
    will there ever be a multiverse without permissions support? because...

    i host my server on servercraft.co they use mcmyadmin, but mcmyadmin doesnt work with permissions only essentials group manger, i dont use group manager so im not asking if you can integrate essentis group manager support, im asking if you could make another version or a toggle in the config that would disable the NEED for permissions?
    IF you can't or won't i understand it would be nice though for anyone who uses servercraft/mcmyadmin.
    if by any chance you do this i would be very happy to donate $20
    thank you for your time
  23. I use this: http://forums.bukkit.org/threads/mech-multiinv-v1-5-2-per-world-inventories-709.4742/

    I like it because you can chose which worlds allow you to carry stuff between them :)

    if you have an updated version of MCMA, they DO support permissions now. The only problem is, as far as i can see, MCMA doesn't have an option for multi-world permissions (on any permissions systems)

    Servercraft is a good host, unless you need to start doing deeper work on your server. I believe they now have file editing, so you can probably manually edit the permissions files for each world.

    I hosted with servercraft for a while, and their support team is good. You can ask them if they have any suggestions as to how to do this :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  24. Offline


    i know what your saying but the new version of mcma has only a beta version that runs permissions i am going to try tonight to get the permissions working.
    also does permissions work with essentials or should i look for something to replace essentials?

    but overall it would be nicer to use multiverse without permissions
    thanks for the reply though :)
  25. Personally, i prefer to avoid essentials... i've had so many issues with it because it doesn't play nice with others, which limits my expansion possibiilities.

    Basically, if you have essentials, they claim that you shouldn't use permissions, because essentials permission plugin will simulate the permissions u need. I tried essentials for a month,it had the occasional bugs-nothing major, but as soon as i attempted to try a new plugin, things started crashing again...
    So now i stick with permissions.
    From what i've seen, yeah... the permissions built-into MCMA will overwrite your current permissions...which sucks... but in the long run, if thats how ur gonna do it, then it may be worth the time to re-impliment the permissions... or even wait until mcma updates and supports more permissions integration :)
  26. Offline


    thats exactly my problem mcmyadmin overwriting permissions and essentials ***ing me out with every new plugin
  27. Offline


    im still having trouble... i copied the World.yml permissions thing and changed it to Flatgrass.yml like you said and i still cant change the time... i even have my self as admin in the permissions folder
  28. Offline


    Ah thanks! This will solve my problem.

    Ehr to the plugin developer: Why I have to be a player to create a world? :(
    >mvcreate portal NORMAL
    17:08:36 [INFO] [MultiVerse]  This command needs to be run as a Player.
  29. Offline


    Could you explain to me why Ghasts "spill over" into the normal worlds from the nether?
  30. This will be fixed in 2.x. Added to feature request.

    To actually answer your question, you shouldn't :p

    I remember reading that this is a rare bug with bukkit, but I don't actually remember where I read that...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016

Share This Page