[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Wow... so many replies last night... Here we go!

    What are all the plugins you're running? Are they all up to date? What version of CB are you running?

    No new features are going to be implemented until 2.X, which Rigby has stated will come out soon.

    This has been asked multiple times, I don't think he'll have an issue submitting this when 2.X comes out, but there really aren't any planned updates for the next week.

    These are errors with MultiInv. Please talk to the correct plugin author.

    I'm looking into this now, but I remember an issue having to do with either iChat or EssentialsChat config. Are you using any of these?

    This plugin does not "show" portals. You could build the standard style 3x2 portal, light it, and then make it a MVPortal. If you don't want to use obsidian, you can always put water in and the water won't flow out of the portal area.

    A. I dunno about this, one part of me says, this would be cool for admins, but the other part of me says this would be too easialy abused, as creating a world lags MOST servers, and is not something that should be done daily.

    B. Yes but you could use this to have inventories preserved between certain worlds MultiInv
  3. Offline


    Yeah, I have iChat, but I have already tried to put this on iChat :

    [+world][+prefix+group+suffix&f] +name: +message

    But that didn't work :(
  4. Alright, I'm running iChat too, gonna go mess around with it, i'll get back with you.
  5. Offline


    Yeah, I see what you mean here. Maybe a per-world permission? E.G., multiverse.makeworld.world2 lets that person only make the world called 'world2.'

    The reason I ask is because I plan to have a separate world for mining that regenerates every couple weeks or something. I can easily delete the world automatically each week, but I don't know how to make a new one right after that.

    Maybe you could help? I'm using linux, so could I make a shell script to run a command in the console and set up a crontab to do it automatically?

    Thanks for your help!
  6. Ah cool, now that makes sense to me, although this may be something that could be it's own plugin, just because it's such a specific a purpose. WorldRefresh, hmm interesting.

    Maybe it will be in 2.X, or will be a plugin to 2.X, since it uses the Core, FeatureA, FeatureB... format

    EDIT: Looks like right now, requires server restart to delete a world, at least on windows, gonna let this one go, if you still want this, please post it in the plugin reqests forum
  7. Offline


    Awesome, thanks! While you're at it, it would be awesome to have a command to teleport to the world, then when you use the same command in the mining world, you get teleported back to the same spot you were last at in the normal world.

    Again, thanks!

    Oh, and I'm sure you've thought of this, but something to teleport people back to the real world before the mining world is refreshed so they don't end up inside a mountain! =P
  8. Offline


    For some reason I keep getting this errors:
    2011-04-07 15:56:38 [SEVERE] Could not pass event PLAYER_INTERACT to MultiVerse
        at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerInteract(MVPlayerListener.java:216)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:217)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:133)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:661)
        at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:35)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    I never had this problem ever since the 1.4 update.
    I'm using the lastest version of bukkit (b617), permission 2.5.5, and multiverse 1.6.2

    I dont always get this error when using the wand. But the wand doesnt work in general. If I try to set a point it sets both 1st and 2nd point, then constantly sets the 2nd point no matter which button I click :/

    PS: Is there another way to create portals without the wand?
  9. A. 617 is not the latest, 670 is: http://ci.bukkit.org/job/dev-CraftBukkit/
    B. You could go into Portals.yml and edit that; then do a restart, but you'd have to know the coords you want
  10. Offline


    Ok i'm waiting for u ;)
  11. Offline


    installed and working great. does everything our server needs it to. also it said
    [SEVERE] Nag author: 'Rigby' of 'MultiVerse' about the following: onPluginEnable has been replaced with a new signature, (PluginEnableEvent)
    consider yourself nagged. and thanks for a great plugin. ^^;
  12. Offline


    Wondering if anyone could help me...

    When I left click with the wooden pickaxe to set my coords, it sets both Position 1 and Position 2. This can be fixed by just selecting Position 2 elsewhere, but I figured a bug should be fixed. :)
  13. Offline


    MultiVerse 1.6.2 is not working for me on Bukkit reccommended 670. I use Brohoster. My server is successfully running Essentials 2.1.25, WorldEdit 4.3, and mcMMO 0.9.17

    The server operates perfectly with these mods installed, but as soon as MultiVerse.jar is added to my plugin folder and the server brought back online, no one can log in.

    I get one of two errors after waiting for about 30 seconds to connect:


    Any help would be appreciated. I haven't attempted to run my server with MultiVerse ONLY, without my other mods, to see if it's a possible conflict between these mods and MultiVerse.

    Note: I have had all of these running well on Experimental 627 for a while, albiet with older versions of each of these mods (appropriate for the pre-670 change)
  14. Offline


    when i enter the nether no matter wich way this is what happens.

    Cannot get back out.
    All commands dont work including /stop
    have to restart the server the bad way.

    Can someone help me, also I am using CB 646
  15. Not a bug, this sets the region as the 1x1x1 cube that you clicked.

    MultiVerse REQUIRES Permissions 2.5.5+. Please review the OP and the requirements for MV

    Upgrade to RB 670. Then check your permissions.
  16. Offline


    MultiVerse up until THIS VERY RELEASE has worked absolutely flawlessly with Essentials GroupManager, which includes FakePermissions.

    On top of that, the mod disables when permissions isn't found -- it doesn't crash and burn and tank the entire server, as I'm currently experiencing.

    But, for the sake of argument, I will disable GroupManager, manually recreate my entire permissions files for Permissions, and watch MultiVerse crash and burn my server anyway... BRB
  17. Ha, turns out I read your post as Permissions 2.1.25 instead of Essentials, whoops
  18. Offline


    Alright, Permissions 2.6 [670] installed, and GroupManager/GroupBridge removed. I rewrote my servers permissions and it seems to be performing identically (albeit, without the in-game /commands to change permissions and groups, etc...)

    Now, let's test it with MultiVerse 1.6.2 [670] uploaded.

    Does not work!

    However, the server loads and MultiVerse fails to load.

    When I type /mvtp I get the error:
    I have tested Permissions 2.6 and 2.5.5 and neither get MV to start.

    I'm currently trying to figure out how to see if Permissions is working correctly, but considering it's just a single jar and a single yml file, I'm hard pressed to understand why it wouldn't load.
  19. Offline


    could you make it so that this can spawn worlds or a certain seed? That would be absolutely amazing
  20. Offline

    John Kapsis

  21. Offline


    I've gotten Permissions loaded correctly, and now that Permissions is loading correctly... DUN DUN DUN! The server crashes and won't let anyone in.

    Turns out it's an out of memory error, trying to run too many / too large worlds using MV.

    Lesson learned: MAKE SURE you have enough RAM to support the number/size of worlds you want to run.
  22. Offline


    Can somone please help me i have permissions installed and i set myself for the required permissions do create a new world and i get this error "Permissions 2.1 is no enabled or hasnt been found" after typing "/mvcreate [worldname] [enviorment] please help me
  23. Offline


    I thought the same thing: but it turns out it's pretty easy, depending on how you host your server. Load up a singleplayer game with the seed you want, watch the world load, then log out and quit. Go to your %appdata%\.minecraft\saves where you will find your world. All you have to do is copy those files to the root of your world and use
    /mvimport {WORLDNAME} normal
    to import that world into MultiVerse. I did this to add an awesome 'gargamel' world to my server.

    The first thing to check is your server.log in the root directory of your server. Or, watch the console as your start your server, if you have access to it. Both of these will show errors during start up.

    The error message you are seeing is because Permissions is NOT loaded! You need to figure out why permissions isn't loading. You may think it's working, but if you've set yourself to Admin in Permissions AND as an OP to the server, you already have full access so you can't see if Permissions is working.

    Upload your server.log to pastebin.com or a similar site and link it here, so we can see what's wrong with your server.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
    John Kapsis likes this.
  24. Offline


    I can't, on home page of bukkit I press download and I get craftbukkit646, already tried it.

    Also all permissions are correct
  25. Offline


  26. is there any way to restrict a certain usergroup from using portals all together?
  27. Offline


    2011-04-09 21:31:33 [INFO] Starting minecraft server version Beta 1.4
    2011-04-09 21:31:33 [INFO] Loading properties
    2011-04-09 21:31:33 [INFO] Starting Minecraft server on *:25565
    2011-04-09 21:31:33 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-646-gb61ef8c-b670jnks (MC: 1.4)
    2011-04-09 21:31:33 [INFO] Preparing level "World"
    2011-04-09 21:31:33 [INFO] Preparing start region
    2011-04-09 21:31:34 [INFO] 144 recipes
    2011-04-09 21:31:34 [INFO] Preparing spawn area: 52%
    2011-04-09 21:31:35 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-04-09 21:31:35 [INFO] [AutoPlant] version 1.5 is enabled!
    2011-04-09 21:31:35 [INFO] [BackupPlugin]  BackupPlugin version 0.8.8 is enabled!
    2011-04-09 21:31:35 [INFO] [BackupPlugin]  Permissions plugin found, using Permission config
    2011-04-09 21:31:35 [WARNING] [BackupPlugin]  Disabled MapperUnit, mapper_path invalid: mcmap\mcmap.exe
    2011-04-09 21:31:35 [INFO] [BackupPlugin]  Finished setting up a thread: BackupUnit Next run in: 8 minutes.
    2011-04-09 21:31:35 [INFO] BankAccount version 0.4 is enabled!
    2011-04-09 21:31:35 [INFO] BankAccount: Config file found!
    2011-04-09 21:31:35 [INFO] BankAccount: Properties Loaded
    2011-04-09 21:31:35 [INFO] BankAccount: Connected to SQLite
    2011-04-09 21:31:35 [INFO] CraftBukkitUpToDate version 2.4.8 is enabled!
    2011-04-09 21:31:35 [INFO] [Permissions] version [2.6] (Phoenix)  loaded
    2011-04-09 21:31:35 [INFO] BankAccount: Established connection with Permissions!
    2011-04-09 21:31:36 [INFO] CButD: CraftBukkit is up to Date
    2011-04-09 21:31:36 [INFO] [EverCart]: v1.0 has been enabled.
    2011-04-09 21:31:36 [INFO] [HeroSneak] enabled.
    2011-04-09 21:31:36 [INFO] [iChat] Found Permissions (v2.6)
    2011-04-09 21:31:36 [INFO] iChat (v2.2.2) enabled
    2011-04-09 21:31:36 [INFO] [iConomy] Logging enabled.
    2011-04-09 21:31:36 [INFO]  - Updating MySQL Database for latest iConomy
    2011-04-09 21:31:36 [INFO] [iConomy] Error updating database: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Duplicate column name 'hidden'
    2011-04-09 21:31:36 [INFO] [iConomy] v4.65 (Kenzi) loaded.
    2011-04-09 21:31:36 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    2011-04-09 21:31:36 [INFO] BankAccount: Running interest every 5 minutes by 0.1%
    2011-04-09 21:31:36 [INFO] BankAccount: Established connection with iConomy!
    2011-04-09 21:31:36 [INFO] [iConomy] hooked into Permissions.
    2011-04-09 21:31:36 [INFO] Lampstone version 0.5 is enabled.
    2011-04-09 21:31:36 [INFO] LocalShops: Permissions found.
    2011-04-09 21:31:36 [INFO] LocalShops: iConomy found.
    2011-04-09 21:31:36 [INFO] LocalShops: Loading shop blacksmith
    2011-04-09 21:31:36 [INFO] LocalShops: Loading shop Redstone
    2011-04-09 21:31:36 [INFO] LocalShops: Loaded 2 shop(s).
    2011-04-09 21:31:36 [INFO] LocalShops: version 2.2.1 is enabled!
    2011-04-09 21:31:36 [INFO] [MultiVerse] Permissions Found
    2011-04-09 21:31:36 [INFO] [MultiVerse] - Version 1.6.2 Enabled
    2011-04-09 21:31:36 [INFO] [MultiVerse] Found iConomy, enabling payments.
    2011-04-09 21:31:36 [INFO] [MultiVerse] Loading World & Settings - 'World' - NORMAL
    2011-04-09 21:31:36 [INFO] [MultiVerse] Loading World & Settings - 'Nether' - NETHER
    2011-04-09 21:31:37 [INFO] [MultiVerse] 2 - World(s) loaded.
    2011-04-09 21:31:37 [INFO] [MultiVerse] Loading Portals
    2011-04-09 21:31:37 [INFO] [MultiVerse] 1 - Portal(s) loaded.
    2011-04-09 21:31:37 [SEVERE] Nag author: 'Rigby' of 'MultiVerse' about the following: onPluginEnable has been replaced with a new signature, (PluginEnableEvent)
    2011-04-09 21:31:37 [INFO] OtherX enabled
    2011-04-09 21:31:37 [INFO] Whitelist: Trying to load whitelist and settings...
    2011-04-09 21:31:37 [INFO] done.
    2011-04-09 21:31:37 [INFO] Whitelist version 2.7 is enabled!
    2011-04-09 21:31:37 [INFO] Done (0.418s)! For help, type "help" or "?"
    2011-04-09 21:31:39 [INFO] Stopping the server..
    2011-04-09 21:31:39 [INFO] CONSOLE: Stopping the server..
    2011-04-09 21:31:39 [INFO] Stopping server
    2011-04-09 21:31:39 [INFO] [AutoPlant] version 1.5 is disabled!
    2011-04-09 21:31:39 [INFO] [BackupPlugin]  BackupPlugin disabled!
    2011-04-09 21:31:39 [INFO] BankAccount is disabled!
    2011-04-09 21:31:39 [INFO] [EverCart]: v1.0 has been disabled.
    2011-04-09 21:31:39 [INFO] [HeroSneak] disabled.
    2011-04-09 21:31:39 [INFO] [iChat] iChat Disabled
    2011-04-09 21:31:39 [INFO] [iConomy] Plugin disabled.
    2011-04-09 21:31:39 [WARNING] BankAccount: Lost connection with iConomy!
    2011-04-09 21:31:39 [WARNING] BankAccount: Stopping BankAccount - Reason: Missing iConomy plugin!
    2011-04-09 21:31:39 [INFO] LocalShops: Lost connection to iConomy.
    2011-04-09 21:31:39 [INFO] LocalShops version 2.2.1: is disabled!
    2011-04-09 21:31:39 [INFO] [MultiVerse] - Disabled
    2011-04-09 21:31:39 [INFO] OtherX disabled
    2011-04-09 21:31:39 [INFO] [Permissions] (Phoenix) saved all data.
    2011-04-09 21:31:39 [INFO] [Permissions] (Phoenix) disabled successfully.
    2011-04-09 21:31:39 [WARNING] BankAccount: Lost connection with Permissions!
    2011-04-09 21:31:39 [INFO] [iChat] Permissions plugin lost.
    2011-04-09 21:31:39 [INFO] LocalShops: Lost connection to Permissions
    2011-04-09 21:31:39 [INFO] Goodbye world!
    2011-04-09 21:31:39 [INFO] Saving chunks
    This is what i get, it says build 646 right after i downloaded the latest recommended. Or im blind
  28. Offline


    Bukkit-0.0.0-646-gb61ef8c-b670jnks what you want is the "b670" not the 0.0.0-646
    So maybe ur blind :p

    when I go in the nether world I see zombie Pigmen but no ghast
    and I play with mobs=true
    I d'ont get any errors when runnning craftbukkit
    and i'm running 670

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Are you in an area big enough to find ghasts? Personally, this is a plus, seeing as ghasts are terrifying!

    Are you doing a cycle? Or is that the startup log for your server? It looks like it's starting up and shutting down. I would disable that plugin that has warnings for testing.
  30. Offline


    No I decided after I get the log to shutdown. If you need I can give you a log when I use the /mv command for portals and going to nether. Or simple a video.
  31. Offline


    +1 , me to , groupmanager and permissions doesnt work...

    2 days ago , it works fine , the other diffrent i found; The map name was: Essentials groupmanager, and now groupmanager.

Share This Page