[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline

    Jack Daun

    When I try to do /mvcreate i says you don't have rights to access that command or something and im admin on permissions with an asterisk for my permissions im also in ops.txt
  3. Offline


    @Jack Daun
    Any error messages? Also, please post your permissions file.
  4. Offline

    Jack Daun

    I think i figured it out, i was using essentialsgroupmanager which has its own version of permissions (2.5.1) and it was listening to that one that was unedited (i hadn't added my name o the admins on that one).
  5. Offline


    @Rigby90 how do i find the cordinates where my players spawn?
  6. Offline


    I'm not entirely sure if it is multiverse but when ever move to a nether type world the server seems to freeze. I'm using 612 with 1.6, and it has been happening from before 612/1.6.

    There is no console error it just completely locks, no console commands every one times out.
  7. Offline


    Are you running it from your home computer? Or on an external server?
  8. Offline


    External server although its running at my house.
  9. Offline


  10. Offline


    I have a another computer running as a server. It's not a issue of ram as it has 8gb ddr3, and the server runs 3 worlds just fine. The actual bukkit server locks up when a player enters the nether, however the server's OS is fine.
  11. Offline


    OK here it is
    animals: true
    spawn: -195:64:417:0.0:0.0
    price: 0.0
    mobs: true
    environment: NORMAL
    pvp: true
    alias: ''
    worldBlacklist: ''
    playerBlacklist: ''
    playerWhitelist: ''
    animals: true
    spawn: 5:64:-7:0.0:0.0
    price: 0.0
    mobs: true
    environment: NORMAL
    pvp: false
    alias: ''
    worldBlacklist: ''
    playerBlacklist: ''
    playerWhitelist: ''
    animals: true
    spawn: 0:76:0:0.0:0.0
    price: 0.0
    mobs: true
    environment: NETHER
    pvp: true
    alias: ''
    worldBlacklist: ''
    playerBlacklist: ''
    playerWhitelist: ''
    I wanted to play planetoids. But /mvimport didn't work for some reason. So I made a world called planetoids and replaced the world folder with the real planetoids map. But Its not the right spawn.
    I tried loading planetoids in single player and wrote the spawn cordinates with F3 and wrote all the numbers that are after X Y and Z. But when I wrote the cordinates in my worlds.yml file it didn't work.
  12. Offline


    Could u update it to 617? (recommended build)
  13. Offline


    Can you have different plugins in different worlds?
  14. Offline


    How would i set it up so i have my main map which is a creative build map and then i have a legit map were we use iconomy shops etc, but i dont want inventories to transfer from map to map what do i have to do to make that happen?
  15. Offline


    The dropbox download link (first one) doesn't seem to work.
    John Kapsis likes this.
  16. Offline

    John Kapsis

    The dropbox download link (first one) doesn't seem to work.

    Also is an update due??? when??
  17. Offline


    This plugin works fine for me on 617, no issues on my end what-so-ever.
  18. Offline



    Is there a way to get plugins to work in some worlds but not in other worlds?

    IE: I'd like my default world to have "NoExplode" activate, but my primordial desert map to have tnt/fire enabled (so "noexplode" is disabled).

    Ideas? :)
  19. Offline

    Celtic Minstrel

    Minecraft's vanilla /time command is not compatible with multiple worlds. You'll need to install a plugin that overrides it, such as General or CommandBook.
  20. Offline

    Chris Lewis

    Im using CB 617 Permission 2.5.5 and Multiverse 1.6 and getting the issue where its still charging my Admins to go through the portal.

    Have tried adding the permission - 'multiverse.portal.exempt' to the admin group and to the names individually in permissions, however, nothing is working... it is still trying to charge my admins iconomy coins everytime they use a portal.

    any update on this?
  21. Offline


    I know the cause and intend to release an update/fix for it, unless fernferret wants to.

    Basically the repo fernferret based his update on was 1.4 which lacked some fixes and changes from 1.5 This included potal.exempt proper world white/blacklisting and so on.
  22. @Rigby90
    Sorry, I did not see the 1.5 repo, didn't realize it was forked. If you can point me to the 1.5 repo it is I'll gladly apply the changes I did to that to get a better version out.
  23. Offline


    I never got round to pushing the 1.5 changes to the repo.
  24. Ah well if you do, I think I should be able to pull those onto my repo with little effort then do a pull request. <3 Git.
  25. Offline


    In your commands 'n syntax thing, it says:
    Example - /mvpd - The above command will set the selected portals destination to the players current position.''
    Shouldn't that be /mvpd here?
  26. Offline


    Yup it should :), the whole OP needs rewriting as there's some outdated and wrong information in there now.
  27. Offline


    I cant seam to get the plugin to work. I have permissions installed, just it doesnt recognize it.
  28. Offline


    Any way to make it so it doesn't report which world you're on in chat? I.E next to my name it says

    [world1]TPMJB: herp derp derp
  29. Offline


    Try going your your plugins folder, and then into the Multiverse folder. Open multiverse.yml, and try adding the line "Prefix: false" To the file. If it works, yay! If not, post here and I'll see what I can do.
  30. Offline


    I just fixed it with iChat. I now have it working my own custom way :)
  31. Offline



Share This Page