[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline

    Multiverse

    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:
    http://dev.bukkit.org/server-mods/multiverse-core/
    http://dev.bukkit.org/server-mods/multiverse-portals/
    http://dev.bukkit.org/server-mods/multiverse-netherportals/

    Thanks!

    [​IMG]

    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet


    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Description
    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..


    The Multiverse Team:
    Developers:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!

    Documenters:
    @Elizacat
    @AkiTensai
    @Xanipher

    Testers (official I know a bunch of you have helped, thanks!):
    @jonDatz
    @jfulleton


    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...
    Requirements

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki


    Downloads:
    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)


    Why multiple Downloads?
    https://github.com/Multiverse/Multiverse-Core/wiki/Plugins-of-Multiverse-2

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:
    https://github.com/Multiverse/Multiverse-Portals/wiki/Basic-portal-tutorial

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:
    https://github.com/Multiverse/Multiverse-Core/wiki/FAQ

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki


    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelog:

    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)



    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1





    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7





    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4





    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3





    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2





    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'





    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]





    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)






    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)






    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)






    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...


    [​IMG]
     
    TGF, maino, aTxT and 58 others like this.
  2. Offline

    zorphon

    Well there is one message on server start up that seems a bit odd...
    Code:
    [INFO] Invalid config file found and converted to proper name/format.
    2011-04-01 19:28:53 [SEVERE] Could not load plugins\Permissions.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:105)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:158)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:106)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:63)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:101)
        ... 8 more
    Caused by: while scanning for the next token
    found character     '\t' that cannot start any token
     in "<reader>", line 103, column 1:
                    - 'falsebook.anyic'
        ^
    
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:360)
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingValue.produce(ParserImpl.java:592)
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:132)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
        at org.bukkit.util.config.Configuration.load(Configuration.java:73)
        at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:126)
    So, it seems to be the problem of FalseBook permissions somehow?
     
  3. Offline

    Itssnowing

    You're using tabs instead of spaces on one of the lines in you Config file. Post the config, please.

    Edit: Prefferably post in on Pastebin, I can find the exact line faster that way.
     
  4. Offline

    Celtic Minstrel

    If you have mobs off in server.properties, then they'll disappear the moment they spawn. If you want some worlds peaceful and some not, you have to have mobs on.
     
  5. Offline

    zorphon

    Odd, I've never used tabs; only spaces...
    Here it is:
    http://pastebin.com/p14Qkqpv
     
  6. Offline

    Itssnowing

    That's funny. According to the Permissions type guide, that is the problem. At least, it says this:
    Code:
    Caused by: while scanning for the next token
    found character '\t' that cannot start any token
    in "<reader>", line 58, column 1:
    A tab [\t] is used instead of 4 spaces.
    groups:
    [TAB]Default:
    default: true
    info:
    depending on the editor you use, use find & replace
    find: \t
    replace: [4 spaces]
    
     
  7. Offline

    Alex H

    I have a question, how does multiverse effect Dynmap?
     
  8. Offline

    zorphon

    Nevermind, got it working. I reinstalled the permissions.jar and it worked, doesn't seem to be the config file. Using Wormhole X-Treme and it's working.
     
  9. Offline

    Itssnowing

    Okay, yay!
     
  10. Offline

    fernferret

    Effect? in a good way i guess, I'm using dynmap and MultiVerse with no adverse side effects! Are you having an issue with it?

    Ah, cool, i'll buy that. I'm still very interested in how difficulty gets handled on a per world basis.
     
  11. Offline

    tremor

    will there be a use.portal permission.. per chance, I dont want all my users having access via portal, and I prefer not to use the /mvtp command?
     
  12. Offline

    Pomme72

    Yes, of course ! :p

    And I use iChat too, but I have already try to put this in iChat :

    [+world][+prefix+group+suffix&f] +name: +message

    But that didn't work :(
     
  13. Offline

    fernferret

    I have not tested compatibility with the newest iChat (or any iChat for that matter), but we may find the issue there, Gonna get some sleep tonight, but I'll look at it tomorrow for ya.

    EDIT: In iChat this works for me, if you could try this line exactly and if that does not work we can keep looking
    Code:
    message-format: '[+world+prefix+group+suffix&f] +name: +message'
    EDIT2: I put in your iChat config and it appears to work fine on my server, any chance you could hit me up with what builds of everything your using? (preferably in pastebin)
     
  14. Offline

    Pomme72

    Okay, thank you very much dude ! Go sleep a little, that'll be good for u ;) and see you tomorrow ! :p
     
  15. Offline

    zorphon

    Anybody know if we can use this WITH Wormhole X-Treme?
     
  16. Offline

    fernferret

    Sure can! It works great! I use MultiVerse to do my world administration, and WHX to do the actual teleportation!

    Ok, because i'm crazy, and couldn't sleep after I got the same error you did on one of my test servers, but not the other, It turns out I was stupid and deleted all of my config associated with the plugins. then it worked...

    So, here is my suggestion:
    1. Make a copy of your current plugins/ folder
    2. Install JUST Permissions, MultiVerse, Essentials and EssentialsChat
    3. Use Multiverse to create a second world using /mvcreate testworld NORMAL
    4. type "test"
    5. Did this work? If not, stop here and reply to me here
    6. If it did, Continue installing your other plugins 1 by one, testing after each one, you can use /reload in the server console to make this easier
    7. Start comparing the differences in config files and fine the problem
    8. Profit.

    Let me know.
     
  17. Offline

    zorphon

    Fantastic! Was trying to figure out how to make new worlds easy. I'll try it out right away!

    P.S. WHX is awesome for the actual teleportation part.

    For some odd reason, I can't delete anything in the Region folder of the worlds I've generated using /mvcreate, it won't let me delete it in my ftp client or anything.

    What's the best way to rename worlds in both the server files and in MultiVerse /mvlist to be the same world and spawn you set in MultiVerse, but not be named something stupid like "test3"?

    Sorry for all the replies, but this plugin seems to have broke the /time set "" command. I used it before while building my base to skip night, and now the command (default minecraft server/bukkit command) doesn't do anything. Also my worlds are on separate time schedules, and the command to set time is broken like I said. How can I fix this, I'm super angry about it.

    *edit* actually, the command changes the time in the world I created with /mvcreate. Is there a way I can get this function back into my normal/main world?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 18, 2016
  18. Offline

    piratescott

    Ok, I'm not sure if its the 1.4 update that broke this or the latest version of bukkit or I messed it up myself maybe but my wand isn't working, i know the default it the pickaxe, i changed it to the bowl, neither work and I've checked the settings for it, when I left click I don't get the "point 1 is set" message or whatever (same with right click) any ideas?
     
  19. Offline

    gilgatex

    First I just want to say thanks so much for all the hard work you put in to this! And for free too! I really appreciate it! My server wouldn't be what it is without this plugin.

    Would it be a quick fix to make it so that if you don't have access to the /mv* commands, it won't show up in /help? Regular users on my server can see the 5-10 commands they can use and then 4 pages of the /mv* stuff they can't.
     
  20. Offline

    Chris Lewis

    im having an issue that even though i have a permission set
    - 'multiverse.portal.exempt'

    its still charging my OP's and Myself to go through portals. I had an admin portal locked this way. Now my OPS and such cant get to it? Anyone else experiencing this problem?
     
  21. Offline

    Itssnowing

    Are you getting any errors? Also, make sure you're putting your OPs all in a Permissions group and not just OPing them.
     
  22. Offline

    fernferret

    I remember reading somewhere that this is tough to do right now due to the way the help command is handled. Seems like something that should be handled by the help command... (the whole, user does not have access so they should not see it)
     
  23. Offline

    gilgatex

    That's the thing though, it's handled correctly by every other plugin I use. The MultiVerse commands seem to be the only ones that show up regardless of permissions level.

    This is for EssentialsHelp, not the built-in one. Sorry if that wasn't clear.
     
  24. Offline

    Chris Lewis

    And I have my OPS in my admin permission group which gets the permission
    - 'multiverse.portal.exempt'
    they are not just op'd. the thing is that this worked just fine before the CB617/MC1.4/multi-verse v1.6 update...
    I am not getting any errors, its just charging them.
     
  25. Offline

    zorphon

    One quick question, does having more than one world slow down the server anymore than a single world? I mean, does it use more RAM or anything? If not, I will feel fine using another world and making a portal between with WHX, but I am concerned with my limited BroHoster.com server that it will use too much RAM.

    Looking forward to hearing from you, thanks.
     
  26. Offline

    Itssnowing

    It shouldn't slow the server down. The only slow part is the teleporting, because you have to load new chunks. All it is is loading chunks somewhere else- So if you have two players in one world in two completely different areas, it will take the same amount of ram as two people in two different worlds.
     
  27. Offline

    zorphon

    That's very good to know. Thank you.
     
  28. Offline

    Itssnowing

    You're welcome :)
     
  29. Offline

    Alex H

     
  30. Offline

    Itssnowing

    I think it would make more sense to ask the maker of Dynmap, how multiworld would work.
     
  31. Offline

    ElgarL

    Bug on the tracker is in error (world names with spaces). Sorry posted to wrong plugin tracker :(
     

Share This Page