[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Gooji, I recommend you download Notepad++ - no, I order it! :)

    Always open your config files with that one from now on, and in notepad++ you can put an option on that it ALWAYS replace tabs with spaces, so no misstakes comes from that either!
    Notepad++ -> Settings -> Preferences -> Language menu/tab settings: Tab space, tick the "Replace by space"
    ShadowDrakken likes this.
  3. Offline


    PSPad is also nice. Both Notepad++ and PSPad use scintilla, so they behave pretty similar :)
  4. Offline


    thanks alot guys i finally got it to work!

    but i have encountered another problem lol

    it said i created a portal, but how do i create a destination and connect them?
  5. Offline


    First post in the thread (shown at the top of every page) has details
    I've also attached a nice printable version I made for my own use :)

    Attached Files:

  6. Offline



    Version: "This server is running Craftbukkit version git-Bukkit-0.0.0-447-g84246c4-b428jnks (MC: 1.3)"

    Multiverse is the newest v1.3

    Theres nothing worth looking at in the log, as it freezes and gives no errors.
    I also tried with the normal permissions 2.0 (not GroupManager) and it does the same thing.
  7. Offline


    Hi I'm running the latest version of bukkit and multiverse but the portals don't work any more i keep getting this error every time i walk thought a portal (using sigh method).

    2011-02-24 03:05:17 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
        at com.onarandombox.Rigby.MultiVerse.MVPlayerSession.getTeleportable(MVPlayerSession.java:120)
        at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:284)
        at org.bukkit.plugin.java.JavaPluginLoader$8.execute(JavaPluginLoader.java:165)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:115)
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
  8. Offline


    Can you try redownload 1.3 and tell me if the error still occurs.
    --- merged: Feb 24, 2011 2:21 PM ---
    Ok I'll look into it then, if I already got you to do the following then just ignore it... just woken up and in a rush to head out for lunch.

    Can you try running just Permissions 2.0 and MultiVerse together? If the error still occurs then this means that its most likely not a plugin conflict and is either a problem with MultiVerse or a configuration error. Either way hopefully we can get to the bottom of it.
  9. Offline


    In the latest version of multiverse the portals do work now.

    Also do I have to use a another plugin to use the animal or mob in world.yml to disable animal or mob spawning because I set them to false but mobs still spawn?
  10. Offline


    I tried with both Permissions 2.0 and (what I'm running now) GroupManager
  11. Offline


    Ok can you do me a favor then, can you zip up your server directory, basically I need the craftbukkit jar + the plugins folder that contains MultiVerse and Permissions.

    Remove any other plugin details and your ops.txt and world folder. I can't seem to reproduce the error myself so not sure what to do.
  12. Offline


    Thank you!,
    ... [Please, /mvsethome, /mvhome].. ?_?
  13. Offline


    I have another (minor) request: could you please make the world prefix configurable or at least add a space at the end? I use MultiVerse together with CraftIRC and it would be really cool to have matching prefixes.
  14. The only pulgins Myself and MrAdam have in common are the WorldGuard and WorldEdit plugins, oh and MinecartMainaCore. Not that this matters as it still occours with no other plugins other than Perms2.0 and Multiverse.

    If you want me to upload my server directory as well let me know.
  15. Offline


    I am having a problem on the most recent recommended build of craftbukkit. I just was updating from build 266 and I am gradually re adding my plugins 1 at a time, so at this point I only have scrapbukkit permissions 2.0 and MultiVerse running, but for some reason MultiVerse won't load my worlds or portals. I have already tried using permissions 2.1 as well to see if it fixed the problem, and I converted my other worlds before I added MultiVerse back into my server.
  16. i'm getting this error whit whatever command i use( from Multiverse)
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvtp' in plugin MultiVerse v1.3 (Permissions 2.0)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:173)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:633)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:596)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:590)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:248)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
        ... 12 more
  17. Offline


    The "/mvpd" command does not seem to work. I verified that I had permissions, I first issued the command "/mvps {portalname}. I received confirmation that I had selected a portal, but no confirmation that I had set it's destination. I have no doubt I'm doing something wrong, since I'm not really smart with this stuff, but if there is a known bug, or something obvious I'm missing, please help. I have the v.1.3 and I'm using Permissions 2.0
  18. Offline


    Getting the same error, but am running Perm 2.1 so am waiting for the release for that today.
  19. Offline


    Alright., first things first.


    Now to business: I can teleport to my nether world perfectly fine aside from the expected render time. So, I get to the nether world and everything is fine until I want to travel back through the portal that it created.

    I stand in the portal...... nothing happens. I think, "Oh. I just have to define that that portal will take me back to 'world'." So I do the clicky thing, and type the "/mvimport world NORMAL". Then it tells me that "world" is already in use, or something like that.

    I mean, that does make sense, but I just wanna go back through the portal to my real world... lol.

    Help? :)
  20. Offline


    wrong command, you need to use /mvpc
  21. Offline


    Sooo, "/mvpc world NORMAL" will take me back through the portal to my starting world? Am I going to spawn in the default spawn in the normal world? Thats no biggie I can just use the custom spawn command..
  22. Offline


    no, your worlds already exist, you're not creating new worlds... the first post in the thread (shown at the top of every page) describes the syntax, as well as providing examples. I also posted a PDF of the same information in a little bit easier to read format on page 35 of the thread.
  23. Offline


    OH. Alright, thanks.

    Your PDF is the bomb. haha.
  24. Offline


    haha, thanks, but all I did is reformat the information that was already on the page :)
  25. Offline


    Yeh chances are I'll be doing this in the split up version as there doesnt seem to be a proper Multi-World /home /warp plugin... unless MyWarp and MyHome has finally been updated.
    --- merged: Feb 24, 2011 6:11 PM ---
    hmmm theres an option in the config called ALIAS, when this is set it uses this instead of the Worlds name in chat etc, so you should be able to set it as "Hellworld ", or something similar.
    --- merged: Feb 24, 2011 6:14 PM ---
    Sure the more info etc I can get for the issue the better.
  26. Offline


    @Rigby90 they have been, although I have problems with MyHome's multiworld support... I use MyWarp and SpawnControl and they both play nice with MV :)
  27. Offline


    Can you pastebin your config files.

    And what Version of MultiVerse did you have previously? as there was a config change around version 1.0
    --- merged: Feb 24, 2011 6:15 PM ---
    It's erroring on a Permissions check, which either means you dont have permissions installed or you're using Permissions 2.1 which is not supported atm. Just got back from the Pub so I intend to sit down and try implement Perm 2.1 now.
    --- merged: Feb 24, 2011 6:16 PM ---
    Will look into it, what happens when you type "/mvpd here"
  28. Offline


    Does Mutliverse work with Essientals group manager?
  29. Offline


    ooo I must of missed that, will go take a look and possibly link it in the original post :).
    --- merged: Feb 24, 2011 6:27 PM ---
    *shrug* Essentials Group Manager is just GroupManager, but errr..... combined in the Essentials package.... god knows why......

    So providing Group Manager works itself then it should.
  30. Offline


    Ok, I didn't realize there was a config change. I had version .8, so I will make the necessary changes to my files
  31. Offline


    Group Manager is working for me, but when I put mutliverse on, i get these errors, http://pastebin.com/kvy0mNis
    I'm using CB 432 and Minecraft 1.3. I only get the error when I run MV with group manager. I tried the /mvcreate and I get an internal error in game

Share This Page