[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    I'll go give it a whirl, just out of curiosity did you download 1.3 as soon as i uploaded/announced it... or have you redownloaded the corrected version since then?
  3. Offline


    I must have grabbed it directly when you uploaded it, I just downloaded it again and it seems to be working fine. Derp!

    Thanks putting in the time to support your plugin!
  4. Offline


    You warn that we need to convert our worlds first. How do we do that? minecraft does the one automatically, but how do we get minecraft to convert the one that was made by multiverse? Redirect minecraft to that world in server.properties?
  5. Offline


    Sorry you'll have to manually set it in server.properties and convert each world manually.
  6. Offline


    Yep I just finished playing fun and games with my 4 maps I got my host to zip them all up (kept timing out when i tried)
    Then i downloaded all 4 put them into my singleplayer converted them all ziped them back up put them on the server and extracted Fun times so far no errors of any sorts as far as i can see.

    I kind of want to use permissions 2.1 cause i heard about a groups data fix in it but not sure if its worth braking other plugins that don't like it yet any 1 here using it what feed back can you give me I really need the black list to use groups.
  7. Offline


    Hi there, me again. There's a problem with spawns, new players, instead of spawning at the spawnpoint I've set with /mvsetspawn they spawn at the map's original spawnpoint. I've set the map default in MultiVerse.yml and changed the name of the world in server.properties.
  8. Offline


    mvsetspawn only sets the location where you would teleport to if you use the world as a destination and the respawn point for players when they die.

    I think when I split the plugin up I'll set it up properly so it uses the spawn point for new players etc.
  9. Offline


    Alright, thanks.
  10. Offline


    Um for some reason, I cant build in my 2nd world...I have Essentials and this on the server.....why?
  11. Offline


    This happened to me a few times and teleporting back into the world seemed to fix it.
  12. Offline


    it's a well-known issue when you log-off in any "secondary" world; teleporting to a default world and then back is a workaround at present
  13. Offline


    I just had a crazy idea. could you add a feature to teleport other people to another world and clean their inventories? I figured that, instead of banning people, I could send them to a Nether world with pvp on, invincible monsters everywhere and no chance for survival!
  14. Offline

    Boon Pek

    Hello there!
    I seem to be having problem with running MultiVerse 1.3 and CraftBukkit Build 432. Whenever I use /mvcreate it outputs: An internal error occured while attempting to perform this command. I have tried with other builds, 430 and 428 respectively but to no avail.
    Here are the logs:
    .bukkit.command.CommandExceptionUnhandled exception executing command 'mvcreate' in plugin MultiVerse v1.3 (Permissions 2.0)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:173)
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:633)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:596)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:590)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused byjava.lang.NullPointerException
        at com
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
    12 more
  15. Offline


    Ok the line it's erroring on is a permissions check line, chances are you don't have Permissions 2.0 installed or you're running 2.1 which currently isn't supported.
    --- merged: Feb 24, 2011 7:39 AM ---
    I plan to implement the ability to teleport a targetted person to another world. :)
  16. Offline


    Exact same problem on my server. Any kind of tp command freezes the server completely.
  17. Offline


    Can you provide more information?

    Eg -

    List of Plugins
    CB Build
    MultiVerse build
    Pastebin link to your server.log

  18. Offline


    Hi, i relatively new to this, so i have installed the following plugins:

    Minecart Mania
    MultiVerse 1.3
    Permissions 2.1

    And when i try to type in /mvcreate nether nether, I get the "an internal error has occurred while attempting to perform this command"

    i put the permission scripts on the first post, but i'm not sure I put it in correctly, i put it under default, and under permissions.

    what am I doing wrong?
  19. Offline


    You're running Permissions 2.1 theres not an update out for MultiVerse that supports this yet.
  20. Offline


    I just downloaded Permissions 2.0 and loaded all the permissions to default and under permissions and it is still giving me the same error
  21. Offline


    In that case can you pastebin your server log from start to error.
  22. Offline


    Whats the timetable for Multiverse to work with permissions 2.1? I almost shit my pant of happiness today when I saw you had updated the addon, but then I got the errors again and realised I could not enforce it to run on permissions 2.1 :)

    Thanks for a good plugin so far!
  23. Offline


    Alright, here it is

    2011-02-24 11:12:38 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvcreate' in plugin MultiVerse v1.3 (Permissions 2.0)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:173)
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:633)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:596)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:590)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:212)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
            ... 12 more
  24. Offline


    I'm not quite sure been looking around and seems like some people are finding bugs etc within Permissions 2.1... Seems like its not as finished and working as people think or would like it to be.

    I may update still anyways and keep both 2.0 and 2.1 going, there shouldn't really be anymore updates unless CraftBukkit changes.
    --- merged: Feb 24, 2011 8:17 AM ---
    Ok in that case it's still a Permissions error, can you pastebin the startup log where it shows all the plugins loading.

    I wan't to verify that you have Permissions 2.0 loading and ONLY Permissions 2.0 :)
  25. Offline


    Alright here it is!

    2011-02-24 11:11:07 [INFO] Starting minecraft server version Beta 1.3
    2011-02-24 11:11:07 [INFO] Loading properties
    2011-02-24 11:11:07 [INFO] Starting Minecraft server on *:25565
    2011-02-24 11:11:07 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-02-24 11:11:07 [WARNING] While this makes the game possible to play without internet access,        it also opens up the ability for hackers to connect with any username they choose.
    2011-02-24 11:11:07 [WARNING] To change this, set "online-mode" to "true" in the server.settings        file.
    java -Xmx728M -Xms728M -jar minecraft_server.jar no2011-02-24 11:11:09 [INFO] This server is runn       ing Craftbukkit version git-Bukkit-0.0.0-450-gd3c1ba4-b432jnks (MC: 1.3)                       20       11-02-24 11:11:09 [INFO] Preparing level "world"                                           2011-0       2-24 11:11:09 [INFO] Preparing start region           2011-02-24 11:11:12 [INFO] Preparing spawn        area: 0%
    2011-02-24 11:11:13 [INFO] Preparing spawn area: 0%
    2011-02-24 11:11:15 [INFO] Preparing spawn area: 12%
    2011-02-24 11:11:16 [INFO] Preparing spawn area: 16%
    2011-02-24 11:11:17 [INFO] Preparing spawn area: 16%
    2011-02-24 11:11:18 [INFO] Preparing spawn area: 20%
    2011-02-24 11:11:19 [INFO] Preparing spawn area: 24%
    2011-02-24 11:11:20 [INFO] Preparing spawn area: 32%
    2011-02-24 11:11:21 [INFO] Preparing spawn area: 36%
    2011-02-24 11:11:22 [INFO] Preparing spawn area: 40%
    2011-02-24 11:11:23 [INFO] Preparing spawn area: 48%
    2011-02-24 11:11:24 [INFO] Preparing spawn area: 60%
    2011-02-24 11:11:26 [INFO] Preparing spawn area: 69%
    2011-02-24 11:11:27 [INFO] Preparing spawn area: 81%
    2011-02-24 11:11:28 [INFO] Preparing spawn area: 85%
    2011-02-24 11:11:30 [INFO] Preparing spawn area: 89%
    2011-02-24 11:11:31 [INFO] Preparing spawn area: 93%
    2011-02-24 11:11:32 [INFO] Preparing spawn area: 93%
    2011-02-24 11:11:33 [INFO] Preparing spawn area: 97%
    2011-02-24 11:11:38 [INFO] WorldGuard loaded.
    2011-02-24 11:11:39 [WARNING] Using the stupidly long constructor net.seinfinium.eek.EekRunes(Plu       ginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer recommended. Go n       ag the plugin author of EekRunes to remove it! (Nothing is broken, we just like to keep code clea       n.)
    2011-02-24 11:11:39 [SEVERE] Could not load plugins/Permissions.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:85)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:55)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:187)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:174)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:120)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:227)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.ja       va:57)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccesso       rImpl.java:45)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:77)
            ... 8 more
    Caused by: while parsing a block collection
     in "<reader>", line 44, column 13:
                    - 'general.spawn'
    expected <block end>, but found Scalar
     in "<reader>", line 68, column 16:
                    - 'general.time'
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(ParserImpl.java:5       20)
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:203)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at org.bukkit.util.config.Configuration.load(Configuration.java:73)
            at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:178)
            at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:41)
            at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:74)
            ... 13 more
    2011-02-24 11:11:40 [INFO] LWC  [v1.54] Loading shared objects
    2011-02-24 11:11:40 [INFO] Config       [v1.54] Loaded 11 config entries
    2011-02-24 11:11:40 [INFO] LWC  [v1.54] Native library: lib/native/Linux/i386/libsqlitejdbc.so
    2011-02-24 11:11:43 [INFO] [MultiVerse] - Version 1.3 (Permissions 2.0) Enabled
    2011-02-24 11:11:43 [INFO] [MultiVerse]  Permission system not enabled. Disabling plugin.
    2011-02-24 11:11:43 [INFO] [MultiVerse] - Disabled
    2011-02-24 11:11:43 [INFO] WorldEdit 4.0-beta4 enabled.
    2011-02-24 11:11:43 [INFO] WorldEdit: No known permissions plugin detected. Using configuration f       ile for permissions.
    2011-02-24 11:11:44 [INFO] WorldGuard: No known permissions plugin detected. Using configuration        file for permissions.
    2011-02-24 11:11:45 [INFO] WorldGuard: Single session is enforced.
    2011-02-24 11:11:45 [INFO] WorldGuard: TNT ignition is PERMITTED.
    2011-02-24 11:11:45 [INFO] WorldGuard: Lighters are PERMITTED.
    2011-02-24 11:11:45 [INFO] WorldGuard: Lava fire is blocked.
    2011-02-24 11:11:45 [INFO] WorldGuard: Fire spread is UNRESTRICTED.
    2011-02-24 11:11:45 [INFO] WorldGuard 4.0-alpha1 enabled.
    2011-02-24 11:11:45 [INFO] Minecart Mania Core version 0.97 is enabled!
    2011-02-24 11:11:46 [INFO] Rune CompassRune loaded!
    2011-02-24 11:11:46 [INFO] Rune ChronoTriggerRune loaded!
    2011-02-24 11:11:46 [INFO] Rune PowerToolRune loaded!
    2011-02-24 11:11:46 [INFO] Could not load door state - starting new door list
    2011-02-24 11:11:46 [INFO] Rune DoorRune loaded!
    2011-02-24 11:11:46 [INFO] Could not load teleport state - starting new teleport list
    2011-02-24 11:11:46 [INFO] Rune WaypointRune loaded!
    2011-02-24 11:11:46 [INFO] Rune OracleRune loaded!
    2011-02-24 11:11:46 [INFO] Rune FreezerRune loaded!
    2011-02-24 11:11:46 [INFO] EekRunes loaded!
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -admin
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -create
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -free
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -info
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -p
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -modify
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -unlock
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loaded command: /lwc -owners
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> PLAYER_QUIT
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> ENTITY_EXPLODE
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> BLOCK_INTERACT
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> BLOCK_DAMAGED
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> BLOCK_BREAK
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> BLOCK_PLACED
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] -> REDSTONE_CHANGE
    2011-02-24 11:11:46 [INFO] LWC  [v1.54] Loading SQLite
    2011-02-24 11:11:47 [INFO] PhysDB       [v1.54] Creating physical tables if needed
    2011-02-24 11:11:47 [INFO] MemDB        [v1.54] Creating memory tables
    2011-02-24 11:11:47 [INFO] SQLite       [v1.54] Using: Native
    2011-02-24 11:11:47 [INFO] Done (37969483000ns)! For help, type "help" or "?"
    2011-02-24 11:12:27 [INFO] 143 recipes
  26. Offline


    gooji18x, from what I see there its not loading permissions at all? (Could not load plugins/Permissions.jar)

    since you also have this:

    2011-02-24 11:11:43 [INFO] [MultiVerse] Permission system not enabled. Disabling plugin.
  27. Offline


    your permissions file is malformed. Make sure there's no tabs, only spaces, and that all your indents are correct... both problems will break Permissions
  28. Offline


    How do I make it load then? i plugged it into my plugins folder. It should load right?

    Btw thanks for the help, i really appreciate it
  29. Offline


    It /should/ load correctly once you fix Permission's config file
  30. Offline


    This is what I have in my file ATM:

    # Supports "Default" and "GroupUsers"
            system: default
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:"
    #   field seperated by commas.
    #   Example: inheritance: Default,Admins,
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
            default: true
                build: true
                - 'general.spawn'
                - 'multiverse.world.create'
                - 'multiverse.world.list'
                - 'multiverse.tp'
                - 'multiverse.world.setspawn'
                - 'multiverse.world.spawn'
                - 'multiverse.portal.create'
                - 'multiverse.portal.select'
                - 'multiverse.portal.remove'
                - 'multiverse.portal.destination'
                - 'multiverse.portal.list'
                - 'multiverse.portal.rename'
                - 'lwc.protect"
            default: false
                build: true
                - Default
                - 'general.time'
                - 'general.teleport'
                - 'general.teleport.here'
                - 'general.player-info'
            default: false
                build: true
                - Moderator
                - '*'
    # DarkGrave has control over all commands.
    # sk89q can use /spawn & /time
            group: Admins
            group: Default
                - 'general.time'
  31. Offline


    hrm, looks ok... ah, except for the double quotes after lwc.protect

    also, you might want to edit the two users at the bottom and replace the admin one with yourself

Share This Page