[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    i'v got a serious problem, that is not letting me use multiverse at all. any mv command i try to use it says" internal error occred when attempting to preform this command." how can i fix?
  3. Offline


    Please update to CB 1.2.3 R0.2
  4. Offline


    That was one of the first things I checked, same with updating Multiverse. Still doesn't work.

    I neglected to mention that portals in my main world do work. So we have the same issue really.
  5. Offline


    I have the same problem!
    Only op and people with multiverse.* can keep the custom position !
  6. Offline


    I have the 1.2.3 r0.1 beta, Will this plug-in work if it is 1.1?
  7. Offline


    So I created a world and all users can go through the portals to get there, but once they're there only ops can build. Any help here please??
  8. Having issues with multiverse Unloading my world settings.

    Using 2.4 latest dev build and beta 1.2.3 -R02 Bukkit

    The console will say the worlds config has loaded but once the server is up exactly every 60 seconds it will spam [SERVER] INFO Unloaded x8 (I have 8 worlds)

    I deleted the world config file and restarted the server, no more [SERVER] INFO Unloaded messages but once i reimport my worlds and do the settings again i am once again spammed with the [SERVER] INFO Unloaded x8 message.

    Very serious error as it basically stops Multiverse working at all

    EDIT: this was actually caused by Marquee if you can believe it.
  9. Offline


    So i was wondering, is it possible to have different server properties on different worlds?

    I'd like to have one world with animals and monsters disabled and one world with them enabled.
  10. Offline


    Go into your mutliverse Core folder and change the settings under for Worlds.yml
  11. Offline


    That worked, thanks :)
  12. Offline


    is there a way to allow non ops to go through my portals without permissions?
  13. Offline


    When i try to type /mv create PVP_World survival it says:
    an internal error occurred while attempting to perform command

    what to do???

  14. I've unearthed a teleport bug in the current dev versions of Core/Portals. Should be fixed tomorrow.
  15. Offline


    I have a bug. I import all of my worlds using /mv import and then I stop the server. I got the the worlds.yml file and change some spawn settings to false. For example, in my casino world, I don't want monsters spawning. But when I start it up again, I cant spawn anything with a spawnegg in any of my worlds. My config after I change settings:
    Yes, I did use the YAML paster, I can't seem to figure out what's wrong.
  16. Offline


    its is possible to clear all items from inventory when player going back to primary world ?
  17. Offline


    No GitHub account, so sorry for posting this here instead of a ticket.

    Console Error on non MV-Worlds, like SkyBlockMultiplayer (LINK).
    On Teleport or plugin-command:

    MV #522
    CB #2063
  18. Offline


    I am getting some errors in console, and when I type anything for multiverse, it says "A internal error occured"

  19. Offline


    Getting the same problem as oskar , also when i check the multiverse-core file i only get a file called debug and debug.lok with both nothing in them , please help
  20. Offline


    Is this updated for 1.2.3?

    Cause on the console&server on every command it says 'an internal error has occoured'

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  21. Offline


    Hello everyone, I am seeking a little help. I have a world that i am trying to import into my server, but whenever i do it imports a world with no buildings, just the environment. When i load it into MCedit, everything is there. Any suggestions? Thanks!
  22. Offline


    Thanks for a great plugin. I have now a server with a starter world that is vanilla minecraft, with gates to worlds where you only are let in with spoutcraft client. Now I am looking at doing the same with tekkit (http://www.technicpack.net/tekkit/) which uses a branch of spout. Basically having a world with only tekkit clients let in. Have anyone had any experience in what I am attempting? Does the world have to run as a seperate server process to work?

    Any help would be appriciated.
  23. You're trying to use the AB, which is stated that was built for MC 1.1 with 1.2.3. See the dev builds at http://ci.onarandombox.com.

    General rule of thumb: Dev/Beta build of bukkit: Dev/Beta build of all plugins.
  24. Offline


    Also noticed the world aliases and colors now work with PermissionsEx...not sure if that's from this most recent update but thanks for getting that fixed finally :D
  25. Offline


    SAME problem for me! my players go to spawn but only ops and admins spawn where they log out, its very annoying
  26. Offline


    It Says For Me An "An Internal Error Has Ucorred: Please Help:mad:
  27. Offline


    I had portals fully set up and stuff, but now they are broken and the commands wont work.

    (MVPortal.java:65) [0m
    at com.onarandombox.MultiversePortals.MVPortal.loadMVPortalFromConfig(MVPortal.java:155) [0m
    at com.onarandombox.MultiversePortals.MultiversePortals.loadPortals(MultiversePortals.java:197) [0m
    at com.onarandombox.MultiversePortals.MultiversePortals.onEnable(MultiversePortals.java:122) [0m
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215) [0m
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:336) [0m
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381) [0m
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:250) [0m
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:232) [0m
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:374) [0m
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:361) [0m
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187) [0m
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425) [0m
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:490) [0m
    10:19:02 [INFO] [EssentialsGeoIP] Enabling EssentialsGeoIP v2.8.3 [0m
    10:19:02 [INFO] [EssentialsGeoIP] This product includes GeoLite data created by MaxMind, available from http://www.maxmind.com/. [0m
    10:19:02 [INFO] [Multiverse-NetherPortals] Enabling Multiverse-NetherPortals v2.4-b527 [0m
    10:19:02 [INFO] [MultiVerse-NetherPortals] - Version 2.4-b527 Enabled - By Rigby and fernferret [0m
    10:19:02 [INFO] [ChestShop] Enabling ChestShop v3.39 [0m
    10:19:02 [INFO] [ChestShop] WorldGuard version 5.5.2-SNAPSHOT loaded. [0m
    10:19:02 [INFO] [ChestShop] Vault loaded using economy plugin Essentials Economy [0m
    10:19:02 [SEVERE] [ChestShop] WARNING! Your spawn-radius in bukkit.yml isn't set to 0! You won't be able to sell to shops built near spawn! [0m
    10:19:02 [INFO] [EssentialsChat] Enabling EssentialsChat v2.8.3 [0m
    10:19:02 [INFO] [Factions] Enabling Factions v1.7.4_dev [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] === ENABLE START === [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] Loading board from disk [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] Found and will integrate chat with EssentialsChat v2.8.3 [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] Economy integration through Vault plugin successful. [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] NOTE: Economy is disabled. You can enable it with the command: f config econEnabled true [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] Successfully hooked to WorldGuard. [0m
    10:19:02 [INFO] [Factions v1.7.4_dev] === ENABLE DONE (Took 371ms) === [0m
    10:19:02 [INFO] Server permissions file permissions.yml is empty, ignoring it [0m
    10:19:03 [INFO] Done (9.264s)! For help, type "help" or "?" [0m
    10:19:03 [INFO] [Citizens] Loaded 8 NPCs. [0m
    10:19:03 [INFO] [Citizens] Loaded 0 quests. [0m
    10:19:03 [INFO] / lost connection [0m
    10:19:03 [INFO] GroupManager - INFO - Bukkit Permissions Updated! [0m
    10:19:21 [INFO] Disconnecting 99ark [/]: You are not white-listed on this server! [0m
    First attempt at checking for presence of Bukkit RTK plugin...
    Bukkit RTK plugin found! Enabling heartbeats...
    10:21:27 [INFO] / lost connection [0m
    10:23:42 [INFO] / lost connection [0m
    10:24:34 [INFO] krihelion [/] logged in with entity id 580 at ([world] 10019.391525963021, 70.0, -10101.434895484519) [0m
    10:24:42 [INFO] [PLAYER_COMMAND] krihelion: /time day [0m
    10:24:58 [SEVERE] null [0m
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvp' in plugin Multiverse-Portals v2.4-b538 [0m
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42) [0m
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:166) [0m
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:473) [0m
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:821) [0m
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:781) [0m
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:764) [0m
    at lishid.orebfuscator.hook.NetServerHandlerProxy.a(NetServerHandlerProxy.java:117) [0m
    at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:33) [0m
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:229) [0m
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113) [0m
    at lishid.orebfuscator.hook.NetServerHandlerProxy.a(NetServerHandlerProxy.java:60) [0m
    at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78) [0m
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:554) [0m
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452) [0m
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:490) [0m
    Caused by: java.lang.NullPointerException [0m
    at com.onarandombox.MultiversePortals.commands.SelectCommand.runCommand(SelectCommand.java:49) [0m
    at com.pneumaticraft.commandhandler.multiverse.CommandHandler.checkAndRunCommand(CommandHandler.java:279) [0m
    at com.pneumaticraft.commandhandler.multiverse.CommandHandler.processFoundCommands(CommandHandler.java:143) [0m
    at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand(CommandHandler.java:93) [0m
    at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand(CommandHandler.java:71) [0m
    at com.onarandombox.MultiversePortals.MultiversePortals.onCommand(MultiversePortals.java:312) [0m
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40) [0m
    ... 14 more [0m
  28. Offline


    I am having a lot of problems. With this PermissionsEx and Button Warp. My members can warp to the creative world I have but their gamemode wont change. But I can change the settings so their gamemode will cange and mobs wont spawn whn I dont want them to. But then the members cant warp to the world. Also I need the permissions for this plugin.

    I also cant change pvp between worlds like I was before

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Offline


    players cant get trough my portals. is there some config i'm missing, i can't find one
  30. Offline


    I gave my players tp permissions for a certain creative world, but they can use that to tp to players located in other worlds. Any way I can restrict their tp to players in their current world?
  31. Offline


    So the multiverse access isnt working for other worlds. It works for like one but no matter what it will not allow plays to go to other worlds even thought i have it set up for it.

    I have the most current builds for cb and multiverse

Share This Page