[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Hello. Great mod and I've been using it nearly since it has come out. With v2, I see that you can set prices for the use of the portals. In our server, we don't have an economy mod but instead use an item. How can I set the price of the portal use to be a # of that item? For example, if we use feathers, how do I set portal use to 50 feathers? Thank you.
  3. Offline


    This plugin looks pretty awesome, I will definitely be using it.

    Just to make sure I understand, this plugin enables links between multiple worlds on one server, but not functionality to link worlds on separate servers, correct?
  4. can a dev merge MV core and MV portals into one jar file?
  5. Offline


    Is there anyway I can edit permissions per world like each of my worlds have different permissions??
  6. Offline


    I was wondering if someone could help me out. I have created another world with the SKYLANDS environment, i have "Inception" installed, so when i ascend up high enough i go to the skylands. After i see the loading screen my game crashes without me ever actually being teleported into the new map. I am using CB 1060 with MV 2.0.
  7. Offline

    Codex Arcanum

    I just installed MV 2.0 (using the very helpful instructions provided), and after doing so, I am getting this very mysterious error when anyone joins the game, giving them an end of stream error. I know that this problem may or may not stem directly from MV, but any ideas? Thanks in advance.

    Show Spoiler

    13:39:19 [SEVERE] java.lang.NullPointerException
    13:39:19 [SEVERE] at java.lang.System.arraycopy(Native Method)
    13:39:19 [SEVERE] at java.io.BufferedOutputStream.write(BufferedOutputStream.java:111)
    13:39:19 [SEVERE] at java.io.DataOutputStream.write(DataOutputStream.java:90)
    13:39:19 [SEVERE] at net.minecraft.server.Packet51MapChunk.a(Packet51MapChunk.java:88)
    13:39:19 [SEVERE] at net.minecraft.server.Packet.a(Packet.java:116)
    13:39:19 [SEVERE] at net.minecraft.server.NetworkManager.f(NetworkManager.java:107)
    13:39:19 [SEVERE] at net.minecraft.server.NetworkManager.d(NetworkManager.java:263)
    13:39:19 [SEVERE] at net.minecraft.server.NetworkWriterThread.run(SourceFile:107)
  8. Offline


    Will upgrading from 1.7.2 to Multiverse 2.0 break the current portals?
  9. Offline


    Ok, I've got an odd one here! Not sure where to start, or which mod may be causing the issue, or if it's by design, but here goes.

    Bukkit was always out of reach, because I run IC/BC servers. Well, with a new fellow doing custom ports of ModloaderMP mods, I was able to move to the land of Bukkit. FANTASTIC!

    Got everything working well, runs so smooth, like butter, and the plugins are all cooking along nicely!

    WELL!! With the addition of Bukkit, I was finally able to run the Multiverse plugin. Got it all working nicely as well!

    HOWEVER! ACK!!!!

    Any world that isn't the PRIMARY world that the server starts with, the buildcraft pipes don't work!! The extractor pipes suck items from their respective places, the blocks look like they're going down the pipe, and then each block also pops out of the pipe onto the ground!

    I confirmed this by switching worlds around. The primary world always runs fine, any additional worlds, you get full IC functionality, but the BC pipes do not function.

    Now, since this is a custom port of a mod of a beta game running on top of a plugin developed by other people, I have no idea where to start. Is this a Multiverse proplem? Is this a buildcraft problem? Is this a Bukkit problem? Is there a way to fix this? The world may never know!

    Up until this fantastic bit of code, there were no secondary worlds running under Multiverse running buildcraft! I have no idea how to begin trying to fix this issue!

    Any ideas on where to start, or who I might report this to as a possible issue? Kind of hard with with all these layers, I'd appreciate any ideas. I tried setting up servertoserver tp, but CraftProxy doesn't like the packets in IC/BC, I believe.

    Other than the weird "buildcraft pipes not working in secondary worlds" issue, Multiverse is freakin AWESOME!

    Thanks for any input!!!

  10. Maybe. I'm a PermissionsBukkit fanboy. Try it out and let us know. I'm sure they have a bridge.

    All the MV devs use PermissionsBukkit. This is also what we test MV with.

    Yep you sure can. Currently it is limited to items the player can hold. Ie: you can't currently charge more than 64 of an item.

    Just use: /mvm set currency ITEMID
    And: /mvm set price HOWMANY

    That is correct. The primary reason for this is that this is not supported natively by minecraft. I've heard there are Spout plugins that do though, and it should work fine with those.

    Nope. We've spent months seperating them. They make it a lot easier to maintain and update. If you can wget one file, it's just a yyp away from 2 files!

    PS: vim reference in there :p

    This is up to your permissions plugin. The developers use and provide limited support for PermissionsBukkit.

    I have heard there are issues with Inception. Try removing it, and then just teleporting to skylands. If you don't get a crash, then you can go talk to those developers. If you do, come back to us and post a stack trace.

    It does not.
    I think this may be your issue, from the op:
    "People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version."

    If you don't have Spout, post your entire serverlog to pastebin.com and we'll go from there.

    It should not. We have included a migrator that we think we've gotten all of the bugs out of. Try it. If it explodes, try the Portals Dev version

    Oh wow... that's quite the setup you've got there. This is (in my opinion) a BuildCraft problem. Now my rationale for saying that is simply put: MV works great with Bukkit, and all stock Bukkit plugins (that I know of) work with it. You've introduced an extra level of modification that I'm not sure is supported. So i'd go talk to the buildcraft guys about multiworld support (MV simply uses the multi-world functions that are built into Bukkit).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  11. Offline


    Any progress with iConomy 6 support? :)
  12. Offline


    It doesn't recognize my original world.
  13. Offline


    How would I edit different world permissions through permissions bukkit?
  14. perm group setperm user creative:multiverse.* true
    perm group setperm user world:multiverse.* false

    Those 2 commands would give a group 'user' ALL MV2 perms in a world 'creative' and NO MV2 perms in a world 'world'

    It's in the dev builds. I'll get it promoted to an AB (Awesome Build, similar to Bukkit's RB, but named AB to avoid confusion) soon.

    MV2 does this on purpose and there's a long reason that I will type out in the wiki sometime. But not now.

    Just do: /mv import NAME normal

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  15. Offline


    Getting this in console once in a while, at start up, and variously at other times (possibly on teleport to from world to world.)
    Show Spoiler
    18:30:20 [INFO] [Multiverse-Core] - Version 2.0-b218 Enabled - By Rigby and fernferret
    18:30:20 [INFO] [AllPay] - Version .5.1 - hooked into BOSEconomy Multiverse-Core v2.0-b218
    18:30:20 [INFO] [Multiverse-Core] - Multiverse Config -- Loaded
    18:30:20 [INFO] [Multiverse-Core] - World Config -- Loaded
    18:30:20 [INFO] Preparing start region for level 2 (Seed: 3728061572168267695)
    18:30:20 [INFO] [Multiverse-Core] Loading World & Settings - 'Vres' - NORMAL
    18:30:21 [INFO] Preparing start region for level 3 (Seed: 6265770135705327848)
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@68
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@69
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6a
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6b
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6c
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6d
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6e
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@6f
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@70
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] Wrong location! net.minecraft.server.EntityChicken@71
    18:30:21 [INFO] 167.5,-290.5(10,-19) vs -7,35
    18:30:21 [INFO] [Multiverse-Core] Loading World & Settings - 'Sehnall' - NORMAL
    18:30:21 [INFO] Preparing start region for level 4 (Seed: 2095213626937920524)
    18:30:22 [INFO] [Multiverse-Core] Loading World & Settings - 'Aria' - NORMAL
    18:30:22 [INFO] Preparing start region for level 5 (Seed: 7031250695946269565)
    18:30:22 [INFO] [Multiverse-Core] Loading World & Settings - 'Sidhe' - NORMAL
    18:30:22 [INFO] Preparing start region for level 6 (Seed: -2762805607240605818)
    18:30:23 [INFO] [Multiverse-Core] Loading World & Settings - 'Maere' - NETHER
    18:30:23 [INFO] [Multiverse-Core] Loading World & Settings - 'Sandbox' - NORMAL
    18:30:23 [INFO] Preparing start region for level 7 (Seed: -3579348296476534770)
    18:30:23 [INFO] [Multiverse-Core] Loading World & Settings - 'Ucitel' - NORMAL
    18:30:23 [INFO] [Multiverse-Core] 7 - World(s) loaded.
    18:30:23 [INFO] [MultiVerse-Portals] - Version 2.0-b168 Enabled - By Rigby and fernferret
    18:30:24 [INFO] [MultiVerse-Portals] 24 - Portals(s) loaded
    18:30:24 [INFO] ObsidianFlow: Enabled. (Version:

    I was getting it before MV2, but was blaming Bukkit because I had ZeldaChickens installed. I am now in the process of restoring the server from scratch, and didn't have ZC installed yet. I hadn't noticed it at start up before, so didn't connect it with MV. Was only getting the wrong locations messages up until now.

    Any idea what this is, or were we right, and it is a Bukkit fault? Suspecting a corrupted world as another possibility, and while this particular world "Vres" isn't that vital and could be trashed, I would like to narrow down what is causing it in case it happens in a more important world. Help is appreciated :) and thanks for the great plugin!
  16. Assuming you're talking about the Wrong Location stuff? That's not really a MV message as we tag all of our messages with [Multiverse-PLUGIN]

    I'd double check that you deleted the jar (can't really see from your server startup). Start your bukkit server vanilla (no MV even) see if it goes away.
  17. Offline


    Crisis averted.
  18. New Awesome Builds(AB) are out of all three!
    Changes in Core 2.0b-227
    * Add iCo 6 Support
    * Add MultiCurrency Support
    * Fix AllPay bugs when no econ was found
    * Allow /mvtp cannon-X
    Changes in Portals 2.0b-180
    * Add iCo 6 Support
    * Add MultiCurrency Support
    * Fix Bug in the Portal Migrator when importing portals with no destination
    Changes in NetherPortals 2.0b-182
    * Add iCo 6 Support
    * Add MultiCurrency Support
  19. Offline


    Okay, I am just going to assume it was a chicken problem (evil chickens!)

    I did an /mv purge command and got rid of chickens. No more errors. Don't know why it didn't occur to me to do that before. Still have no idea what was causing it. Maybe a corrupted chicken flock... hehehe.
  20. Offline


    k. But thinking now, i might have MV 1 and not MV 2 so when i get time i'll try and fix that. But i also had other plugins that didn't work so i'm still not going to jump to it.
  21. Offline


    I currently don't have much time to jump in irc since you are active at 4am my time. I will try later tonight, my post was basically pointing out the problem with new players spawning in in the old spawn point and not the one I have set via multiverse.

    To test it just remove the player.dat file then login, so it looks like it is not looking up the set spawn for players that have not been in the world before then it just falls back to the old spawn.(Which is what my other post was saying in how I found it strange that if you overwrite the spawn loaction in the world I am not sure how this occurs)

    Also when teleporting to the worlds on dynmap it shows the person to very quicky at the original spawn then at the portal, in game you do no see it this happens when the loadign screen is almost done. I'm just pointing this out as it has the same characteristics as the problem with new people spawning but only for a split sec. None the less it shows the person at the old spawn point.

    If I can I will jump into irc when I'm finished work hope I haven't confused you too much with my post.
  22. Offline


    Anyone know how to use the minecart thing? I tried to put a rail in it and it didn't do anything. I tried to look everywhere but I couldn't find out how ><.
  23. Offline


    Players are having issues using portals on the server. I get the following message. I checked to make sure opfallback is set to true (it is). using CB 1060. I can use them fine just not players (I even added the multiverse.portal.access.* to the players permissions and still not working)

    Any Ideas?

    Just download Multiverse Core Version 2.0-b227 and Multiverse Portals Version 2.0-b168 from the download links above. It looks like the portals ver is different that what is listed?

    EDIT: Fixed! The link updated or something happened, it works fine with b180.

    2011-08-18 06:56:39 [SEVERE] Could not pass event PLAYER_MOVE to Multiverse-Portals
    java.lang.NoSuchMethodError: com.fernferret.allpay.GenericBank.getFormattedAmount(DI)Ljava/lang/String;
    at com.onarandombox.MultiversePortals.listeners.MVPPlayerListener.onPlayerMove(MVPPlayerListener.java:104)
    at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:286)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:174)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:527)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:435)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  24. Offline


    I'm sorry, but I have a quick question. What I'm looking for is some say to set a specific "zone", then make it so all/no people can come into/build on it. I know what I'm looking for is Regios, but I've hit a bug in that and don't know when the bug will be fixed. I came to this because it says "World Management Plugin". Does this do what I want? And if it doesn't, then can you please refer me to one that does (besides Regios and Towny)?

    the way I do it, is I just push it, then quickly get in. but you also have to make power rails, which will make it go faster after it's already going. you only need to place those every once in a while. oh, and they need to be powered, preferably by a redstone torch next to it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  25. Offline


    I already knew that :p I ment using minecarts with portals. Sorry if I wasn't very descriptive
  26. Offline


    oh....lol sorry, havn't used the plugin yet so idk...
  27. Offline


    Two odd issues, one with Multivers-core and one with Multiverse-Portals running on Bukkit1060.

    With Multiverse-core, if I try to mvtp to one of my other two worlds, I get "Multiverse did not teleport you to {world} becasue it was unsafe. Would you like to try to anyway?" /mvtp worked fine with these worlds prior to the upgrade, which ties into the portals problem...

    With Portals, I'm not being placed in the right place after I go through a portal. One portal in particular that I really noticed the problem was between {world1} and {world3}. When I go through the portal from {world1} to {world3} ({world3} is one of the worlds that mvtp claimed was unsafe), I get placed approximately 34 blocks above the portal on top of the hill over it and bouncing up and down like I spawned half in a block or someting. when I go throught he portal to return from {world3} to {world1}, I get placed near the portal, but bouncing up and down like I spawned half in a block. Prior to the update, they worked fine.

    I removed the updated jar files and config directories and placed the previous version back, and everything works normally.

    Any thoughts?
  28. Offline

    Mint Condition

    Two questions. One is a configuration question and one is a feature question:

    1) We're running Permissions. We actually just Upgraded to 3.x and use MCMA to manage it all. I'm still trying to wrap my brain around the millions of possible combinations of permissions setups. Currently all users can access all worlds. Do I need to abandon Perms 3 and convert everything to the built in perms system in order to prevent users from accessing other worlds? I did try to put a "-multiverse.access.Heaven" in the default group but people can still access the Heaven world.

    2) Is there a way to /mvtp to a specific portal?

    I lied... 3 questions. =)

    3) Is there a way for a single portal to offer multiple destinations?

  29. Offline


    Hey, I got everything working, Just wondering how to Set spawn in both world's. When i go into my new world, I type /spawn and it takes me back to the other world. Any help here?
  30. Offline


    /mv setspawn while standing where you want the current world's spawn to be.
    Rinse and repeat for each world.

    @Mint Condition
    I am not sure on the first questions, but am interested in knowing that, too.
    2nd question: mvtp p:portalname. I experimented with it last night, and except when I misspelled the name, it worked. even if you misspell it, it offers help on syntax. I haven't played to see how to do it with coords, but I am betting that works too.
    3rd: I thought you used to be able to do that with signs, but don't think you can anymore. I just set up a pseudo-stone henge with portals between and signs labeling where they go.

    Edit for first question:
    Show Spoiler

    Multiverse World Permissions

    Multiverse allows you to control who can enter worlds via permissions! When you create a world or import a world into Multiverse-Core, it automatically creates a permission: multiverse.access.WORLDNAME. If a player has multiverse.access.WORLDNAME, then they can enter that world.
    NOTE: Ensure you have opfallback disabled in your Multiverse config.yml. If opfallback is set to true (and it is by default currently) anyone can go to any world.
    If you give a user multiverse.access.* they can go to all worlds.

    which you already know, but maybe your "opfallback" is set to true?
    Show Spoiler

    Multiverse Portals Permissions

    Multiverse-Portals allows you to control who can use portals via permissions! When you create a portal, it automatically creates a permission: multiverse.portal.access.PORTALNAME. If a player has multiverse.portal.access.PORTALNAME, then they can enter that world.
    For this reason, Portals are caseinsensitive, meaning MyPortal is the same as myportal.
    NOTE: Ensure you have opfallback disabled in your Multiverse-Core config.yml. If opfallback is set to true (and it is by default currently) anyone can use any portal.
    If you give a user multiverse.portal.access.* they can go use all portals.

    These both sound promising. Going to try this tonight. Hope it helped you!
  31. Offline


    well my promblem isnt with the permissions its that i need some kind of seperate permissions yml for each world do you know if that is possible or if there is a plugin for taht i think it must be because of i know of server that have item spawning in one word and none in another thanks for your help btw.

Share This Page