[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Providing you dont use Multiverse portals to get to the Notch Nether then maybe? I'm not sure how Notch implemented his Nether.

    It is indeed, you'll need a plugin like WorldEdit to prevent portal blocks from dissappearing, then just give yourself the portal blocks and place them down. The only way to do it currently.
  3. Offline


    I just want to be sure that the vanilla portals will still work with multiverse.

    Hm, i tried it with WorldEdit but they're disappear. Both, the "//replace" and the replacer tool option won't work. Is there any trick?^^
  4. Looks like I missed one, I'll push a 1.7.2 sometime today, sorry :(
  5. Offline


    I've been having trouble with portal destinations across worlds, If your on the world it works but if you go from another world (via command or portal) you spawn 100 blocks-ish away. This is mainly a problem on my second world as it's just biospheres!

    I'm running worldborder, essentials, permissions worldedit and not much else. (on a linux box if it matters)
  6. Offline


    Have you tried updating to CraftBukkit build 819? There was a bug in 818 which caused problems during Teleporting.
  7. New VERY minor update. Fixes _s in mvmodify:

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
  8. Offline


    I dropped a feature request on the tracker, anything else need to be done or is that it?
  9. Offline


    Well it looks like one of 4 portals decided to work suddenly, though I have no idea how.

    This one is actually working, when I stand "in" the 2x3 portal space, on the block 2 blocks to the right of the [mv] sign

            price: 0.0
            destlocation: w:LavaCraft:spawn
            location: 4.0,69.0,-1.0:7.0,94.0,36.0
            owner: aoa2003
            world: DC3
    These 3 aren't working:

            price: 0.0
            destlocation: w:LavaCraft_nether:spawn
            location: -35.0,14.0,-8.0:-17.0,47.0,2.0
            owner: aoa2003
            world: LavaCraft
            price: 0.0
            destlocation: w:DC3:spawn
            location: 7.0,94.0,36.0:4.0,69.0,-1.0
            owner: aoa2003
            world: LavaCraft
            price: 0.0
            destlocation: w:DC3:spawn
            location: -1.0,62.0,-4.0:-4.0,69.0,0.0
            owner: aoa2003
            world: LavaCraft_nether

    1. build #819 did fix the "jumping all over the place" if teleporting between worlds

    2. If I enter the nether from DC3, I enter LavaCraft_nether, and if I then enter the portal I initially made, I enter LavaCraft. The other way around doesn't seem to work just yet however
  10. Make sure all the worlds you want are in your worlds.yml file.

    You may have to do an /mvimport LavaCraft_nether, also make sure you have 1.7.2, just released today.
  11. Offline


    Still having problems with Whitelists working.. Am I doing it wrong?
            animals: true
            pvp: true
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: -6:70:-27:89.25003:14.39999
            mobs: false
            price: 0.0
            environment: NORMAL
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: 'g:Admin,g:Donator,g:Donator1,g:Mod,g:VIP2'
            editBlacklist: ''
    Just says "Sorry but you cannot enter the 'vip2' world."
    Ive tried with just g:Admin which Im in. Ive also tried using blacklist to keep certain groups out.. no matter what I try it no worky :)
  12. Offline

    Trevor Bradley

    Not a critical issue, but I've tried "/mvcreate delta SKYLANDS", which creates the world just fine (and I can dynmap it to see it's there), but it I try to teleport to it with "/world delta", I get "Error: Hole in floor". Moving around in the world I'm in doesn't seem to help.

    Ideally if I can just get in there I'd be able to reset the spawn point or set a portal to a particular location, but I can't.

    Do I need to just keep trying to create the world over and over again until there's a spawn point I can land on, or am I missing something? (Bukkit 819, latest MultiVerse)
  13. Offline


    Is it just me or is this not working with Permissions 3? When I try e.g. /mvtp it says "You don't have the permissions to do that". I have * Permissions and I'm an OP, too.
  14. Offline


    A recent 'bugfix' broke worlds in sub-directories. Previously (1.6*) they would load and function correctly. Now they no longer load and instead I get this error:
    16:19:24 [INFO] [MultiVerse] 'worlds\survival' - Name contains invalid characters. Example - 'world23_nether'
    16:19:24 [INFO] [MultiVerse] 'worlds\survivalnether' - Name contains invalid characters. Example - 'world23_nether'
    I am not sure why this was changed because as I said they worked perfectly fine before (minus the commands that worked after a small(tm) edit by myself).

    edit: I noticed that the repo for 2.0 was created; can't wait for it :D.
  15. Offline


    I've set up these portals about every way possible, and it still seems to warp me to the EXACT same location on both worlds.
    I can't seem to get it to warp me anywhere else, I've even tried a different plugin. I've done almost everything.
    It keeps warping to the SAME PLACE, I've used p: and w: to warp to the worlds.
    It doesnt work when hopping WORLDS, but it works when hopping PORTALS in the SAME WORLD.

    It was working earlier, and just broke for some reason.
    Please help. :(
  16. Offline


    Yeah, they are in the worlds.yml

            animals: true
            pvp: false
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: 7:72:0:0.14942934:-6.450023
            mobs: false
            price: 0.0
            environment: NORMAL
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
            animals: true
            pvp: false
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: -7:83:-5:-0.30056763:6.2999787
            mobs: false
            price: 0.0
            environment: NORMAL
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
            animals: true
            pvp: false
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: 30:64:-49:0.0:0.0
            mobs: false
            price: 0.0
            environment: NETHER
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
  17. Everytime I try to create a Nether world it automatically changes from the "NETHER" environment to "NORMAL" after a server restart, any ideas on how to fix this?
    EDIT: in the worlds.yml file it still states the the environment is NETHER
  18. Offline


    Hello Lildirt :D Upgrade to Bukkit 819, that's a bug in 818.

    "/world delta" is not a Multiverse command. The command you are looking for is "/mvtp delta"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    hey multiverse work for me but i become often the notify:

    > 00:36:37 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:139)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:285)
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:199)

    whats wrong?
  20. Offline


    Our multiverse is completly messed up too.
    It appears that the new update caused all worlds center point move many miles off where they used to be and we also cant use any of the multiverse commands even if we are in Admins with * commands and OP.
  21. Have you updated? because for me the commands and spawns are working fine.
  22. Offline

    Trevor Bradley

    Perfect. Thanks!
  23. Offline



    I've 4 worlds, 2 normal and 2 in the nether (world1, world1_nether, world2, world2_nether). If I'm in world1, I want to build a portal with obsidian only, which create another portal automaticly in world1_nether. In world2, I want to make, with obsidian, a portal to world2_nether, etc.

    Is it possible with this plugin ?

    (sorry for my very bad english, I'm french :oops:)
  24. Offline

    Trevor Bradley

    Multiverse.yml has an autobuild=false.. you could try changing that to autobuild=true

    I haven't tried it myself though.

    Good Luck/Bon Chance! (Je suis Canadien, mais je parle francais tres tres pauvre aussi)
  25. Offline


    I second this guy-- this is precisely what I was looking for. If changing that value doesn't work, could this be implemented please? Thanks.
  26. Offline


    I am having a problem to where if a user dies in say the world Mole, they will respawn back in the world Morus(my server default). Is there a way I could fix this?
  27. Not in the current version of MV, this will be fixed in MV 2

    Not in the current version (MV 1.7.1), but I already have plans for this in MV 2.X :D

    Side note: Your english is very good and MUCH better than my french!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  28. Offline


  29. Offline


    BUG FOUND, possibly already mentioned.

    /mvcreate Skyworld skylands (works perfect)
    Warp to world, look around, ahhh pretty.
    Restart server, look around more, NORMAL world chunks start being generated...

    Or upon server restart or plugin reload it WILL start generating "NORMAL" world chunks!!

    also, "Error: Hole in floor" circumvented by just /mvtp THEN /mvspawn instead of /world. Worked for me just fine.
  30. Offline


    this happened to me earlier. the new build (#820) fixes it.
  31. I'll take a look at this in a bit, bit busy with a secret project (MV2).

Share This Page