[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    @Trevor: You are listed as an Admin in both, Admins have access to everything with the "- '*'" node as I'm sure your aware. So if your doing the testing yourself, unless you change what group your in you will be able to do anything you want.

    The permissions files look okay to me otherwise
  3. Offline

    Trevor Bradley

    I actually did my testing on two computers: one as a "Default" user, using the "Admins" user on another computer to test I still had access. The world specific info sections work fine, but not permissions.

    The last time I had something like this it was a mod conflict. I should probably test this with *just* Multiverse and Permissions to see if it works then.
  4. Hey guys,

    No i'm not dead. I'm undergoing graduation and a move, I'll be scarce around here for a few weeks until I get my dev environment setup!

  5. Offline

    TEM Vogelwurst

    is it somehow possible to fill the portal with item ID 90 (portal) . Because in MP everytime a portal is set next to another portal they all disappear.
  6. Warning, this broke my world seeds - causing my entire world to become snow, i used an old level.dat (and i don't think this helps, but i also copied session.lock) cleaned out the snow in mcedit, then started server and bam a normal world.
  7. Offline


    I can't create a portal. When i don't put anything after the commands, it displays examples of commands. But whenever i try to as an example... say, make a portal, it just says " An internal error occured" . I am OP and i have the permissions. The wooden pickaxe to select portals also doesn't work. /mvtp also gives me " an internal error occured" I deleted multiverse and all its folders and installed the newest just now and nothing has changed. It still doesn't work.
  8. Offline


    When an internal error occured you normally get an error log in the console. I think it would be helpful if you post it here.

  9. Offline


    cant create new portals dont know if its a bug or anything but i type /mvpc portalname and it says you havent selected the co ordinates yet any help with this i think i have the latest version unless u have updated from my last comment
  10. Offline


  11. Offline


    I cannot create a portal. It always kepps saying "you have not set your coordinates yet".
  12. Offline


    Tried on permissions 3 beta and bukkit 803 get this error.

    Happened on updating the permissions beta to the latest build just then.

    01:59:21 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
            at com.onarandombox.Rigby.MultiVerse.MVTeleport.canEnterWorld(MVTeleport.java:330)
            at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:290)
            at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:285)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:131)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:292)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  13. Offline


    Same things here... Can't set up a portal. "You haven't set your coordinates yet". Why? :/
  14. Offline


    I <3 this plugin :p
  15. Offline


  16. Offline


    Look for a world repair program, there is one out there, it will either be able to fix the chunk, regenerate it or you will lose the world, here is hoping for the best
  17. Offline

    Der Bruder

    Hi, i get an error when i decieded to teleport back at my default world.
    I can't create an portal or use the command /mvtp world. Then it says 'An internal error occured while attemping to perform this command.
    It only happens when i want go back to my default world.
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvtp' in plugin MultiVerse v1.6.4
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:675)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:638)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:632)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NullPointerException
        at com.onarandombox.Rigby.MultiVerse.MVCommands.MVTP(MVCommands.java:595)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:245)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
  18. Offline


    worldguard but it effects nothing

    make sure your bukkit version is
    [766] :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    its the version its not compatible with the new bukkit so....
    PLEASE UPDATE PLX!!!!:mad::)
  20. Offline


    is there a way to set the default world? Or will this just recognize the server.properties world name as the default? In that case can i just change this to the another world name and it be the default?

    EDIT: seems like that worked lol :)
  21. Offline


    if you switch the world names exple:
    world2= new world u want as default
    rename world2 to "world" and rename/delete "world"
  22. Offline

    Trevor Bradley

    OK, Day 2 of whacking at this. I wanted to try recreating it. At first I was about to recreate the expected condition... where properties were not inherited.. Then a bit got flipped somewhere and it changed back. I tried to recreate the situation from scratch and things got crazy... Here's how things happened:

    1) Create a base minecraft/bukkit install.
    2) Install ONLY Essentials (base), Multiverse, Permissions.
    3) Create default world, and another world called Beta using Multiverse
    4) Set up permissions, so that on world, the player can ping, but not on Beta.
    5) Verify this is working as expected.
    6) Rename world to Alpha, in server.properties, the world directory, Multiverse/Worlds.yml, Permissions/world.yml
    7) Verify that Permissions are now inherited.. Users can ping from Beta
    8) Rename Alpha back to world in all the places above
    9) Verify things are *still* broken, and that Beta can ping when it shouldn't be able to.

    I'm about to lose it here. Any thoughts?

    Here's an idea... Here's a zip file of my broken setup. Anyone who can figure out what's up gets major life karma.


    EDIT: Solved it. Secondary worlds cannot start with capital letters. Beta -> beta solves the problem. (Only took about 3 hours. That's what I get for being an incessant problem solver!)

    A little more info.. I'm on Ubuntu Linux, which means "Beta" and "beta" aren't the same thing in the filesystem... likely that's relevant.
    jbMurdock likes this.
  23. Offline


    I don't like to pressure developers, but this plugin is now a few RBs behind, and its very crucial to our server and I would really appreciate an update.
    I understand development takes a while, but it would be nice to see the first post updated with some progress news.
    Unless of course you're waiting for 1.6 and releasing an updated one then, but even if that is your plan, please keep people informed in the first post.
    flap likes this.
  24. Offline


    im using it with 803 fine at the moment.

    Just wish he'd fix group-whitelist on portals :)
  25. Is there any way to delete every item in someone's inventory when they pass through a certain portal or do I have to get another plugin for that.
  26. Offline


    search multiinv
  27. thanks a bunch!
  28. Offline


    How come my Nether world is stored in Nether/DIM-1/region?
  29. Offline


    Because nether is generated in DIM-1?
    Makes sense to me
  30. Offline


    Check how the nether worlds are stored in vanilla, they're just in a subfolder for some reason.

    And we've had a few issues on my server which seem to have originated from this plugin, like last night one of the admins was logging in and out trying to fix a graphical bug on his end and the whole server crash and this plugin stopped working, listing only 2 out of 7 worlds we have and not allowing the /mvtp command. Could be unrelated, though I don't have access to the server logs atm so I can't check.

    Still, as I said above, would be nice to at least have this confirmed to work with 803 in the original post so I can start looking at other less likely plugins.
  31. Offline


    I'm getting some issues. My server is crashing for no reason (according to logs). It just crashes with no errors. Remotetoolkit throws a heartbeat error and has to forcibly restart the server.

Share This Page