Inactive [EDIT/MECH] Buildr v0.7.1 - Toolbox for creative servers [1.2.4-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by s1mpl3x, Jul 10, 2011.

  1. Offline


    Toolbox for faster and easier building

    Version: 0.7.1 [1.1-R4]
    Version 0.5+ Includes a huge contribution from @Relick Thanks!


    Over at BukkitDev => link


    Buildr is a collection of useful tools to make building/creating stuff easier and faster. The key features of Buildr are the two buildmodes and the structure builders.
    The Globalbuildmode offers Worldbased enhancements to building, while the Userbuildmode gives a single player some handy tools. While the modes are disabled you can play minecraft without any effect.
    Buildr comes with a detailed configuration file so you can modify its behavior to fit to your needs.

    Video showing some of the structure builder and the tree feller

    Global build mode:
    While a world is in the Globalbuildmode, it won't get dark and the weather won't change - so you can build without beeing interruped because you have to change the weather or set the time to see your creation again. Also blocks won't drop items in this world so the floor isn't flooded with useless items.

    • no nighttime -> alway sun
    • no storm/thunder
    • no itemdrops
    User build mode:
    While a user is in buildmode blocks will break (almost) instantly if the player uses a Pickaxe (any of them), the inventory won't get flooded by useless items (pickups disabled), players won't get damaged, blocks are unlimited (stacksize is always 64). Last but not least cutting down trees is quite a pain, but while in buildmode players can fell a tree with just one click of an axe. You can Lock or Unlock the buildmode for a world or generally lock/unlock it, just have a closer look at the config/permissions.

    • Second inventory while in Buildmode
    • Instant Block Break
    • Godmode
    • Unlimited Items
    • No itempickups
    • Treecutter removes trees instant
    Basic Structure builders:
    You can build walls, floors/ceilings,cuboids,spheres,half spheres, cylinders easily with the build-commands of Buildr. Just type the command (see below) and click 2 blocks and Buildr creates these structures for you. The 3-Dimensional structures can be build hollow and all structures have a replace function. You can use wool as material with every structure builder. Just use wool:color as material in the command. And just like the Treecutter you can undo every action you perform with those builders with the /undo or /bu command.
    • /wall builder
    create Walls (or floors/ceilings) easily with just 2 clicks and this command usage: after you typed in the command you have to rightclick on the two blocks between the wall should be build while holding a stick. the line described by the 2 blocks must be parallel to at least one axis
    • /wallx builder
    allows you to create walls that aren't parallel to one of the axis
    • /cuboid builder
    allows you to create Cuboids (Great tool to begin your house with if you set it to hollow).
    • /sphere builder
    allows you to create a sphere. They can be solid or hollow.
    • /halfsphere builder
    allows you to create a half sphere. Can be solid or hollow.
    • /cylinder builder
    allows you to create a cylinder. They can be solid or hollow.

    Example for the replace-function:
    /cubeoid wool:red r1
    this command will replace all stone blocks in the selected area with red wool
    /wall 2 r3
    this command will replace all dirt blocks in the selected area with grass

    Other features:
    /wool command
    gives you a stack of wool in the specified color

    /top command
    Ports the user to the highest Block at its current position

    /airfloor command
    this command allows you to place one block or even a floor direct above yourself. usage: /airfloor

    /gv command
    gives items directly to a player or yourself.
    "/gv 4" would give yourself a stack of 64 Cobbleston
    "/gv stone 20" would give yourself a stack of 20 Stone
    "/gv noob 20 40" would give noob a stack of 40 Glass

    /gvx command
    gives you a stack of items with the specified datavalue
    /gvx 17:1 gives you redwood log

    /clearinv command
    wipes the inventory

    /location command
    gives the location of the block beneath the player

    /port command
    ports the player to the block he is currently facing.

    /undo command
    allows the user to undo his latest actions performed with the treecutter, airfloor tool and all builders (wall, cuboid, sphere etc.)

    All commands have short aliases for faster access. See below:

    Show Spoiler

        description: Toggles the Global Buildmode for the world you're in
        aliases: [gb,gbm]
        usage: |
              Example: /<command>
        description: Toggles the User Buildmode
        aliases: [ub,bm]
        usage: |
              Example: /<command>
        description: Unlocks/Locks the activation of the buildmode in the world you're in. Kicks all users out of buildmode on lock. Only has a Effect if BUILDMODE_BUILDMODE_REQUIRE_ALLOW is true
        aliases: [ab,abm,allowbm]
        usage: |
              Example: /<command>
        description: Starts the wall building function
        aliases: [wl]
        usage: |
              /<command> <material #> {rReplace}
        description: Starts the wallx building function
        aliases: [wlx]
        usage: |
              /<command> <material #> {rReplace}
        description: Starts the cuboid building function
        aliases: [cube,cu]
        usage: |
              /<command> <material #>  {rReplace} {h|hollow}
        description: Starts the sphere building function
        aliases: [ball,sp]
        usage: |
              /<command> <material #>  {rReplace} {h|hollow}
        description: Starts the half sphere building function
        aliases: [hball,hsp,hsphere]
        usage: |
              /<command> <material #>  {rReplace} {h|hollow}
        description: Starts the cylinder building function
        aliases: [cyl,tube]
        usage: |
              /<command> <material #>  {rReplace} {h|hollow}
        description: places a block (area) of material x y blocks above the player
        aliases: [af,airf]
        usage: |
              /<command> <material #> <height #>
              Example: /<command> 4 20 3
        description: gives a Stack of wool in the specified color to the player
        usage: |
              /<command> <color>
              Example: /<command> black
        description: ports the player to the highest block at its current position
        usage: |
              Example: /<command>
        description: Undoes the lastest action the player used (airfloor, wall)
        aliases: [bu,buildrundo]
        usage: |
              Example: /<command>
        description: gives a Stack of items to the player
        aliases: [gv,g]
        usage: |
              /<command> <player> <itemid #|itemname> <amount #>
              Example: /<command> 20 50 gives a stack of 50 Glass to the player
        description: gives a Stack of items with the specified datavalue to yourself
        aliases: [gvx,gx]
        usage: |
              /<command> <itemid:data> <amount #>
              Example: /<command> 17:1 50 gives yourself a stack of 50 Redwood Log
        description: clears the inventory of the player
        aliases: [clrinv,ci,cleari,clear,clearinventory]
        usage: |
              Example: /<command>
        description: returns the location of the block under the player
        aliases: [loc,gps]
        usage: |
              Example: /<command>
        description: ports the player to the block that he is looking at
        aliases: [jmp,go]
        usage: |
              Example: /<command>

    Show Spoiler

    Commands: - /build command
    buildr.cmd.globalbuild - /globalbuild command
    buildr.cmd.allowbuild - /allowbuild command
    buildr.cmd.wall - /wall command
    buildr.cmd.wallx - /wallx command
    buildr.cmd.cuboid - /cuboid command
    buildr.cmd.sphere - /sphere and /halfsphere command
    buildr.cmd.cylinder - /cylinder command
    buildr.cmd.airfloor - /airfloor command - /top command
    buildr.cmd.undo - /undo command
    buildr.cmd.give - /give command
    buildr.cmd.clearinv - /clearinv command
    buildr.cmd.location - /location command

    buildr.feature.treecutter - required to use the treecutter
    buildr.feature.jump - required to use /jump
    buildr.feature.compassjump - required to jump using a compass
    buildr.feature.instantblockbreak - required to use the instantblockbreak (pickaxe) while in buildmode
    buildr.feature.instantblockbreakall - required to use the instantblockbreak (all items) while in buildmode (not able to break bedrock even with the permission below)
    buildr.feature.break_bedrock - allows the breaking/replacing of bedrock with the instantblockbreak pickaxe and the build commands
    buildr.feature.block_info - if the user rightclicks a block with a stick, detailed information about the clicked block will be printed

    rest is not done yet... might add it on demand but the limitations in the configfile should work for most situations

    • none atm.
    • v0.7.1
      • fixed typo in config file
    • v0.7
      • removed inventory-swap
      • added a config value for auto-gamemode change triggered by the buildmode cmd
      • renamed the give and givex command to gv and gvx
      • improved command feedback
      • added a block info tool for the stick
      • Buildr is now firing BlockBreak and BlockPlace events, so it (should) now respect Protection/Region Plugins
      • using the new event system
      • code improvements
    • v0.6.1
      • fixed /allowbuild permission
    • v0.6
      • added givex command
      • removed support for permissions2/3. Bukkitperms is the only supported system now.
      • all builder now have a replace input instead of the aironly stuff
      • fixed wallx builder
      • fixed bug caused by the Pinapp 2 plugin
      • code restructuring
    • v0.5.4
      • fixed player handling on login
    • v0.5.3
      • possible fix for the inventory swap bug
    • v0.5.2
      • fixed /reload inventory confusion
      • fixed bug with inventorystatefile
      • fixed worlds not being set to globalbuild via config
      • added config-value for keep buildmode over a disconnect
      • added config-value for forcing users to buildmode if a world is in globalbuildmode
      • added config version detection. If your version is outdated, a new config is created and the old one is renamed so you can easily convert your old settings over.
    • v0.5.1
      • added config value for the instant block break with all items
    • v0.5
      • added possibility to enable Globalbuildmode on startup in config (Thanks @Relick )
      • added possibility to break blocks with every item in hand while in buildmode (see permissions above) (Thanks @Relick )
      • added possibility to use jump with a compass in hand (see permissions above) (Thanks @Relick )
      • /jump command doesn't require the user to be in buildmode anymore (Thanks @Relick )
      • implemented rudimentary build-in bukkit permission support (untested). I recommend to use the old system for now
    Show Spoiler

    • v0.4.4
      • added permission check for bedrock breaking to the build commands
    • v0.4.3
      • added permission for bedrock block break
    • v0.4.2
      • bugfix for unlimited items
    • v0.4.1
      • added permission for instantblockbreak
    • v0.4
      • added /jump command
      • added the possibility to use wool with the builders ( /cuboid wool:blue)
    • v0.3.1
      • fixed treecutter bug where it would stop working after a attempt to fell a to big tree
    • v0.3
      • fixed timecheck for the globalbuild mode
      • added a sphere/half-sphere and cylinder builder
    • v0.2
      • minor bugfixes
      • added cuboid and wallx builder
    • v0.1
      • initial release
    r3Fuze and Relick like this.
  2. Offline


    how you type it in? /wall 5 r2 would replace all Grass with planks
  3. Offline


    Was typing it like it was previously, "/cuboid 3 r". Like what you typed, the first number in the line still is what material, but what is the number after the r?
  4. Offline


    the numer with the r infront is the material that you want to have replaced by the other material. so if you want the old aironly you use r0
  5. Offline


    Ah, gotcha, ok. I read the new info on it but I couldn't for the life of me understand how to use it. Thanks. :3
  6. Offline



    I'm OP on my server and I have all permissions, but when I try this command : /allowbuild, I give this message in the chat :
    CB Build :#1060.

    Thank You.

  7. Offline


    @Swadon I named one of the permissions wrong, should be fixed in 0.6.1. Thanks for your report!
  8. Offline


    Oh okay, thank you :)

    Edit : Yes, it works ;)

    Spelling mistake in the post :
  9. Offline


    thanks, fixed ;)
  10. Offline


    I installed this plugin and got bug. I have toomanyitmes, so simply just open inventory and click items u want, it worked fine before I installed this. After installing this when I spawn items with toomanyitems I can't see the items, but i got them and if I use the empty block on my inventory that item comes on it. So basically I get item/block I want with toomanyitems but I ca'nt see it before using it. This problem came with this plugin.
  11. Offline


    this is a general problem of toomanyitems as the author stated:
  12. Offline


    Am I the only one whit this error 'An internall error occured while attemping to perform this command'
  13. Offline


    which command? and what version of craftbukkit and buildr are you using?

    Thats a pretty vague errorreport, cant help without more info
  14. Offline


    craftbukkit wher can i see wich one I use?,
    Buildr version Version: 0.6.1

    Craftbukkit 1.7.2

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  15. Offline


    @hatchling /version ingame, and what command did you use?
  16. Offline


    Minecraft beta 1.7.3 and it is whit every command I use
  17. Offline


    hm what other plugins do you have installed? i don't think that it is caused by this plugin..

    also if you type /version the bXXXXjnks part is the important
  18. Offline


    git-bukkit-0.0.0-904 -g9277069-b953jnks (MS: 17.2)


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  19. Offline


    well b953 is pretty old, you should update to 1060.
    and the plugins look ok, what permission plugin is it exactly?
  20. Offline


    I have here my log

    2011-08-23 20:44:30 [INFO] Starting Minecraft server on
    2011-08-23 20:44:30 [WARNING] **** FAILED TO BIND TO PORT!
    2011-08-23 20:44:30 [WARNING] The exception was: Address already in use
    2011-08-23 20:44:30 [WARNING] Perhaps a server is already running on that port?
    2011-08-23 20:45:10 [INFO] Stopping server
    2011-08-23 20:45:10 [SEVERE] Exception in thread "Thread-3"
    2011-08-23 20:45:10 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    2011-08-23 20:45:10 [SEVERE]     at java.util.ArrayList.RangeCheck(
    2011-08-23 20:45:10 [SEVERE]     at java.util.ArrayList.get(
    2011-08-23 20:45:10 [SEVERE]     at net.minecraft.server.MinecraftServer.stop(
    2011-08-23 20:45:10 [SEVERE]     at
    2011-08-23 20:45:11 [INFO] Starting minecraft server version Beta 1.7.2
    2011-08-23 20:45:11 [INFO] Loading properties
    2011-08-23 20:45:11 [INFO] Starting Minecraft server on
    2011-08-23 20:45:11 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-08-23 20:45:11 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-08-23 20:45:11 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-08-23 20:45:11 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-08-23 20:45:11 [SEVERE] Could not load 'plugins/mysql-connector-java-bin.jar' in folder 'plugins': Jar does not contain plugin.yml
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    2011-08-23 20:45:11 [SEVERE] while parsing a block mapping
     in "<reader>", line 43, column 1:
    expected <block end>, but found BlockMappingStart
     in "<reader>", line 52, column 4:
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.composer.Composer.composeNode(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.composer.Composer.composeDocument(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.composer.Composer.getSingleNode(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
    2011-08-23 20:45:11 [SEVERE]     at org.yaml.snakeyaml.Yaml.load(
    2011-08-23 20:45:11 [SEVERE]     at org.bukkit.util.config.Configuration.load(
    2011-08-23 20:45:11 [SEVERE]     at
    2011-08-23 20:45:11 [SEVERE]     at<init>(
    2011-08-23 20:45:11 [SEVERE]     at
    2011-08-23 20:45:11 [SEVERE]     at
    2011-08-23 20:45:11 [SEVERE]     at com.nijiko.permissions.ModularControl.forceLoadWorld(
    2011-08-23 20:45:11 [SEVERE]     at com.nijiko.permissions.ModularControl.loadWorld(
    2011-08-23 20:45:11 [SEVERE]     at com.nijiko.permissions.ModularControl.load(
    2011-08-23 20:45:11 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-08-23 20:45:11 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-08-23 20:45:11 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-08-23 20:45:11 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(
    2011-08-23 20:45:11 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(
    2011-08-23 20:45:11 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-08-23 20:45:11 [SEVERE]     at
    2011-08-23 20:45:11 [SEVERE]     at
    2011-08-23 20:45:11 [SEVERE] [Permissions] Unable to load permission data.
    2011-08-23 20:45:11 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    2011-08-23 20:45:11 [INFO] [Permissions] (Yeti) was initialized.
    2011-08-23 20:45:11 [INFO] [Permissions] (Yeti) disabled successfully.
    2011-08-23 20:45:11 [INFO] Preparing level "world"
    2011-08-23 20:45:12 [INFO] Preparing start region for level 0 (Seed: 10110101)
    2011-08-23 20:45:12 [INFO] Preparing start region for level 1 (Seed: 4049912006344920230)
    2011-08-23 20:45:13 [INFO] Preparing spawn area: 8%
    2011-08-23 20:45:13 [INFO] SignLift - Copyright 2011 - Shannon Wynter (
    2011-08-23 20:45:13 [INFO] SignLift version 0.7 is enabled :)
    2011-08-23 20:45:13 [INFO] [ToolRepair] iConomy not found.
    2011-08-23 20:45:13 [INFO] [ToolRepair] Version 1.3 loaded.
    2011-08-23 20:45:13 [INFO] [ToolRepair] Developed by: [vanZeben]
    2011-08-23 20:45:13 [SEVERE] Error occurred while enabling HomeX v0.7 (Is it up to date?): com/nijikokun/bukkit/Permissions/Permissions
    java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Permissions
        at Method)
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 12 more
    2011-08-23 20:45:13 [INFO] Lockette version 1.3.8 is being enabled!  Yay!  (Core version 1.0)
    2011-08-23 20:45:13 [INFO] Lockette: Detected craftbukkit build [953] ok.
    2011-08-23 20:45:13 [INFO] [Permissions] (Yeti) disabled successfully.
    2011-08-23 20:45:13 [INFO] Lockette: Failed to link to Permissions plugin version 3.1.6!
    2011-08-23 20:45:13 [INFO] Lockette: Using ops file for admin permissions.
    2011-08-23 20:45:13 [INFO] Lockette: Ready to protect your containers.
    2011-08-23 20:45:13 [INFO] [RSPassword v1.0] Enabled!
    2011-08-23 20:45:13 [INFO] [Buildr] Buildr v0.6.1 loading..
    2011-08-23 20:45:13 [INFO] [Buildr] Config: Version OK
    2011-08-23 20:45:13 [INFO] [Buildr] loaded settings.cfg
    2011-08-23 20:45:13 [INFO] [Buildr] using bukkitperms
    2011-08-23 20:45:13 [INFO] [Buildr] Listener registered
    2011-08-23 20:45:13 [INFO] [Buildr] command executors set
    2011-08-23 20:45:13 [INFO] [Buildr] started TimeThread
    2011-08-23 20:45:13 [INFO] [Buildr] Buildr v0.6.1 loaded
    2011-08-23 20:45:13 [INFO] Done (0.184s)! For help, type "help" or "?"
    See for your self


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  21. Offline


    well i suggest you start a clean new server install on the newest RB, just keep your world and get a up to date permissions plugin and switch to BukkitPerms. There are alot of errors from different plugins, also your server doesn't bind on the port it want to... just do a reinstall of the server, should be faster then fixing everything on this installation
  22. Offline


    Alright, I will do that
  23. Offline


    can u please make it so i can give myslef unlimited items like if i wanted unlimited torch i wouldnt have to replace them everytime i run out. like there would be no number next to the item and i could just place it an unlimited amount of times. thx
  24. Offline


    @cash425 just enable the buildmode, then you have unlimited stacks
  25. Offline


    how and thx fo responding

    ok i just enabled it what command do i need too type in to let me get unlimited of 1 item

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  26. Offline


    Suggestion: add Flight to the User Build Mode. This is a must for big projects.
  27. Offline


    Need help, i have problems with permissions, it don't work but i have everythings fine... i dont understand and i don't have permission to use plugins command. ''you don't have permissions to do this action.'' even if i take off permissions plugins, it don't work, and i'm Op... Need help
  28. Offline


    Same here, i have the - '*' permission, and i'm op... still can't use any of the commands (you don't have permissions to do this action)
  29. Offline


    @Thekilin @Ozo you are aware that Buildr uses Superperms/Bukkitperms however you call em?You might want to try the buildr.* permission
  30. Offline


    Ok, what's wrong with Permissions 3.x? ^^
    Is there something i've missed, should i revert to one of those systems you think?
    Yea, i tried with the buildr.* permission aswell!
  31. Offline


    @Ozo The BukkitPermission system is build in, so i as a developer don't have to use a 3rd party system.

    you might want to switch to bPermissions, PermissionsBukkit, PermissionsEx or any other Permission system that uses the build in permission system

Share This Page