[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline


    It should work just fine, working for me.
  3. Offline


    It kept crashing the server when using /b fd since that happened the owner wont but it back till the bug is fixed :/ Just wondering when it will be updated!
  4. Offline


    Do you know how to answer my questions:


    Member Since:
    Jun 25, 2011

    OMFG! how do you get invisible blocks, I watched your YouTube videos. Something to do with negative values? how!​
  5. Offline


    From what I have seen playing on The Voxel Box its todo with some of their plugins that allow you to paint in blocks, im not sure HOW they got them but I know how to place them :D best login to the server and ask!
  6. Hi, first let me say that this is a truely amazing plugin and thank you for creating it :). Second, i have read the wiki's instructions and the replies to similar problems on this thread but i am still unable to use voxel sniper. Whenever i use a command it comes up with
    "/b select-radius
    Example: /b 5 -- sets a brush radius size of 5(11 spaces across).
    Example: /b idr -- sets an ink disc replase brush."

    I have my username in the snipers.txt and i have added all the new blocks into the items.txt, i am also an OP.
    If anyone can help me out it would be much appriciated :)
  7. Offline


    I'm slightly irritated. I updated Voxelsniper expecting it to be better, and instead I find someone removed the feature that I used the most... I particularly enjoy the gunpowders Crouch+Right click delete tool... but now it's become something that is of no use to me (data variable crap.) Is there a way I can change it back to the delete tool? Please.

    Other than that, this is one of the best plugins I've ever used.

    You have to set yourself as an Administrator in Permissions. just edit Globalusers config in the /plugins/permissions folder.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  8. Offline


    Don't listen to this dude, he's a silly goose. A very silly goose.
  9. Offline


    I have a problem. It seems the gunpowder tool behaves the same as the arrow tool when using a brush to create blocks. This is highly annoying. I'm trying to make my own terrain on a flat bedrock world, using the voxel brush with sand, size 5. I right click on the bedrock with my gunpowder tool (which should CREATE blocks ON TOP OF the block I target), and it wipes the bedrock in the area and creates sand, which falls through the void, comes down from the sky, then destroys itself. Wtf? Anyone know why? :s
  10. Offline


    When I click Get it here it just goes to the Wiki and I can't download it there. Please help.
  11. :L Thanks anyway, even if it was that, i am an admin already. Any idea's about what it might be?
  12. Offline


  13. Offline


    So I read through the documentation and I don't see a way to do what I'm particularly trying to do, which is select a large area (select corners) and set the land to a nice level height of 72. Sort of like canyonator but instead of lowering sea level and leaving land, just replace everything above said height with air and everything under said height with stone with a couple of blocks of dirt and grass above it. Is there a way of doing this that I missed? (Can canyonator do it and just I can't understand the instructions?)
  14. Offline


    I would also like to know this as I have the same issue.
  15. I've tried all the usual things and they've not worked so i might as well look into the unusual, what other plugins are you running? and i know it's been said that it's not a compatability issue but like i said - just looking into the unusual.
  16. Offline


    Currently I'm running:
    • Autosave
    • Glowstone Lanterns
    • Multiverse-Core
    • Multiverse-NetherPortals
    • Multiverse-Portals
    • PermissionsEx
    • Remote Bukkit
    • Rules
    • TimeAndWeatherControl
    • VoxelSniper
    • WorldEdit
    • WorldGuard
  17. Offline


    Having the same issue,
    only other plugins are Essentials.
    It's my friends server don't know what bukkit but it's w/e servercraft.co is using right now.
    Latest VS.jar
    It's just an issue with the snipers.txt file

    I tried my name only (Avuja), no bueno.
    I tried his name only, works. (Same PC, same server)
    (Server restarts inbetween trying)
    I tried my name a bunch of different ways and no dice, no matter what I do VS thinks I don't have permission.
    Maybe something to do with the way premium acct names are handled?
  18. Offline


    Question: How do you get the replace brush?

    "/b br" doesn't seem to work. Says "No such brush".
  19. Look at Sniper V5 tutorial video in the main thread.
    basically :

    /b b
    /p mm

    i guess your perfomer might be wrong ...
    try to use the voxel brush (/b v), mat/mat performer (/p mm), voxelreplace to air (/vr 0) and voxel to sand (/v 12)

    i've to think twice every time, with the performer things. but it open somes nice possibilities.

    look more.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  20. Offline


    The download works, but I can't open it, nor move it.
  21. dropbox seems to have very slow response today .. guess you'll have to wait ....

    [edit] : "save as" on the dropbox link seems to works ... maybe chrome is messing up things.
  22. Offline


    Ok, so why hasn't anyone added an updated items.txt ?
  23. please, do :)
  24. Offline


    Is the problem with the use of /b fd making the server lag and crash? or is that fixed in the 5.019 update? Great plugin anyways!
  25. i think the ruler tools seems to crash too ... i will produce a log in a while.

    [edit] here is the log :

    13:53:14 [ATTENTION] [VoxelSniper] Exception while sniping: (Jay Ruler)
    13:53:14 [GRAVE] null
    java.lang.NumberFormatException: For input string: "14,87"
    at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
    at java.lang.Double.valueOf(Unknown Source)
    at com.thevoxelbox.brush.Ruler.roundTwoDecimals(Ruler.java:125)
    at com.thevoxelbox.brush.Ruler.rulerP(Ruler.java:118)
    at com.thevoxelbox.brush.Ruler.powder(Ruler.java:36)
    at com.thevoxelbox.brush.Brush.perform(Brush.java:143)
    at com.thevoxelbox.vSniper.snipe(vSniper.java:285)
    at com.thevoxelbox.VoxelSniperListener.onPlayerInteract(VoxelSniperListener.java:633)
    at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:330)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:171)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:142)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:560)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:471)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    13:53:45 [INFO] Stopping server
  26. Offline


    Any idea when a bug fix will be available? Also a nice feature that could be added is a black list so that the owner can choose which brushes are available to both Sniper and LiteSnipers, or compatibility with a permissions plugin!
  27. Offline


    I hope that you kids do understand that These are Exceptions and not 'crashes'. I will now explain this to you guys in a language that you should understand:

    'Crash' - denotes a system failure in which an application ceases to respond to user input (is frozen) or simply shuts down without user authorization.

    'Exception' - an error that occurs inside an application; likely due to user error.

    What you see there in the quote above gentlemen is an Exception. And an Exception CANNOT crash the server, especially one from within VoxelSniper. I have no idea what your playing here, but the stack trace will never go all the way down to the Thread.run(). There are at the least Two places along this road that catch any Exceptions - VoxelSniper handles all of it's exceptions, Bukkit also catches any exceptions thrown from within any event from any plugin. It is a protective shell you see.
  28. Offline


    Does this also apply for the 'crash' caused by /b fd? I will try and get log to post!
  29. a simple "thank you" for producing the trace would be enough.

    PS : i really dont give a shit about crash and exception. this is your job, not mine. if you dont want help, just continue to talk like that.
  30. Offline

    Mike Geitz

    I have mysteriously lost my voxel replace brush on my server; I've replaced the .jar and looked over the config and can't seem to solve the problem. Using /b vr returns 'No such brush' and using '/vs brushes' doesn't show it in the list.
  31. Offline


    When i try the commands it tell me how to use them, and what they do..... :( I can't use VoxelSniper, I can't even add snipers...... Help?

    Attached Files:

Share This Page