Inactive [EDIT/FUN] BlastPick - Clear your path. [1.1-RB]

Discussion in 'Inactive/Unsupported Plugins' started by gnftoxic, Mar 3, 2011.

  1. Offline

    Phear Chyld

    It would seem that BlastPick will crash the MC server if you type "/bp 1-" which is a fat finger of "/bp 10".

    2011-03-30 19:02:02 [SEVERE] Could not pass event PLAYER_COMMAND_PREPROCESS to BlastPick
    java.lang.NumberFormatException: For input string: "1-"
        at java.lang.NumberFormatException.forInputString(Unknown Source)
        at java.lang.Integer.parseInt(Unknown Source)
        at java.lang.Integer.parseInt(Unknown Source)
        at net.hailxenu.pick.bppl.onPlayerCommandPreprocess(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.NetServerHandler.c(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
  2. Any updates maybe?

    14:08:59 [SEVERE] BLOCK_RIGHTCLICKED loading BlastPick v1.0.0 (Is it up to date?
    java.lang.NoSuchFieldError: BLOCK_RIGHTCLICKED
            at net.hailxenu.pick.bpm.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.reload(
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleComma
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.h(
  3. Offline

    Phear Chyld

    Yea I also have the same issue as k03k.
  4. Offline


    A fix can't come quick enough, I miss this plugin already :)

    I tried to fix it myself from the source, but heh I'm not really sure what the problem is.
  5. Offline


    Yeah an update would be superb at this point :)
  6. Offline

    Phear Chyld

  7. Offline


    Haha. That's one way to get my attention, as I always check paypal.
    I've had a few server issues and I've been gearing more towards fixing up what needs to be fixed on my server rather than updating mods.
    I will update what I can today. I'll put BlastPick on the first of the list, since someone donated (even if it was just $2) for it :p

    Edit: BlastPick has been updated to version 1.0.1, CB#617
  8. Offline


    thanks for the update, only i get a 404 wen trying to download:(
  9. Offline


    Should be working now. My httpd was recompiling via cPanel.
  10. Offline

    Phear Chyld

    Got it D/Led. Thanks for the update d0oder!
  11. Offline


    Download is 404 not found. Can't wait to get the update version.
  12. Offline


    It's working for me - you might've clicked it when I was restarting my server.
  13. Thanks for updating this plugin! =D
  14. Offline

    Phear Chyld

    Thanks again for the update! :D

    Not sure if this is intended or not but instead of just the right mouse button removing blocks now both left and right mouse buttons remove the blocks.

    also I noticed this in my server logs:
  15. Offline


    I too am having the issue of removing a line of block behind me.

    Also, is it possible to change the bp so it can't remove bedrock? It's dangerous! A custom set of unremovable blocks would be kinda nice, actually...

  16. Offline


    Currently getting this error:
    I'm curious if it is something that I am doing wrong or didn't do correctly.
  17. Offline


    this mod interferes with my blueprint mod anyway to fix this?
  18. Offline


    Congrats, you've posted no information as to what you mean.
  19. Offline


    o im sorry um the blueprint plugin also uses /bp so is there anyway i can cahnge the regular command for this so that this plugin doesnt use /bp too
  20. Offline


    I am also having this issue. Did you intend this to happen? Latest version of BP and CB ver 670
  21. Offline


    He is saying that the blueprint plugin (that I am working on has an alias of /bp). As I see you use it I'll go ahead and remove that so they don't cause issues. I will be making a release in the next few minutes so it will be gone then.
  22. Offline


    you gotta fix permissions support
  23. Offline


    Permissions will be fixed tomorrow.

    Permissions support fixed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  24. Offline


    Hi gnftoxic, thanks for making this plugin for Bukkit.

    What I remember from before (hmod I guess) is that blastpick would only work when you'd right-click a block with the pickaxe. That way, if you'd just need one (stone) block removed, you could use the pickaxe normally still. That situation doesn't occur often, but it would be handy to be like that for when it does.

    This could of course be a configurable option.

    Also, a pet peeve of myself I guess. You determine what direction to remove blocks based on the position of the player, relative to the block you target, right? Could you make it an option that it would just use the face of the block you clicked on and remove blocks away from that face? Then I don't have to worry about orientation that much.
  25. Offline


    Right, I need to fix the right-clicking. I forgot about that, as I had reformatted my development partition, the save apparently hadn't been set in the latest version.

    Possibly, yes. I'll look into it.
  26. Offline


    Please update BlastPick for 733. This is an addon I can't live without!
  27. Offline


    Really, patience much? That build is just out for a few hours. Also, doesn't it work. Or didn't you even test yourself?
  28. Offline


    Some devs were still updating their plugins for the other 700 builds I just didn't know if you were going to wait for a new recommended or not.

    And yes I tried it on 733 and it does not work right, It only removes one block at a time, unless you are digging down. And on the old builds of craftbukkit it worked fine but if you would face a certain direction (I think it was east or west) it would clear out one block in front of you and the rest at the back.
  29. Offline


    First, I am not the developer of THIS plugin. I just thought it was a bit early to actively ask that question.

    But you provided some helpful information and hopefully that will be of use to gnftoxic.
  30. Offline


    Yes, I'm aware of some of the issues provided by the 689+ builds, and I'll be updating it as soon as I can, however we're doing state testing in my state, and it's a little bit more stressing than I expected.

Share This Page