[ECON] Jobs - The Job plugin for minecraft [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by phrstbrn, Jun 27, 2011.

  1. Offline


    I have a problem, When i leave job and join again my prefix title is still there like il join hunter it would say novice hunter, when i leave it would stay there
  2. Offline


  3. I suggest you try to add the farming blocker that mcMMO has. Because the way you block it now kinda sucks.. Miners maybe want to build a stonehouse but as of now the stone block gives them -XP and income just because we have to block farming.

    I don't know if its possible but maybe its worth a try?
  4. Offline


    Hey, I'm looking for a nice lightweight plugin for payments on my minecraft server. We use a moderate amount of plugins, and iConomy is one of them, and we need a good payment system to allow our players to earn money, but we don't want it to be super taxing on the server. Currently we have Wurkit, but believe since it logs every block placed for the payday period by all players, that it may be too much...

    Basically, I want to know if this plugin is more efficient/lightweight, or if there is another payment plugin anyone suggests that isn't super exploitable. Thanks to anyone who helps.
  5. Offline


    This looks awesome, gunna try it sometime soon.
    Needed another form of earning money for the server.
    Also, a great addon would be website a website(forum) integration?
    Create a separate .php file and have basically a rank system of who was earned the most from x amount of jobs.
    Somethin like that.
  6. Offline


    i want to ask :p
    the current version supports PermissionsEx? cuz im having a lot of troubles xd
  7. Offline


    Hello! I have the latest Bukkit version, and Jobs v2.5.6, and before i have installed PermissionsEx it was working normally, but now, it says that:

    2011-11-08 22:32:16 [SEVERE] Error occurred while enabling Jobs v2.5.6 (Is it up to date?): null
    at com.zford.jobs.dao.JobsDAO.getConnection(JobsDAO.java:91)
    at com.zford.jobs.dao.JobsDAOH2.setUp(JobsDAOH2.java:52)
    at com.zford.jobs.dao.JobsDAOH2.<init>(JobsDAOH2.java:47)
    at com.zford.jobs.config.JobsConfiguration.loadGeneralSettings(JobsConfiguration.java:145)
    at com.zford.jobs.config.JobsConfiguration.reload(JobsConfiguration.java:97)
    at com.zford.jobs.Jobs.reloadConfigurations(Jobs.java:293)
    at com.zford.jobs.Jobs.onEnable(Jobs.java:113)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:941)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:174)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:157)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)

    Ok forget, i have managed it :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  8. Offline


    Hey, how can you make it so, that you disable titles even though you can have 2 jobs?
  9. Offline



    i have install the plugin. I have set all permissions to the Admin Group, but i cant chose a job (i´m op too but also without op it doesn´t work). I use the standard configs.

    I can show the info of each jobs; the "browse" command says "there is no jobs for you to join" and the "join" commad says "You do not have permission to do that".
    Theres no errors in the log!

    On my server are CB1337, PermissionEx and iConomy 6 - all with MySQL storage - Jobs plugin too - and some other plugins.
  10. Offline


    If you want to pimp your server, use the pimp your sever forum. Posting in plugin threads is very disrespectful to the plugin dev who owns this thread. I have deleted that post.
    der_robert likes this.
  11. Offline


    yeah im getting the same over here with permissionEx, i think thats the problem
  12. Offline


    FOr some reason, this plugin seems very unstable.

    Any time I edit any of the config.yml (s) (and I parse them and everything afterwards to make sure it is correct) then restart the server, the entire jobs plugin just crashes and doesn't work... even if its just a little change to the yml.

    Why is this happening?

  13. Offline


    i was having the same problem chisox, i think you need to delete your h2 database and restart again :/
  14. Offline



    I have the problem solved!/
    I've solved my problem!

    I hve this Perms Plugins:

    - permissionsEX
    - Permissions (comes with PermissionsEX i think) and
    - SuperpermsBridge

    after i delete the last one, all works fine! Users can browse the jobs, show the stats and leave a job and the users get xp and money!

    Here my permission nodes:

    all with standard configs !
  15. Offline


    hmm... what would that entale? Would everybody's job progress get deleted?

    Also, any idea why it would happen in the first place?
  16. @phrstbrn
    Could you make a level-up gift?
    Example: Player gets 20th level and gets once (once=only on this level-up) 100 dollars.
    Of course it should be configurable.
    Lots of [diamond] to you!
  17. Offline


    Whats the best way to see the entire player list with their jobs and levels?
  18. Offline


    My Jobs wont work ! Here is my JobConfig.yml

            fullname: Woodcutter
            shortname: W
            ChatColour: GREEN
            chat-display: full
            #max-level: 10
            #slots: 1
            leveling-progression-equation: 100*((1.13+(0.01*(numjobs-1)))^(joblevel-1))
            income-progression-equation: baseincome*((1.05)^(joblevel-1))
            experience-progression-equation: baseexperience*((1.05)^(joblevel-1))
                    experience: 10
                    income: 1.5
                    experience: -10.0
                    income: -1.5
            fullname: None
            shortname: N
            ChatColour: WHITE
            chat-display: none
            #max-level: 10
            #slots: 10
            leveling-progression-equation: 100*((1.13+(0.01*(numjobs-1)))^(joblevel-1))
            income-progression-equation: baseincome*((1.05)^(joblevel-1))
            experience-progression-equation: baseexperience*((1.05)^(joblevel-1))
                # woodcutter
                    income: -5.0
                    experience: -5.0
                # miner
                    income: -4.0
                    experience: -4.0
                    income: -5.0
                    experience: -5.0
            fullname: Miner
            shortname: M
            ChatColour: DARK_GRAY
            chat-display: full
            #max-level: 10
            #slots: 10
            leveling-progression-equation: 100*((1.13+(0.01*(numjobs-1)))^(joblevel-1))
            income-progression-equation: baseincome*((1.05)^(joblevel-1))
            experience-progression-equation: baseexperience*((1.05)^(joblevel-1))
                    experience: 3.0
                    income: 2.0
                    experience: 1
                    income: 0.01
                    experience: 5.0
                    income: 6.0
                    experience: 5.0
                    income: 6.0
                    experience: 3.0
                    income: 4.0
                    experience: 4.0
                    income: 3.0
                    experience: 6.0
                    income: 10.0
                    experience: -4.0
                    income: -4.0
                    experience: -5.0
                    income: -5.0
                    experience: -5.0
                    income: -6.0
            fullname: Farmer
            shortname: F
            ChatColour: YELLOW
            Chat-display: full
            #max-level: 10
            #slots: 10
            income-progression-equation: baseincome*((1.05)^(joblevel-1))
            leveling-progression-equation: 100*((1.13+(0.01*(numjobs-1)))^(joblevel-1))
            experience-progression-equation: baseexperience*((1.05)^(joblevel-1))
                    experience: 50.0
                    income: 50
                    experience: 50.0
                    income: 50
                    experience: 50.0
                    income: 50
                    experience: 50
                    income: 50
                    experience: 5
                    income: 5
                    experience: 15
                    income: 15
                    experience: 50.0
                    income: 50
                    experience: 50.0
                    income: 50
    The YAML checkers say that there isnt any error, but there is. I just dont know what
    Tried to make it work with
    2.5.4 @ Build 1317
    2.5.4 @ Build 1337
    2.5.6 @ Build 1337
    2.5.6 @ Build 1344 Which it once worked on. Must be the config then.
  19. Offline


    I have one account, that signed up for 2 jobs (2 is max) Then he left one, and tried to sign for another but he can't. It gives no error. I have tried to /jobs employ name job - that doesn't work. Tried to fire him from the other job and then sign for a new. Doesn't work. Tried to fire hom from all jobs - still doesn't work.
    I tried to open jobs.h2 with notepad++ - that gives alot of wierd writing - what program do i need here?
    Or do you have any other way to reset an account?

    Bukkit - 1337
    Jobs 2.5.6
  20. Offline


    Anyone else besides me get this error?

    18:58:55 [INFO] [Jobs] - max-jobs property not found. Defaulting to unlimited!
    18:58:55 [INFO] [Jobs] - Job Woodcutter is missing the max-level property. defau
    lting to no limits !
    18:58:55 [INFO] [Jobs] - Job Woodcutter is missing the slots property. defaultin
    g to no limits !
    18:58:55 [INFO] [Jobs] - Job Miner is missing the max-level property. defaulting
    to no limits !
    18:58:55 [INFO] [Jobs] - Job Miner is missing the slots property. defaulting to
    no limits !
    18:58:55 [INFO] [Jobs] - Job Builder is missing the max-level property. defaulti
    ng to no limits !
    18:58:55 [INFO] [Jobs] - Job Builder is missing the slots property. defaulting t
    o no limits !
    18:58:55 [INFO] [Jobs] - Job Digger is missing the max-level property. defaultin
    g to no limits !
    18:58:55 [INFO] [Jobs] - Job Digger is missing the slots property. defaulting to
    no limits !
    18:58:55 [INFO] [Jobs] - Job Farmer is missing the max-level property. defaultin
    g to no limits !
    18:58:55 [INFO] [Jobs] - Job Farmer is missing the slots property. defaulting to
    no limits !
    18:58:55 [INFO] [Jobs] - Job Hunter is missing the max-level property. defaultin
    g to no limits !
    18:58:55 [INFO] [Jobs] - Job Hunter is missing the slots property. defaulting to
    no limits !
    18:58:55 [INFO] [Jobs] - Job Fisherman is missing the max-level property. defaul
    ting to no limits !
    18:58:55 [INFO] [Jobs] - Job Fisherman is missing the slots property. defaulting
    to no limits !
    18:58:55 [INFO] [Jobs] - Job Weaponsmith is missing the max-level property. defa
    ulting to no limits !
    18:58:55 [INFO] [Jobs] - Job Weaponsmith is missing the slots property. defaulti
    ng to no limits !
    18:58:55 [INFO] [Jobs] - Job None is missing the max-level property. defaulting
    to no limits !
    18:58:55 [INFO] [Jobs] - Job None is missing the slots property. defaulting to n
    o limits !
  21. Offline


    This isnt an error i think
  22. Offline


    Alright thanks Good Sir
  23. Offline


    I'm getting some MySQL error, periodically, which I havn't seen before.
    It happens after Jobs has been running for a few hours, and it'll sporadically occur when someone joins the game.
    Bukkit #1337
    Jobs 2.5.6
    Permissions: GroupManager
    2011-11-17 11:46:55 [SEVERE] com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet successfully received from the server was 34,571,120 milliseconds ago.  The last packet sent successfully to the server was 0 milliseconds ago.
    2011-11-17 11:46:55 [SEVERE] 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    2011-11-17 11:46:55 [SEVERE] 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    2011-11-17 11:46:55 [SEVERE] 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    2011-11-17 11:46:55 [SEVERE] 	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1116)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:3082)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:2968)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3516)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1986)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2140)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2626)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:2111)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:2273)
    2011-11-17 11:46:55 [SEVERE] 	at com.zford.jobs.dao.JobsDAOMySQL.getAllJobs(JobsDAOMySQL.java:72)
    2011-11-17 11:46:55 [SEVERE] 	at com.zford.jobs.config.container.JobsPlayer.<init>(JobsPlayer.java:70)
    2011-11-17 11:46:55 [SEVERE] 	at com.zford.jobs.Jobs.addPlayer(Jobs.java:237)
    2011-11-17 11:46:55 [SEVERE] 	at com.zford.jobs.listener.JobsPlayerListener.onPlayerJoin(JobsPlayerListener.java:41)
    2011-11-17 11:46:55 [SEVERE] 	at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:260)
    2011-11-17 11:46:55 [SEVERE] 	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    2011-11-17 11:46:55 [SEVERE] 	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:129)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:121)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:39)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:94)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:471)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-11-17 11:46:55 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-11-17 11:46:55 [SEVERE] Caused by: java.io.EOFException: Can not read response from server. Expected to read 4 bytes, read 0 bytes before connection was unexpectedly lost.
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.readFully(MysqlIO.java:2529)
    2011-11-17 11:46:55 [SEVERE] 	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:2979)
    2011-11-17 11:46:55 [SEVERE] 	... 21 more
    2011-11-17 11:46:55 [INFO] [Jobs v2.5.6] has been disabled succesfully.
    Like I said, I've never had a MySQL problem like this before, and all my other MySQL plugins work fine after Jobs gets this error and disables it self.
  24. Offline


    Is there a way to reward someone for tilling farmland? I don't know if that kind of functionality is in the API or not, but it'd be nice to have for Farmers.
  25. Offline


    Hello - I would like to report a problem when plugin is using MySQL connection on idle server. When server has no players for a long time MySQL connection times out. I've looked at the code of the Jobs plugin and I see that you have persistent connections stored in connections pool and always take already opened connection even when it is opened for like 24 hours. Default WAIT_TIMEOUT time for MySQL server is ~8 hours.
    When new player connects after 24 hours he will trigger following exception and jobs plugin disables itself.

    [SEVERE] com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: The last packet successfully received from the server was 49,938,112 milliseconds ago.  The last packet sent successfully to the server was 49,938,112 milliseconds ago. is longer than the server configured value of 'wait_timeout'. You should consider either expiring and/or testing connection validity before use in your application, increasing the server configured values for client timeouts, or using the Connector/J connection property 'autoReconnect=true' to avoid this problem.
    10:48:50 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    10:48:50 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    10:48:50 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    10:48:50 [SEVERE]       at java.lang.reflect.Constructor.newInstance(Unknown Source)
    10:48:50 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
    10:48:50 [SEVERE]       at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1116)
    10:48:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.send(MysqlIO.java:3348)
    10:48:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1967)
    10:48:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2140)
    10:48:50 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2626)
    10:48:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:2111)
    10:48:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:2273)
    10:48:50 [SEVERE]       at com.zford.jobs.dao.JobsDAOMySQL.getAllJobs(JobsDAOMySQL.java:72)
    10:48:50 [SEVERE]       at com.zford.jobs.config.container.JobsPlayer.<init>(JobsPlayer.java:66)
    10:48:50 [SEVERE]       at com.zford.jobs.Jobs.addPlayer(Jobs.java:1197)
    10:48:50 [SEVERE]       at com.zford.jobs.listener.JobsPlayerListener.onPlayerJoin(JobsPlayerListener.java:41)
    10:48:50 [SEVERE]       at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:260)
    10:48:50 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    10:48:50 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    10:48:50 [SEVERE]       at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:129)
    10:48:50 [SEVERE]       at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:121)
    10:48:50 [SEVERE]       at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:39)
    10:48:50 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:94)
    10:48:50 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:471)
    10:48:50 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    10:48:50 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    10:48:50 [SEVERE] Caused by: java.net.SocketException: Broken pipe
    10:48:50 [SEVERE]       at java.net.SocketOutputStream.socketWrite0(Native Method)
    10:48:50 [SEVERE]       at java.net.SocketOutputStream.socketWrite(Unknown Source)
    10:48:50 [SEVERE]       at java.net.SocketOutputStream.write(Unknown Source)
    10:48:50 [SEVERE]       at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    10:48:50 [SEVERE]       at java.io.BufferedOutputStream.flush(Unknown Source)
    10:48:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.send(MysqlIO.java:3329)
    10:48:50 [SEVERE]       ... 19 more
    I've tried adding ?autoReconnect=true to database name so it makes correct url, but it did not fix it.

    Possible solution for this would be:

    I hope it helps you to fix it :)
  26. Offline


    Could you make a feature so if you break a block too much you get less money???
  27. Offline


    I has been waiting a long time...
    plz v1.0 revision.... !!

    and plugin is not correctly woking kill reward at nether world or another world when 1.9 pre5
    but normal world was well worked.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  28. Offline


    @min - Keep in mind that this plugin was developed for, and is only approved for, Bukkit 1337 for 1.8.1. If it works on other versions, great, but you shouldn't be surprised when it doesn't.
  29. Offline


    Wow,where are the permsission code things??I cant find them for Jobs
  30. Offline


    It's on BukkitDev, linked in the OP.


Share This Page