[ECON] ChestShop 3.7.18 (iConomyChestShop) - Chest&sign shop for economy plugins [1.8]

Discussion in 'Archived: Plugin Releases' started by Acrobot, Feb 12, 2011.

  1. Offline


    An easy way to create shops - no protection plugin needed!
    You don't need to be on-line to earn money anymore!
    I've put a LOT of effort into making this plugin,
    you can donate if you appreciate my effort =)

    - An economy plugin supported by Register or Vault, for example iConomy, BOSEconomy or Essentials Eco.
    - For additional economy plugin support - Vault
    - For Permissions: bPermissions, PEX, or any other permission plugin
    - For additional protection: LWC, Lockette, Deadbolt
    - For other item names (aliases): OddItem

    Copy the .jar file from the .zip you downloaded into /plugins folder.
    You can also copy the example files if you want to generate statistics page.

    You can change the plugin's language, here's a list of all user-made translations.
    If you want to update or submit a translation, feel free to PM me.
    Translations (open)

    Arabic - Attarhsase2
    Bulgarian - Muff1Ncho
    Czech - LordPgsa
    Chinese (Simplified) - tab415263
    Danish - Cannafix
    Dutch - speedlegs
    French- DragonSlayer875
    German - RasCas
    Hungarian - Anachen
    Indonesian - Yahya98
    Italian - Massimo1993
    Korean - Zwing87
    Norwegian - _AlexN_ and TheUnkownGamer
    Polish - Holls1
    Portugese (Brasil) - FelipeMarques14
    Russian - VADemon from http://minemania.ru/
    Slovak - LordPgsa
    Slovenian - jEErc
    Spanish - thxaaaa
    Swedish - Maxell
    Turkish - Developer
    Traditional Chinese - hellboyincs
    Vietnamese - etrubi1 from http://minevn.com/

    How to create a ChestShop?
    - Place a chest, if you haven't already.
    - Place a sign 1 block near the chest (for example, above the chest)
    - On the sign, write:

    (Item name can actually be item ID or alias)
    First line will be filled in by the plugin automatically.
    Price is a combination of buy and sell price.
    You have to have B near buy price (people buy from you), and S near sell price (people sell to you).
    If you have both B and S, separate them with a colon - :
    For example:

    means that AcrobotPL wants to sell 64 diamonds for 10 currency, and buy them back from you for 5 currency.
    Also, if you put "free" instead of price, it is free to buy or sell :)

    - Now, when you finish editing the sign, if LWC is turned on in config, shop will be automatically created.
    Also, if your default protection is turned on in the config, people won't be able to break chest, sign or the block the sign is on.

    What is an Admin Shop?
    Admin shop is the shop that doesn't require a chest, because it has infinite stock.
    If you sell to it, the items will disappear, and if you buy from it, items will magically appear.
    To create one, you have to be Admin/OP. Just put "Admin Shop" (or anything specified in config file) on the first line of the sign.

    Restricting shops to some groups or regions
    You can either use permissions, or you can just put a sign ABOVE shop sign (you need to be in that group to create the sign) to restrict it to players with ChestShop.group.groupName permission
    The syntax is:
    Only those groups will be able to use that shop

    To restrict a shop to some regions:
    - If you're using Towny, turn TOWNY_INTEGRATION on. Residents will be able to create shops in economy plots (either their or, if specified in config, any)
    - If you're using WorldGuard, you can use an experimental "chestshop" flag. Turn WORLDGUARD_INTEGRATION on and flag a region. (f.e. /region flag ChestShopRegion chestshop allow)

    Do you want to limit the maximum prices for items?
    Well, there's an app.... wait, not that : P
    You can use an experimental feature in ChestShop.
    In your config.yml, add lines like:
    max-buy-price-5: 14
    max-sell-price-5: 15

    That means that the maximum price for items BOUGHT by PLAYER is 14, and items SOLD by PLAYER using the shop is 15.

    You can also use a global setting, like this:
    max-sell-price: 200

    That means that the maximum price for items SOLD to PLAYER is 200 (if there is, for example, a max-sell-price-5 found, it will be used instead of the global sell price)

    You could buy and sell by right and left clicking the sign for a long time.
    Now it's the only way to use the shops.
    It's SIMPLE!
    Just LEFT-CLICK to SELL to shop, and
    RIGHT-CLICK to BUY from shop.
    (This can be changed in the config file)

    If you want to delete your old shop, simply SNEAK and destroy the sign.
    It's that easy =)

    You can either open the chest and stock it up, or click on your own sign - it will open chest's inventory (that way you can have chests not openable by other people for sure :D)

    ItemInfo command
    It's a simple command that shows item information.
    If you use it without any arguments, it shows you information about the item you're holding.
    If you specify item id or item name after the command, it will show you information about that item.

    Source code
    ChestShop is Open-Source =)
    You can find its code on https://github.com/Acrobot/ChestShop-3

    Thanks to:
    - kali876, ziomekYOYO and Herocraft server for testing the plugin and finding every little bug =)
    - Everyone who uses this plugin - really big thanks for this, I never thought it will be so popular
    - Everyone who provided translation - many people's lives will be easier now
    - @Nijikokun for Register
    - @LennardF1989 for awesome Persistence Reimplemented
    - @Temaska for fixing the plugin while I was on holidays
    - @VADemon for providing a great support for other users
    - @Euthyphro for his patience and really good bug spotting
    - vagrant326 for making a great price sheet
    - Epics for his great help
    If something's not working
    You can't change the sign color - that breaks the formatting.
    If that's not the issue, please give me this information, so I can help you faster.
    - CraftBukkit version (type /version in chat)
    - ChestShop version (type /csversion in chat)
    - Your economy plugin (iConomy? BOSEconomy? other one?)
    - Have you got any Permission plugin? Which one?

    Changelog (open)

    Changelog can be found on BukkitDev - http://dev.bukkit.org/server-mods/chestshop/files/
  2. Offline


    Do /iteminfo
    It will tell you exactly what to put on the sign.
  3. Offline


  4. Offline


    It's because you have set the

    Just set it to "" and you'll be fine, or just give the server account 99999999999 money.
  5. Offline


    When comes a Update for 1.1? I wait... -.- Please answer!
  6. Offline


    Why would I need to update something that's working with 1.1 already? :)
    DanoLP likes this.
  7. Offline


    my problem is nobody can use the player shops atm... sign are made like in the describtion not even i as op on the server can use other players shop:confused: permissions are ChestShop.shop.sell .buy .create

    guess that should be right or not?

    thanks in adavance

    ps not even admin shops are working just tested
  8. Offline


    Go to bukkit.yml, change spawn-radius to 0.
  9. Offline


    nothing changed
  10. Offline


    Did you restart the server? (Not reload, but full restart)

    Also, can you post the /csversion?
    Oh, one more -> sometimes I saw something like a "bugged" chunk, try creating a shop 60 blocks away.
  11. Offline


    i got the actuall cs version ofc i just updated all my plugins just yesterday and ofc i restarted reooading is one of the most useless features bukkit gotxD ill try the 60 block stuff and reply after

    ok tried to restart and tried over 60 blocks away and still no use
  12. Offline


    Can I see the /csversion? It is actually needed to see if the plugin's loaded at all and which version exactly is it.
    Also, are there any errors in console?

    This might sound stupid, but have you got any economy plugin installed and working?

    Oh, also -> which CB build are you running?
  13. Offline


    No errors it sais chestshop version 3.33 initialized i use iconomy 6 an bukkit 1.1
  14. Offline



    How exactly does the sign look like?
    Is there any confirmation when you've created a shop?
  15. Offline


    yup its just normal it sais cs created succefully or something like that only thing is u cannot use it
    it sais u cant sell/buy here

    sign looks like

    Admin Shop
    B 10:5 S
    also the same with player shops and tried without B and S only selling nothing can be used always cannto buy/sell ehre
  16. Offline


    Hi there

    Shop 3.33
    bukkit latest 1.1

    2012-01-20 21:31:49 [SEVERE] Could not pass event org.bukkit.event.player.PlayerInteractEvent to ChestShop
    at org.bukkit.craftbukkit.inventory.CraftInventory.getItem(CraftInventory.java:30)
    at com.Acrobot.ChestShop.Utils.uInventory.addManually(uInventory.java:71)
    at com.Acrobot.ChestShop.Utils.uInventory.addManually(uInventory.java:60)
    at com.Acrobot.ChestShop.Utils.uInventory.add(uInventory.java:56)
    at com.Acrobot.ChestShop.Shop.Shop.buy(Shop.java:88)
    at com.Acrobot.ChestShop.Shop.ShopManagement.buy(ShopManagement.java:24)
    at com.Acrobot.ChestShop.Listeners.playerInteract.onPlayerInteract(playerInteract.java:80)
    at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:342)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:57)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:327)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:183)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:274)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:602)
    at net.minecraft.server.Packet15Place.handle(SourceFile:39)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:100)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:587)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:536)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:434)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

    Players can buy and get withdraw money. But they didnt get an item.
  17. Offline


    Well, you cannot buy/sell here means that the 3rd sign line is wrong, but it seems fine in your example.
    Can you create a shop like this:

    Admin Shop

    As you can see, it's a bug in bukkit, not ChestShop - I can't do anything about it, sorry :/
  18. Offline


    ok thanks it works;P problem was i puttedt in the BUY and SELL by hand without writing this it works
  19. Offline


    timmaeh: I have exactly the same problem.
    Acrobot: I must wait for new bukkit? Or what?
  20. Offline


    I have no clue, but I see that in the last commit EvilSeph reverted the change regarding getItem, so probably downloading a new version of CraftBukkit will fix it.
  21. Offline


    Hope so. But their Jenkins... :D

    EDIT: Works with new CB Build
  22. Offline


    I believe negative nodes are supposed to deny permissions without any inherited groups being able to have them granted back. Isn't this how PermissionsBukkit and GroupManager both work?

    So far, I have only come across two plugins which start by granting multiple permissions to the default group like this. ChestShop and PreciousStones.

    Every other plugin I've used works just fine because they don't start off by granting a bunch of permissions, except to ops.

    Doesn't it make more sense to simply have admins add the permissions and use inheritance? It is less to add for me anyway. I can still grant that whole section with .* if needed, without having to give it to the default group by default.

    Not trying to cause trouble or anything. Just wondering why only two out of all the many plugins I've used do it backward.

    The mod is working great now that I made this change too. I had to do the same with PreciousStones because it grants preciousstones.benefit.* to the default group by default....which doesn't make sense at all.

    Keep up the great work! :)
  23. Offline


    Well, the problem is when a player doesn't have any permission plugin.
    I can't check if there is any plugin that sets the permissions with SuperPerms, and when people don't use permissions, they couldn't use the plugin AT ALL.
    That's probably the biggest flaw in the system, unless somebody will tell me how to check for permission plugins NOT using Vault or any other external plugin.

    I just do what the Permissions in plugin.yml is supposed to :)

    If I were to project a permission plugin, I'd do it that if any group inherits a negative node, but it's set to positive again, it would grant him the permission back. (HintHint codename_B :p)

    Thanks again for your opinion :)
  24. Offline


    Acrobot that's how it works.

    default has negative node admin has positive node admin inherits default - players with admin group have positive node.

    At least that's how it works for bPermissions :/
    Acrobot likes this.
  25. Offline


    How would I make a shop sell Light blue wool & Light gray wool?
  26. Offline


    so if i change the name of the server acount it wont get infinite money? hatevbut i just gave it a bunch of money thatnks
  27. Offline


    Hey Acrobot, great plugin that I would love to implement for my players and although I have tried I cannot get it to work. The server loads up with no errors related to this plugin (there is one error related to the "Sunset" plugin but it works anyway lol) and I can create an Admin Shop successfully (it tells me that the shop was created) BUT when one of my players tries to access it they get the "You don't have permission to do that!" error message when trying to buy OR sell.

    Craft Bukkit Build #1744
    Permissions 2.7 (Phoenix)
    Chest Shop 3.33
    LWC 3.53
    iConomy 6

    Having read through most of the 200+ pages on this plugin I have tried editing the bukkit yml to reduce spawn radius to zero AND tried removing the permissions section altogether but neither effort has worked or changed the error. I have tried the permissions you listed (ChestShop.shop.buy, etc) as well as variations (Chest.shop.buy, chestshopbuy, etc) but again nothing works.

    Thank you for providing this plugin and for your patience/diligence in helping users. If you have any suggestions I would appreciate it as I would like to use your plugin.

    ~ TSRDM

    Server startup log:
    [INFO] Starting minecraft server version 1.1
    2012-01-17 14:48:06 [INFO] Loading properties
    2012-01-17 14:48:06 [INFO] Starting Minecraft server on *:25565
    2012-01-17 14:48:06 [INFO] This server is running Craftbukkit version git-Bukkit-1.0.1-R1-61-g5a1b91d-b1744jnks (MC: 1.1) (Implementing API version 1.1-R1-SNAPSHOT)
    2012-01-17 14:48:06 [INFO] [Permissions] (Phoenix) was Initialized.
    2012-01-17 14:48:06 [INFO] LWC: Loading shared objects
    2012-01-17 14:48:07 [INFO] LWC: Protection cache: 0/10000
    2012-01-17 14:48:07 [INFO] LWC: Native library: plugins/LWC/lib/native/Windows/amd64/sqlitejdbc.dll
    2012-01-17 14:48:07 [INFO] [Catacombs] version 0.8 is loaded
    2012-01-17 14:48:07 [INFO] Preparing level "TSR"
    2012-01-17 14:48:07 [INFO] Default game type: 0
    2012-01-17 14:48:07 [INFO] Preparing start region for level 0 (Seed: 199325409972349038)
    2012-01-17 14:48:07 [INFO] Preparing start region for level 1 (Seed: 199325409972349038)
    2012-01-17 14:48:07 [INFO] Preparing start region for level 2 (Seed: -1661959240892539479)
    2012-01-17 14:48:08 [INFO] Preparing spawn area: 93%
    2012-01-17 14:48:08 [INFO] [AlwaysSunshine] Starting
    2012-01-17 14:48:08 [INFO] (version 1.4 by Clever Error and base_case)
    2012-01-17 14:48:08 [INFO] [AlwaysSunshine] Running
    2012-01-17 14:48:08 [INFO] Appleseed: ShowErrorsInClient=true
    2012-01-17 14:48:08 [INFO] Appleseed: DropInterval=120 seconds
    2012-01-17 14:48:08 [INFO] Appleseed: MaxTreesPerPlayer=5
    2012-01-17 14:48:08 [INFO] Appleseed: MaxUncollectedItems=3
    2012-01-17 14:48:08 [INFO] Appleseed: MaxIsPerWorld=true
    2012-01-17 14:48:08 [INFO] Appleseed: WandItem=wood_hoe
    2012-01-17 14:48:08 [INFO] Appleseed: FertilizerItem=bone_meal
    2012-01-17 14:48:08 [INFO] Appleseed: MinimumTreeDistance=8
    2012-01-17 14:48:08 [INFO] Appleseed: SignTag=Appleseed
    2012-01-17 14:48:08 [INFO] Appleseed: TreeTypes=(golden_apple,apple,cookie,cocoa_beans)
    2012-01-17 14:48:08 [INFO] Appleseed: Permissions 2.7 found
    2012-01-17 14:48:08 [INFO] Appleseed: 0 trees loaded in world TSR.
    2012-01-17 14:48:08 [INFO] Appleseed: 0 trees loaded in world TSR_nether.
    2012-01-17 14:48:08 [INFO] Appleseed: 0 trees loaded in world TSR_the_end.
    2012-01-17 14:48:08 [INFO] Appleseed version 0.6.5 is enabled!
    2012-01-17 14:48:08 [INFO] ARG has detected Permissions
    2012-01-17 14:48:08 [INFO] [ARG] Checking/loading files...
    2012-01-17 14:48:08 [INFO] [ARG] Loaded 834 items from Regions.txt
    2012-01-17 14:48:08 [INFO] [ARG] Loaded 20 items from FriendsList.txt
    2012-01-17 14:48:08 [INFO] [ARG] Loaded 16 items from LastOnline.txt
    2012-01-17 14:48:08 [INFO] [ARG] Scheduling tasks...
    2012-01-17 14:48:08 [INFO] AutoRegionGuard version 0.4 is enabled!
    2012-01-17 14:48:08 [INFO] CommandBook 1.5.1 enabled.
    2012-01-17 14:48:08 [INFO] CommandBook: 0 banned name(s) loaded.
    2012-01-17 14:48:08 [INFO] CommandBook: 1 kit(s) loaded.
    2012-01-17 14:48:08 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    2012-01-17 14:48:08 [INFO] [EasyFlight] version [0.5] is Enabled.
    2012-01-17 14:48:08 [INFO] [Giant Trees] version 0.3.3 is enabled
    2012-01-17 14:48:08 [INFO] godPowers version 2.0 is enabled!
    2012-01-17 14:48:08 [INFO] [GravelClay] version 1.2.4 by [Darklust] is enabled.
    2012-01-17 14:48:08 [INFO] [HeroicDeath] 1.11.2 enabled.
    2012-01-17 14:48:08 [INFO] [iConomy - Celty] Enabled (10 ms)
    2012-01-17 14:48:08 [INFO] [MultiInv] version 2.4.2 is enabled!
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] - Version 2.0-b228 Enabled - By Rigby and fernferret
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] - Attached to Permissions
    2012-01-17 14:48:08 [INFO] [AllPay] - Version 1.0.3 - hooked into iConomy 6 for Multiverse-Core v2.0-b228
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] - Multiverse Config -- Loaded
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] - World Config -- Loaded
    2012-01-17 14:48:08 [INFO] Preparing start region for level 3 (Seed: 5616918127005512080)
    2012-01-17 14:48:08 [INFO] Appleseed: 0 trees loaded in world TSR_Skylands.
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_Skylands' - NORMAL
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_nether' - NETHER
    2012-01-17 14:48:08 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR' - NORMAL
    2012-01-17 14:48:08 [INFO] Preparing start region for level 4 (Seed: 598582805920947428)
    2012-01-17 14:48:09 [INFO] Appleseed: 0 trees loaded in world TSR_Skylands_nether.
    2012-01-17 14:48:09 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_Skylands_nether' - NETHER
    2012-01-17 14:48:09 [INFO] Preparing start region for level 5 (Seed: -343076274153780310)
    2012-01-17 14:48:09 [INFO] Appleseed: 0 trees loaded in world TSR_NOVA.
    2012-01-17 14:48:09 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_NOVA' - NORMAL with seed: -343076274153780310
    2012-01-17 14:48:09 [INFO] Preparing start region for level 6 (Seed: -254439240786660143)
    2012-01-17 14:48:09 [INFO] Appleseed: 0 trees loaded in world TSR_NOVA_nether.
    2012-01-17 14:48:09 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_NOVA_nether' - NETHER
    2012-01-17 14:48:09 [INFO] Preparing start region for level 7 (Seed: -4459946304584762670)
    2012-01-17 14:48:10 [INFO] Appleseed: 0 trees loaded in world TSR_AQUA.
    2012-01-17 14:48:10 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_AQUA' - NORMAL with seed: -4459946304584762670
    2012-01-17 14:48:10 [INFO] Preparing start region for level 8 (Seed: -9121625436959431867)
    2012-01-17 14:48:10 [INFO] Appleseed: 0 trees loaded in world TSR_AQUA_nether.
    2012-01-17 14:48:10 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_AQUA_nether' - NETHER
    2012-01-17 14:48:10 [INFO] Preparing start region for level 9 (Seed: -2324890876239962112)
    2012-01-17 14:48:10 [INFO] Appleseed: 0 trees loaded in world TSR_CINDER.
    2012-01-17 14:48:10 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_CINDER' - NORMAL with seed: -2324890876239962112
    2012-01-17 14:48:10 [INFO] Preparing start region for level 10 (Seed: -97478664800127209)
    2012-01-17 14:48:10 [INFO] Appleseed: 0 trees loaded in world TSR_CINDER_nether.
    2012-01-17 14:48:10 [INFO] [Multiverse-Core] Loading World & Settings - 'TSR_CINDER_nether' - NETHER
    2012-01-17 14:48:10 [INFO] Preparing start region for level 11 (Seed: -4632771386763384235)
    2012-01-17 14:48:11 [INFO] Appleseed: 0 trees loaded in world dungeon.
    2012-01-17 14:48:11 [INFO] [Multiverse-Core] Loading World & Settings - 'dungeon' - NORMAL
    2012-01-17 14:48:11 [INFO] [Multiverse-Core] 11 - World(s) loaded.
    2012-01-17 14:48:11 [INFO] [MultiVerse-NetherPortals] - Version 2.0-b182 Enabled - By Rigby and fernferret
    2012-01-17 14:48:11 [INFO] [MultiVerse-Portals] - Version 2.0-b183 Enabled - By Rigby and fernferret
    2012-01-17 14:48:11 [INFO] [MultiVerse-Portals] 8 - Portals(s) loaded
    2012-01-17 14:48:11 [INFO] [OutputHandler] Adding listener to Minecraft's logger
    2012-01-17 14:48:11 [INFO] [OutputHandler] Plugin enabled! (version 1.0)
    2012-01-17 14:48:11 [INFO] [Permissions] version [2.7] (Phoenix) loaded
    2012-01-17 14:48:11 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    2012-01-17 14:48:11 [INFO] [Multiverse-Core] - Attached to Permissions
    2012-01-17 14:48:11 [INFO] SleepAnnounce version 1.1.0 is enabled.
    2012-01-17 14:48:11 [INFO] Permissions plugin detected. Using it for SleepAnnounce.
    2012-01-17 14:48:11 [INFO] SpawnCreature is on!
    2012-01-17 14:48:11 [SEVERE] Error occurred while enabling SunSet v1.3.3.7-DEV (Is it up to date?): Found interface org.bukkit.command.ConsoleCommandSender, but class was expected
    java.lang.IncompatibleClassChangeError: Found interface org.bukkit.command.ConsoleCommandSender, but class was expected
    at net.D3GN.MiracleM4n.SunSet.SunSet.log(SunSet.java:41)
    at net.D3GN.MiracleM4n.SunSet.SunSet.onEnable(SunSet.java:31)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:230)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:977)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:190)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:173)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:356)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:343)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:175)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:407)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    2012-01-17 14:48:11 [INFO] Tombstone v.1.3.6 is enabled.
    2012-01-17 14:48:11 [INFO] [Tombstone] Using Permissions (v2.7)
    2012-01-17 14:48:11 [INFO] TreeFeller version 0.3 has been enabled.
    2012-01-17 14:48:11 [INFO] [Vanish2] 0.1.1 enabled.
    2012-01-17 14:48:11 [INFO] WorldEdit 4.6 enabled.
    2012-01-17 14:48:11 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2012-01-17 14:48:11 [INFO] [MultiVerse-Portals] Found WorldEdit. Using it for selections.
    2012-01-17 14:48:11 [INFO] [Catacombs] Looking for Permissions plugin
    2012-01-17 14:48:11 [INFO] [Catacombs] Found and will use plugin Permissions v2.7
    2012-01-17 14:48:11 [INFO] [Catacombs] Preferred payment method [any] not found, using first found.
    2012-01-17 14:48:11 [INFO] [Catacombs] Payment method found (iConomy version: 6)
    2012-01-17 14:48:11 [INFO] [ChestShop] Permissions version 2.7 loaded.
    2012-01-17 14:48:11 [INFO] [ChestShop] LWC version 3.53 loaded.
    2012-01-17 14:48:11 [INFO] [ChestShop] version 3.33 initialized!
    2012-01-17 14:48:11 [INFO] [ChestShop] iConomy 6 loaded.
    2012-01-17 14:48:11 [INFO] LWC: Loaded 137 locale strings (0 overrides)
    2012-01-17 14:48:11 [INFO] LWC: Permissions API: NijiPermissions
    2012-01-17 14:48:11 [INFO] LWC: Currency API: iConomy6Currency
    2012-01-17 14:48:11 [INFO] LWC: Loading SQLite
    2012-01-17 14:48:11 [INFO] LWC: Using: Native
    2012-01-17 14:48:12 [INFO] LWC: Precached 2249 protections.
    2012-01-17 14:48:12 [INFO] LWC: At version: 3.53 (b294)
    2012-01-17 14:48:12 [INFO] [Tombstone] Using LWC (v3.53)
    2012-01-17 14:48:12 [INFO] [mcMMO] Permissions version 2.7 found, using Permissions.
    2012-01-17 14:48:12 [INFO] Loading Config File...
    2012-01-17 14:48:12 [INFO] [mcMMO] Permissions version 2.7 found, using Permissions.
    2012-01-17 14:48:12 [INFO] mcMMO version 1.2.07 is enabled!
    2012-01-17 14:48:12 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2012-01-17 14:48:12 [INFO] Done (5.824s)!
  28. Offline


    Okay I'm having a similar issue, I'm able to make admin buy/sell shops, I add these 2 commands to a group
    ChestShop.shop.buy - lets you buy from shops
    ChestShop.shop.sell - lets you sell to shops

    Now when I try to buy/sell it works for both, but when the group i assigned the permissions to trying to buy, it allows them to buy, but it says nothing when they try to sell.

    Now i've tried it for:
    admin shop
    S 10


    admin shop
    B 10:10 S

    Now All my admins can use these shops, but the group i assign the permissions to, they can only buy & it says nothing at all when they try to sell.

    Any ideas on how to fix this?
  29. Acrobot What would happen to all the shops that are not currently in Shop plots when i change the setting? would they stop working? and is there anyway around that cuz i want a server shop at spawn but having it set as shop is just annoying
  30. Offline


    Uh oh.

    I can't use this plugin with iConomy InventoryDB?
    How to keep Physical Currency then !?
    Can't buy when player offline.
  31. Offline


    I'm sorry, but it's a problem with iConomy, not ChestShop.
    Probably it doesn't check if the inventory is full - that's where the problem comes from.

    Kieron Etherimgton
    They will be usable.

    Go to bukkit.yml, change spawn-radius to 0.

    Wow, really thanks for this awesome report.
    I'd say it's a problem with your permissions config.
    Mind pasting it on pastebin.com?

    Just do /iteminfo, it will tell you exactly what's the ID.

    Excuse me, but can you tell me again what exactly are you trying to accomplish?

    If you set the server economy account to "", it will have infinite money.
    If you don't, it won't.

Share This Page