[ECON] ChestShop 3.7.18 (iConomyChestShop) - Chest&sign shop for economy plugins [1.8]

Discussion in 'Archived: Plugin Releases' started by Acrobot, Feb 12, 2011.

  1. Offline


    An easy way to create shops - no protection plugin needed!
    You don't need to be on-line to earn money anymore!
    I've put a LOT of effort into making this plugin,
    you can donate if you appreciate my effort =)

    - An economy plugin supported by Register or Vault, for example iConomy, BOSEconomy or Essentials Eco.
    - For additional economy plugin support - Vault
    - For Permissions: bPermissions, PEX, or any other permission plugin
    - For additional protection: LWC, Lockette, Deadbolt
    - For other item names (aliases): OddItem

    Copy the .jar file from the .zip you downloaded into /plugins folder.
    You can also copy the example files if you want to generate statistics page.

    You can change the plugin's language, here's a list of all user-made translations.
    If you want to update or submit a translation, feel free to PM me.
    Translations (open)

    Arabic - Attarhsase2
    Bulgarian - Muff1Ncho
    Czech - LordPgsa
    Chinese (Simplified) - tab415263
    Danish - Cannafix
    Dutch - speedlegs
    French- DragonSlayer875
    German - RasCas
    Hungarian - Anachen
    Indonesian - Yahya98
    Italian - Massimo1993
    Korean - Zwing87
    Norwegian - _AlexN_ and TheUnkownGamer
    Polish - Holls1
    Portugese (Brasil) - FelipeMarques14
    Russian - VADemon from http://minemania.ru/
    Slovak - LordPgsa
    Slovenian - jEErc
    Spanish - thxaaaa
    Swedish - Maxell
    Turkish - Developer
    Traditional Chinese - hellboyincs
    Vietnamese - etrubi1 from http://minevn.com/

    How to create a ChestShop?
    - Place a chest, if you haven't already.
    - Place a sign 1 block near the chest (for example, above the chest)
    - On the sign, write:

    (Item name can actually be item ID or alias)
    First line will be filled in by the plugin automatically.
    Price is a combination of buy and sell price.
    You have to have B near buy price (people buy from you), and S near sell price (people sell to you).
    If you have both B and S, separate them with a colon - :
    For example:

    means that AcrobotPL wants to sell 64 diamonds for 10 currency, and buy them back from you for 5 currency.
    Also, if you put "free" instead of price, it is free to buy or sell :)

    - Now, when you finish editing the sign, if LWC is turned on in config, shop will be automatically created.
    Also, if your default protection is turned on in the config, people won't be able to break chest, sign or the block the sign is on.

    What is an Admin Shop?
    Admin shop is the shop that doesn't require a chest, because it has infinite stock.
    If you sell to it, the items will disappear, and if you buy from it, items will magically appear.
    To create one, you have to be Admin/OP. Just put "Admin Shop" (or anything specified in config file) on the first line of the sign.

    Restricting shops to some groups or regions
    You can either use permissions, or you can just put a sign ABOVE shop sign (you need to be in that group to create the sign) to restrict it to players with ChestShop.group.groupName permission
    The syntax is:
    Only those groups will be able to use that shop

    To restrict a shop to some regions:
    - If you're using Towny, turn TOWNY_INTEGRATION on. Residents will be able to create shops in economy plots (either their or, if specified in config, any)
    - If you're using WorldGuard, you can use an experimental "chestshop" flag. Turn WORLDGUARD_INTEGRATION on and flag a region. (f.e. /region flag ChestShopRegion chestshop allow)

    Do you want to limit the maximum prices for items?
    Well, there's an app.... wait, not that : P
    You can use an experimental feature in ChestShop.
    In your config.yml, add lines like:
    max-buy-price-5: 14
    max-sell-price-5: 15

    That means that the maximum price for items BOUGHT by PLAYER is 14, and items SOLD by PLAYER using the shop is 15.

    You can also use a global setting, like this:
    max-sell-price: 200

    That means that the maximum price for items SOLD to PLAYER is 200 (if there is, for example, a max-sell-price-5 found, it will be used instead of the global sell price)

    You could buy and sell by right and left clicking the sign for a long time.
    Now it's the only way to use the shops.
    It's SIMPLE!
    Just LEFT-CLICK to SELL to shop, and
    RIGHT-CLICK to BUY from shop.
    (This can be changed in the config file)

    If you want to delete your old shop, simply SNEAK and destroy the sign.
    It's that easy =)

    You can either open the chest and stock it up, or click on your own sign - it will open chest's inventory (that way you can have chests not openable by other people for sure :D)

    ItemInfo command
    It's a simple command that shows item information.
    If you use it without any arguments, it shows you information about the item you're holding.
    If you specify item id or item name after the command, it will show you information about that item.

    Source code
    ChestShop is Open-Source =)
    You can find its code on https://github.com/Acrobot/ChestShop-3

    Thanks to:
    - kali876, ziomekYOYO and Herocraft server for testing the plugin and finding every little bug =)
    - Everyone who uses this plugin - really big thanks for this, I never thought it will be so popular
    - Everyone who provided translation - many people's lives will be easier now
    - @Nijikokun for Register
    - @LennardF1989 for awesome Persistence Reimplemented
    - @Temaska for fixing the plugin while I was on holidays
    - @VADemon for providing a great support for other users
    - @Euthyphro for his patience and really good bug spotting
    - vagrant326 for making a great price sheet
    - Epics for his great help
    If something's not working
    You can't change the sign color - that breaks the formatting.
    If that's not the issue, please give me this information, so I can help you faster.
    - CraftBukkit version (type /version in chat)
    - ChestShop version (type /csversion in chat)
    - Your economy plugin (iConomy? BOSEconomy? other one?)
    - Have you got any Permission plugin? Which one?

    Changelog (open)

    Changelog can be found on BukkitDev - http://dev.bukkit.org/server-mods/chestshop/files/
  2. Offline


    So I got it working after I disabled the most recent LWC auto locking.

    Seems if you let LWC autolock the chests when placed, the plug in blows up and says they don't have permission with the sign. If you disable auto locking chests it works.

    Now, is there anything that can be done about the spam of "THis sign is locked by soandso" when they buy/sell to it?
  3. Offline


    @Boon Pek
    Godlike! Thanks you very much!
  4. Offline


    The reason this plugin requires an economy plugin is because you cannot do a item for item swap. All transaction are item for economy plugin money. So you would sell 1 diamond for something like 100 imaginary money and then use 25 imaginary money for 1 stack of logs (Per the exchange rate you mentioned) the economy plugins use a database to store how much imaginary money each player has (this is their basic function, but they also have other money based functions to go along with them) I do not have a large server to check performance issues however so maybe someone else can answer on that.
  5. Offline


  6. Offline


    Im getting this:
    19:24:50 [INFO] Can not test connection as heartbeatsql is not set
    19:24:50 [INFO] Closing Connection[iConomyChestShop.6] psReuse[0] psCreate[1] psSize[1]
    19:24:50 [INFO] DataSourcePool [iConomyChestShop] grow; id[iConomyChestShop.7] busy[8] max[20]
    19:24:50 [SEVERE] javax.persistence.PersistenceException: ERROR executing DML bindLog[] error[Field 'id' doesn't have a default value]
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(DmlBeanPersister.java:116)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.insert(DmlBeanPersister.java:76)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersistExecute.executeInsertBean(DefaultPersistExecute.java:91)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeNow(PersistRequestBean.java:527)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeOrQueue(PersistRequestBean.java:557)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersister.insert(DefaultPersister.java:404)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaInsert(DefaultPersister.java:377)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaRecurse(DefaultPersister.java:361)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveRecurse(DefaultPersister.java:308)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.DefaultPersister.save(DefaultPersister.java:282)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.core.DefaultServer.save(DefaultServer.java:1765)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.core.DefaultServer.save(DefaultServer.java:1751)
    19:24:50 [SEVERE]       at com.Acrobot.iConomyChestShop.DBqueue.run(DBqueue.java:29)
    19:24:50 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    19:24:50 [SEVERE]       at java.lang.Thread.run(Unknown Source)
    19:24:50 [SEVERE] Caused by: java.sql.SQLException: Field 'id' doesn't have a default value
    19:24:50 [SEVERE]       at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1073)
    19:24:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3593)
    19:24:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3525)
    19:24:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1986)
    19:24:50 [SEVERE]       at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2140)
    19:24:50 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2626)
    19:24:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:2111)
    19:24:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:2407)
    19:24:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:2325)
    19:24:50 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:2310)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.ExtendedPreparedStatement.executeUpdate(ExtendedPreparedStatement.java:16
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.type.DataBind.executeUpdate(DataBind.java:74)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.dml.InsertHandler.execute(InsertHandler.java:155)
    19:24:50 [SEVERE]       at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(DmlBeanPersister.java:105)
    19:24:50 [SEVERE]       ... 14 more
    How to fix?
    And I'm ALSO getting this:
    19:32:03 [SEVERE] Caused by: java.sql.SQLException: Unsuccessfully waited [1000] millis for a connection to be returned. No connections are
    free. You need to Increase the max connections of [20] or look for a connection pool leak using datasource.xxx.capturestacktrace=true
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue._getPooledConnectionWaitLoop(PooledConnectionQueue.j
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue._getPooledConnection(PooledConnectionQueue.java:307)
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue.getPooledConnection(PooledConnectionQueue.java:247)
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.getPooledConnection(DataSourcePool.java:658)
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.getConnection(DataSourcePool.java:646)
    19:32:03 [SEVERE]       at com.avaje.ebeaninternal.server.transaction.TransactionManager.createTransaction(TransactionManager.java:307)
    19:32:03 [SEVERE]       ... 6 more
    How to fix that aswell :p
  7. Offline


    My server found a glitch, right click the sign really fast. You get an error then right click the chest and you can get into the chest.
  8. Offline


    The plugin works great except for one of my players who the sign just pops off and tells him not to steal. I fooled around with things and from what I can see it may actually be his name that is causing the problem. His name is 15 characters long and will not fit on the sign if you type it in. Would this cause a problem with making a shop?
  9. Offline


    Hello! I've got some problem.
    Could you explain me how I should fix it?

    10:15:30 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-
    gb9d0b04-b860jnks (MC: 1.6.6)
    10:15:35 [INFO] DataSourcePool [iConomyChestShop] autoCommit[false] transIsolati
    on[SERIALIZABLE] min[2] max[20]
    10:15:35 [INFO] SubClassFactory parent ClassLoader [org.bukkit.plugin.java.Plugi
    10:15:37 [INFO] Entities enhanced[0] subclassed[1]
    10:15:37 [INFO] [Permissions] (Yeti) was initialized.
    10:15:37 [INFO] [Permissions] version [3.1.5] (Yeti) loaded
    10:15:39 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    10:15:39 [INFO] [iConomy] Developed by: [Nijikokun]
    10:15:39 [INFO] [iConomy] hooked into Permissions.
    10:15:39 [INFO] [iConomyChestShop] version 2.75 initialized!
    10:15:39 [INFO] [iConomyChestShop] iConomy version 5 loaded.
    10:15:39 [INFO] [iConomyChestShop] Permissions version 3.1.5 loaded.
    10:15:39 [INFO] [iConomyChestShop] LWC version 2.31 loaded.
    >pr DEK parents list
    10:27:34 [INFO] [Permissions] No world specified. Defaulting to default world.
    10:27:34 [INFO] [Permissions] Parents: Group Users in world, User DEK in *
    10:22:57 [INFO] [iConomyChestShop] DEK bought 1 WOOD with durability of 0 from A
    iglos for 1.00 Dollars
    10:22:59 [INFO] [iConomyChestShop] DEK sold 1 WOOD with durability of 0 to Aiglo
    s for 1.00 Dollars

    Users group permissions:
    default: false
    prefix: ''
    suffix: ''
    build: true
    - Default
    - '-commandbook.give.*'# admins
    - '-commandbook.more'# admins
    - '-commandbook.more.infinite'# admins
    - 'commandbook.who'# moderator user
    - 'commandbook.motd'# moderator user
    - 'commandbook.intro'# user
    - 'commandbook.midi'# user
    - 'commandbook.rules'# user
    - '-commandbook.kit.*'# mod
    - '-commandbook.setspawn'# adm
    - '-commandbook.time.*'# mod
    - '-commandbook.spawnmob.*'# adm
    - '-commandbook.weather.*'# mod
    - '-commandbook.spawn'# mod
    - '-commandbook.teleport.*'# adm
    - '-commandbook.return'# mod
    - '-commandbook.call'# mod
    - '-commandbook.broadcast'# mod
    - 'commandbook.say'# usr
    - 'commandbook.say.me'# usr
    - 'commandbook.msg'# usr
    - 'commandbook.mute'# usr
    - '-commandbook.whereami.*'# mod
    - '-commandbook.clear.*'# adm
    - '-commandbook.slap.*'# mod
    - '-commandbook.rocket.*'# adm
    - '-commandbook.barrage.*'# adm
    - '-commandbook.shok.*'# adm
    - '-commandbook.thor.*'# adm
    - '-commandbook.whois.*'# mod
    - '-commandbook.debug.*'# adm
    - '-commandbook.reload'# adm
    - '-commandbook.kick'# mod
    - '-commandbook.bans.*'# adm
    - 'craftbook.mech.bridge'# usr
    - 'craftbook.mech.bridge.use'# usr
    - 'craftbook.mech.gate'# usr
    - 'craftbook.mech.elevator'# usr
    - 'craftbook.mech.elevator.use'# usr
    - 'craftbook.mech.light-switch'# usr
    - 'craftbook.ic.safe.*'# usr
    - '-craftbook.*'# adm
    - 'lwc.protect'# usr
    - '-lwc.mod'# mod
    - '-lwc.admin'# adm
    - '-worldedit.*'# adm
    - '-worldguard.*'# adm
    - 'myhome.home.*'# usr
    - '-myhome.*'# adm
    - '-xauth.admin.*' #adm
    - 'iConomyChestShop.shop.*'# usr
    - '-iConomyChestShop.command.*'# mod
    - '-iConomyChestShop.admin.*'# adm
    - 'ChestShop.shop.*'
    - '-iConomy.admin.*'# adm
    - '-iConomy.bank.*'# adm
    - '-permissions.*'# adm
    - '-moblimiter.*' #adm

    User DEK in USERS group. Users group have permissions for create shop.
    User DEK can buy and sell.
    But if DEK trying create shop-sign:

    server says: "[Permissions]You can't make this type of shop!"

    If shop create admin-user - it's work.

    Only admins can create shop?

    Sorry for my language, I'm from Russia =)


    Added sometime later
    With ChestShop 3.0 beta 5 I haven't this trouble
  10. Offline

    Boon Pek

    Show Spoiler
    tags, please :)

    Remove the iConomy portion from the permissions if you run Beta 3 ;)
  11. Offline


    Concerning the minprice/maxprice in the config.
    What is the syntax? Players are complaining about price too high/low nomatter what price they set,
    my config has:
    maxPrice: -1
    minPrice: 10.00
    at the moment.
    Are users with the chestshop admin permission exempt from the minprice maxprice? Seems so on my server.
    Running craftbukkit 860, iConomy 5.01 and iConomyChestShop 2.75
  12. Offline


    Disregard my first question, the minprice setting of 10.00 works perfectly. I just have incredibly stupid users... *lord give me strength*
  13. Offline


    I have a problom when i get a user to try and buy it says do not have permission and chest is locked, when i clearly added the nodes, i disabled sign protection and chest protection everythings public but it still wont work?
  14. Offline


    Help! The Plgin worked 1 Day and now i become this message:
    17:57:18 [SEVERE] Could not load 'plugins/iConomyChestShop.jar' in folder 'plugins':
    com.avaje.ebeaninternal.server.lib.sql.DataSourceException: java.sql.SQLException: Access denied for user 'ni7537_3_DB'@'localhost' (using password: YES)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.(DataSourcePool.java:210)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.getDataSource(DataSourceManager.java:210)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourceGlobalManager.getDataSource(DataSourceGlobalManager.java:63)
            at com.avaje.ebeaninternal.server.core.DefaultServerFactory.getDataSourceFromConfig(DefaultServerFactory.java:427)
            at com.avaje.ebeaninternal.server.core.DefaultServerFactory.setDataSource(DefaultServerFactory.java:388)
            at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(DefaultServerFactory.java:168)
            at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(DefaultServerFactory.java:64)
            at com.avaje.ebean.EbeanServerFactory.create(EbeanServerFactory.java:78)
            at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:175)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:174)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:194)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:117)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.sql.SQLException: Access denied for user 'ni7537_3_DB'@'localhost' (using password: YES)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1073)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3593)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3525)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:931)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:4046)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1296)
            at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2338)
            at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2371)
            at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2163)
            at com.mysql.jdbc.ConnectionImpl.(ConnectionImpl.java:794)
            at com.mysql.jdbc.JDBC4Connection.(JDBC4Connection.java:47)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
            at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:378)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:305)
            at java.sql.DriverManager.getConnection(Unknown Source)
            at java.sql.DriverManager.getConnection(Unknown Source)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createUnpooledConnection(DataSourcePool.java:401)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createConnectionForQueue(DataSourcePool.java:607)
            at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue.ensureMinimumConnections(PooledConnectionQueue.java:205)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.initialise(DataSourcePool.java:248)
            at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.(DataSourcePool.java:208)
            ... 17 more
    I don't understand what the Problem is! I installed the Plugin more than 5 times now and it doesn't work :(
    I have CB 860 # and Permissions with iConomy.
  15. Offline


    do you have the file (not folder!) named ebean.properties in your server folder? Same one the craftbukkit jar is in? A missing file is usually what the ebean messages mean.
    If not there, create it. It just needs to be a blank text file named ebean.properties
  16. Offline


    Hi I have a problem .... If I or someone else wants to buy what it says
    The seller does not want what they buy ...

    (Sorry for my English it was translated with Google Translator)

    Show Spoiler
    Hi ich hab ein Problem.... Wenn ich oder ein anderer was kaufen möchte steht dort
    Der Verkäufer möchte nicht das sie was kaufen...

    (Entschuldigung für mein Englisch habe es mit Google Übersetzer übersetzt)
  17. Offline



    I wanted to see if you had been able to make any progress with a restricted sign setup. If its not something you will be able to make happen soon thats fine, I would just like to know if I need to take a new route to restrict my signs.
  18. Offline


    Shops won't work. I can create one, and I get a message about "shop created", but no body can buy or sell from it, no body even get a Shop message when they click on sign and chest. The only message appearing is:
    "You don't have permissions to use this
    This chest is locked by (name)"
    I use LWC, permissions and iConomy.
    I really don't know what to do ... All users have permission to buy and sell, and nodes are written right.
  19. Offline

    Russian potato

    S 99​
    B 99:99 S​
    I haven't tried taking out the space but that will probably make it fail​
  20. Offline


    I know it would be hard because the info is displayed on a sign so it would have to modify the sign, but if you could add dynamic prices this plugin would move from good to great.
  21. Offline


    <= For 3.0 beta
  22. Offline


    Hi! Its the fist time when i trying to build the server. when I put the file iConomyChestShop.jar into the plugin directory.
    And when I star server – a have this:
    148 recipes
    16 achievements
    11:13:31 [INFO] Starting minecraft server version Beta 1.6.6
    11:13:31 [INFO] Loading properties
    11:13:31 [INFO] Starting Minecraft server on *:25565
    11:13:31 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-892-ga9ddbaa-b935jnks (MC: 1.6.6)
    11:13:31 [INFO] While loading iConomyChestShop (plugins\ChestShop.jar) renamed data folder: 'plugins\ChestShop' to 'plugins\iConomyChestShop'
    11:13:31 [SEVERE] ebean.properties not found

    where i can download ebean.properties?

  23. Offline


    I tried with these nodes as well, but it still won't work.
  24. Offline


    I see that I have that file. But everytime I start the Server the Plugin doesn't get activated >.< I need help :s
  25. Offline


    where i can download iConomyChestShop for build 860? give me a link please
  26. Offline


    From OP, big bright letters.

    The name is changed to ChestShop, so will have to take the iConomy out of your permissions nodes.

    @Rizzak did you try using the beta3 file? It seems to be working smoothly for me, had it working on both 860 and 935 now.
  27. Offline


    I would double check how they did the sign setup. It isn't intuitive for the shop owner, but it is for the customer.
    B $:$ S
    Buy price is where the customer buys it, but the owner is selling.
    Sell price is where the customer sells it, but the owner is buying.

    So for him to sell something not buy, he needs
    B: price

    Could be wrong about it, but that sounds like what is happening. Let us know if he has it set up right.
    I had same issue when I first used this. Turn off LWC protections in the config, tell it to use it's own internal protections. Alternatively, turn it off for just the signs.
  28. Offline


    I have this error in console:
    14:43:27 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-
    Show Spoiler
    gb9d0b04-b860jnks (MC: 1.6.6)
    14:43:27 [INFO] Preparing level "world"/ Spoiler]
    14:43:27 [INFO] Preparing start region for level 0
    14:43:28 [INFO] Preparing spawn area: 93%
    14:43:28 [INFO] LWC Loading shared objects
    14:43:28 [INFO] Cache Protection cache: 0/10000]
    14:43:28 [INFO] LWC Native library: plugins/LWC/lib/native/Windows/x86/sqlit
    14:43:29 [SEVERE] expected '<document start>', but found BlockMappingStart in "<reader>", line 3, column 1:
    14:43:29 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseDocumentStart.produce(ParserImpl.java:233)
    14:43:29 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    14:43:29 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    14:43:29 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:108)
    14:43:29 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    14:43:29 [SEVERE] at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)

    14:43:29 [SEVERE] at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfiguration.java:54)
    14:43:29 [SEVERE] at com.nijiko.data.YamlUserStorage.<init>(YamlUserStorage.java:31)
    14:43:29 [SEVERE] at com.nijiko.data.YamlCreator.getUserStorage(YamlCreator.java:34)
    14:43:29 [SEVERE] at com.nijiko.data.StorageFactory.getUserStorage(StorageFactory.java:76)
    14:43:29 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(ModularControl.java:92)
    14:43:29 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(ModularControl.java:84)
    14:43:29 [SEVERE] at com.nijiko.permissions.ModularControl.load(ModularControl.java:104)
    14:43:29 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(Permissions.java:186)
    14:43:29 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(Permissions.java:139)
    14:43:29 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
    14:43:29 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    14:43:29 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    14:43:29 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    14:43:29 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    14:43:29 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    14:43:29 [SEVERE] [Permissions] Unable to load permission data.
    14:43:29 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    14:43:29 [INFO] [Permissions] (Yeti) was initialized.
    14:43:29 [INFO] [iConomy] Logging is currently disabled.
    14:43:29 [INFO] [iConomy] v5.0 (Eruanna) loaded.
    14:43:29 [INFO] [iConomy] Developed by: [Nijikokun]
    14:43:29 [INFO] LWC Loaded 134 locale strings (0 overrides)
    14:43:29 [INFO] [Permissions] (Yeti) disabled successfully.
    14:43:29 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    14:43:29 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    14:43:29 [INFO] LWC Using Permissions API...
    14:43:29 [INFO] LWC Loading SQLite
    14:43:29 [INFO] SQLite Using: Native'] ['spoiler']
  29. Offline


    I have tried both, ChestShop Beta and iConomyChestShop. But the Plugins doesn't gets activated somehow :S
  30. Offline


    @Rizzak how about changing the config:
    LOG_TO_FILE: false
    LOG_TO_CONSOLE: false
    USE_DATABASE: false
    try using one of the top two as true, if you absolutely must have a log file, and disable the third, so it doesn't try to use the ebean database? I have all three as false.
  31. Offline


    Got this with another config this morning. Look above the line that says users: and I bet you have a : with no space after it. Could be in one of your essentials/permissions files (both are named right afterward) or a config file that has "users:" in it. That one confuses me on which file it is, you don't run GM and Permissions both, do you? I can't figure out what other Essentials file other than GM uses "users:"

    If you can't find the file, open them and do a search function for the string "users"
    Any that have it, run through the Parser at this link.

Share This Page