Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpoutDev

    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use www.spout.org for support with our projects going forward.
     
  2. Offline

    Age123

    so lemme get this straight u guys are planning on porting the ability to play plugins on single player? or did you mean put mods on multi-player? because i think the plugins to SP would be awesome because someone has yet to do this and personally there are good plugins id like to use on SP like Voxelsniper, Voxelport, and Voxeltronics when it comes out.
     
  3. Offline

    Wulfspider

    The addon support for Spoutcraft has been discontinued actually. We've moved on to our own standalone platform for voxel games. You can still make plugins for SpoutPlugin that run on CraftBukkit servers that will do things on the Spoutcraft client though. Regular client mods that you are used to are unsupported though.
     
  4. Offline

    sazrocks

    Ok, im running a tekkit server, (google it) and i want spout on it. The server still runs minecraft 1.2.5 and the plugin says that its running on the wrong version. Is there a way i could get an older version so it would be compatible with my server, or would that not work because all the plugins wouldn't work?
     
  5. Offline

    Wulfspider

    It's not compatible as far as I know. They modify core files that we modify as well. We don't support 1.2.5 builds anymore either. I suggest you update. ;)
     
  6. Offline

    Sketaful

    what I know they use a modified spout launched.
     
  7. The launcher isn't the API at all. Also, the launcher has changed significantly since then.
     
  8. Offline

    Wulfspider

    It actually has. It uses a whole new system now for build selection and most of the other files.
     
  9. Offline

    sazrocks

    ok, but you suggested that I update, and I can't do that unless the devs update tekkit. My question was that can I find somewhere an older version of spout thats compatible with 1.2.5? Another question: since tekkit is a modified version of spout, is it possible to use it as spout if I got spout working on my server?
     
  10. Offline

    Wulfspider

    Tekkit isn't a modified version of Spoutcraft, all they use is our OLD launcher source, nothing else.
    Here is a 1.2.5 build of SpoutPlugin, but no guarantees that things won't break.
     
  11. Offline

    sazrocks

    Thanks for the 1.2.5 compatible version, but what I meant in my second question was that can I use the tekkit client as spout client so I can use the spout plugin on my server? Is that O.L.D. Or old? I'm going to try the version you gave me sometime today.

    ok tried the plugin, and it gave me a gazillion error messages that said something about rails. ok i went and checked my rails, and my rails that were only in tekkit (not vanilla) got turned into regular rails. Why?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  12. Offline

    lol768 Retired Staff

    Quite simply, it will not work. Tekkit only uses launcher code and modifies loads of files that Spoutcraft also modifies
     
  13. Offline

    Wulfspider

    Because of the conflicts I mentioned before.

    He's using the server parts, not client. The Tekkit server modifies core files that SpoutPlugin also modifies.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  14. Offline

    lol768 Retired Staff

    Mistake on my part. Even so, I'm guessing the Tekkit mods would conflict with spoutcraft on the client side as well as the server-side conflicts?
     
  15. Offline

    Wulfspider

    If they're actually trying to combine the client parts, yes. Simply running Spoutcraft and connecting to a Tekkit server shouldn't have any issues, it just wouldn't be much use.
     
  16. Offline

    sazrocks

    tried that. didnt work. the whole reason I want spout, is because I want custom music on my server. you guys seem nice so ill ask you: what is the best way to get custom music on a tekkit server?
     
  17. Offline

    RiotShielder

  18. Offline

    Wulfspider

    We're not going anywhere, just changing. ;)
     
  19. Offline

    RiotShielder

    I know that, I accidentley put Spout instead of SpoutPlugin :p
     
  20. Offline

    sazrocks

    wait, you guys are no longer providing support? does this mean that i will have to make a spout server? or will i continue to be able to use it as a plugin?
     
  21. Spout isn't quite ready for production yet. SpoutPlugin has basically been outlawed by the recent changes to Bukkit. This is gonna be like the interim between hMod and Bukkit.
     
  22. Offline

    sazrocks

    So soon, you guys are going to start making your own server? like a spout server instead of bukkit?
     
  23. Work began quite a while ago actually. There are already developer releases where features are being tested.
     
  24. Offline

    sazrocks

    What happens to all the great plugins that rely on spoutplugin?
     
  25. They will either port or cease to exist. There's nothing the Spout team can do about Bukkit's decision.
     
  26. Offline

    sazrocks

    ouch:(
     
  27. Offline

    sazrocks

    Wait, on your website there is a spout plugin build for 1.4.6. Huh? Define what you mean when you said bukkit outlawed spout plugin.
     
  28. Ok, I'd like to make a few corrections here. First, I don't speak officially for the Spout team. I've contributed but I'm not in charge of anything. So my word isn't final on any of this.

    Second, it appears that there is still a workaround for SpoutPlugin to continue existing, but it's requiring increasing amounts of work to maintain between updates. The Spout dev team is having trouble keeping up, and efforts are being put into creating the standalone Spout platform instead of trying to update SpoutPlugin for all of Mojang's tiny bugfixes and Bukkit's weird internal changes.
     
  29. Offline

    sazrocks

    Right after I found this new update, I found a few posts on the website that said they would try to maintain spoutplugin and spoutcraft unless the updates required a major rewrite of the code. though I did find something interesting, the new spout platform will not be based on minecraft(under development). there will be a vanilla plugin (or whatever they're going to call add ons) which will add minecraft (under development). something else, there will also be a plugin called bukkit bridge (under development) which will allow most bukkit plugins to be played on this new platform. I am unsure whether this will allow spoutplugin-dependent plugins not to have to port to the new spout platform. You may already know all of this, I just found it interesting.
     
  30. What you posted is true. I'm actually more active on the Spout forums than the Bukkit forums now and can confirm what you said. To clarify though, SpoutPlugin based plugins should just be ported to Spout rather than trying to use BukkitBridge.
     
  31. Offline

    sazrocks

    I'm not a plugin developer, but why not use bukkit bridge?

    Looks like we are the only people posting here. :(

    I wish bukkit would just revert the recent changes so the community wouldn't be split in half. :(
     
Thread Status:
Not open for further replies.

Share This Page