Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpoutDev

    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use www.spout.org for support with our projects going forward.
     
  2. Offline

    Wulfspider

    Like I said, if they are using our launcher, it does md5 checks, so without them disabling those checks, there really isn't an easy way unless they did a manual install of Spoutcraft without our launcher (even harder to do now too).
     
  3. Offline

    shauwk

    alright thanks for the info!
     
  4. Offline

    Julianoz1224

    I need some help, I can't find where to set my Server icon that appears on the server list. Is it apart of spout or another plugin? (for example SpoutEssentials)
     
  5. Offline

    Wulfspider

    You submit your server via http://servers.getspout.org and set the icon there when you submit it. When you manually add a server to your favorites list, there is no icon. Only servers added to your favorites from the public server list have icons on your favorites list.
     
  6. Offline

    Julianoz1224

    Ah ok. Thanks for the help
     
  7. Offline

    Wulfspider

    No problem. :)

    Recommended build of Spoutcraft available now for Minecraft 1.0.0! If you have your launcher on "Latest Recommended" it will update to it.

    If you need to downgrade to beta 1.8.1, you'll have to manually select a build under the launcher options.

    Spout build 642 is our first recommended build candidate for CraftBukkit 1.0.0 servers.
    You can get it from the usual link, http://spout.in/plugindev and is compatible with the latest CraftBukkit dev build(s).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  8. Offline

    Strebelschneck

    great work guys, awesome!
     
  9. Offline

    Mario_987

    Can you help me? I get this error

    Code:
    
    19:28:21 [SEVERE] java.lang.ClassCastException: java.lang.Float cannot be cast to net.minecraft.server.EnumToolMaterial
    19:28:21 [SEVERE]     at org.getspout.spout.item.mcitem.CustomItemSpade.replaceSpades(CustomItemSpade.java:35)
    19:28:21 [SEVERE]     at org.getspout.spout.Spout.onEnable(Spout.java:220)
    19:28:21 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
    19:28:21 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:957)
    19:28:21 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    19:28:21 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:182)
    19:28:21 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:165)
    19:28:21 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:124)
    19:28:21 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
    19:28:21 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:141)
    19:28:21 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:388)
    19:28:21 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    19:28:21 [SEVERE] Error occurred while enabling Spout v510 (Is it up to date?): null
    java.lang.NullPointerException
        at net.minecraft.server.ItemTool.<init>(SourceFile:18)
        at net.minecraft.server.ItemSpade.<init>(SourceFile:11)
        at org.getspout.spout.item.mcitem.CustomItemSpade.<init>(CustomItemSpade.java:14)
        at org.getspout.spout.item.mcitem.CustomItemSpade.replaceSpades(CustomItemSpade.java:41)
        at org.getspout.spout.Spout.onEnable(Spout.java:220)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:957)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:182)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:165)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:124)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:141)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:388)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    >
    
     
  10. Offline

    Wulfspider

    Update your server and Spout. http://spout.in/plugindev for the latest Spout dev build.
     
  11. Offline

    Justgotreal

    I got this error:
    [​IMG]

    I am running these plugins:
    AutoAnnouncer
    bPermissions
    ChatMe
    ChatSuite
    CommandBin
    Democracy
    HandyTorch
    MessageChangerLite
    MultiWorld
    Spout
    SpoutEssentials
    StainedGlass
    webgui (for bPermissions)

    Edit: Fixed it.
     
  12. Offline

    Wulfspider

    Update update update. You're running an outdated build of Spout. http://spout.in/plugindev
     
  13. Offline

    shanko

    edit: this was an issue with craftbukkit
     
  14. Offline

    surfarcher

    CB RB for 1.0.0 just hit!

    With a little luck we won't have to wait too long for an official Spout/Spoutcraft :D
     
  15. Offline

    runeslielo

    I'm getting a Black screen whenever i try to join a server, It wasnt happening when i first installed Spout but now i can't join any servers. I have a premium minecraft account, and i have no mods on my client.
     
  16. Offline

    elias79

    I dont see the star.
     
  17. Offline

    Wulfspider

    Already available. ;)

    What builds of Spoutcraft, Spout, and CraftBukkit are you using?

    http://spout.in/plugin

    We know, those are not released features yet and there is still a lot to do on those.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 28, 2018
  18. Offline

    Marcos Cosmos

    just gunna ask if you can add the build # structure that bukkit is newly using rather than the old, if alongside the bukkit build.... gunna download and test spout immediately, hopefully itll run for me in ubuntu 11.10.1 now ><
     
  19. Offline

    Wulfspider

    Do what? CraftBukkit still uses the build numbers on Jekins, we still go by builds, I'm not sure what you are suggesting. I think using build numbers is more specific than using the whole 1.0.0-R1 and such as the snapshots use the same naming so it's rather non-specific when it comes to figuring out what build a user is running and therefore strains support more.
     
  20. Offline

    elias79

    Nope 644 is the first star release.
     
  21. Offline

    Wulfspider

    Please read, I said candidate as in it was the one we were thinking of promoting. 644 ended up being the recommended build though.
     
  22. Offline

    Julianoz1224

    Build 644 has some serious bugs to do with custom blocks and items :S

    Ok, I cant wait until everything is working well because some of the new features are amazing :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Feb 15, 2019
  23. Offline

    aehoooo

    Cant I install spoutcraft trowing those files into minecraft.jar as it used to be on the previous build?
     
  24. Offline

    Wulfspider

    Manual installs are not supported and never have been. The only reason you could before was because that was what we used for our launcher as well. It's possible, but 8 times more difficult than it was before due to the lib jars being split from the Spoutcraft files to speed up the update times and only download the jars that have changed.
     
  25. Offline

    Marcos Cosmos

    Their feed uses a new system and so its confusing for those who follow the feed.. I meant adding the new system, not replacing, as in, listing the bukkit compatibility AND the mc one ><
     
  26. Offline

    Niduin

    Will Spout support to edit the map height to 256 instead if 128 ?
     
  27. Offline

    elias79

    Its planned.
     
  28. Hi all,

    I've got a problem. Everytime I try to open my Spoutcraft client, it stays closed. Can you help me?? I've got a mac, Mac OS X Lion (10.7) please help me. I NEED SPOUTCRAFT. Now i can't enjoy my own server. I can join with the usual Mc launcher but spout craft is even better.

    Thank you
     
  29. All I need from spout is 3 things:
    1. Zombe Flying support (OR include spout flying that works just as great, NOT like the creative Notch flying which is like surfing on ice midair...)
    2. Custom Block Support
    3. Custom Map Height Support
    Don't think I need anything more :)
     
  30. Offline

    Chronx6

    There is a flying mod for spout that is fairly widely used( I don't use it so no clue how it works), custom block(and item and entities if I remember correctly) are in the works. Custom map height is client side done and the server side will be released as a plugin.
     
  31. Offline

    panborsuk

    @SpoutDev How to remove message after writing /reload command. It's most stupid message I ever seen :/ I don't care Spout prefers /spout reload or not because I do it (/reload) for other plugins or things and this message is nervous me :)
     
Thread Status:
Not open for further replies.

Share This Page