Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpoutDev

    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use www.spout.org for support with our projects going forward.
     
  2. Offline

    DigitalStorm

    With the latest Server RB, is the chunk caching fixed?
     
  3. Offline

    TangoFox4

    Hi!
    I have Mac and since i use Spoutcraft the sound isnt working..
    I hear nothing :(
     
  4. Offline

    bogdan_mihai58

    Hi, is there any Spout Port of Too Many Items ???
     
  5. Offline

    MCTSS

    Cant Wait!
     
  6. Offline

    Top_Cat

  7. Offline

    BioRage

    Any chance we will be seeing custom mob's and such ^.^
     
  8. Offline

    Top_Cat

    Very good chance the client api will allow this :)
     
  9. Offline

    Ixy

    Search didn't show any results for this error, and I am not signing up to Github just for that :)

    When you type fast and backspace too quick (and I do this a LOT) I get this problem. Does not crash the game, but does get annoying when it glitches the text (like double deleting).

    Code:
    java.lang.StringIndexOutOfBoundsException: String index out of range: 12
            at java.lang.String.substring(Unknown Source)
            at org.getspout.spout.player.ChatManager.onChatKeyTyped(ChatManager.java
    :115)
            at gc.a(GuiChat.java:36)
            at da.g(GuiScreen.java:144)
            at da.e(GuiScreen.java:117)
            at net.minecraft.client.Minecraft.k(Minecraft.java:1075)
            at net.minecraft.client.Minecraft.run(Minecraft.java:622)
            at java.lang.Thread.run(Unknown Source)
    
    Edit: Woops the version detail didn't copy to clipboard *facepalm*

    Spoutcraft 1.0.2.165 MC 1.7.3.
    Server: Spout 1.0.2.121
     
  10. Offline

    Izze

    Still haven't solved this. I tried to recompile an older plugin, which is almost identical to this one I'm testing now, but is using the sound functions instead of the graphical functions. That plugin still works fine. The sutup is exactly the same (same API version and tested on the same server) but the one using the graphical functionality of Spout isn't working. I can't see where I'm doing anything worng.
    Help very much appreciated.
     
  11. Offline

    Elitedude

    I'm having the same problem as Tango here. I'm using a mac, and when I installed the Spoutcraft client mod all my sounds stopped working.
     
  12. Offline

    thehutch

    Hey @Top_Cat just to let you know @captainawesome7 and I were testing his new plugin and we got the custom skins working so just to let everyone know it does work. :D
     
  13. Offline

    Ritsbits

    Could I get some kind of help? I asked earlier about this; Spoutcraft client/launcher freezes when progress bar moves. It will freeze and never move even when left a lone. It also freezes at different %'s when the launcher is closed, and re-opened to try again. I posted what builds I'm using earlier but CB is 1060 and Spoutcraft is the newest.

    Screenshot if that will help:
    [​IMG]
     
  14. Offline

    Frogging101

    Without. I was only using spout because the latest version of LogBlock needed it. The server runs out 0f memory spontaneously and abruptly, and crashes.
     
  15. Offline

    captainawesome7

    Yeah apparently I didn't read the Javadocs very well...
     
  16. Offline

    thehutch


    *FACEPALM*
     
  17. Offline

    BioRage

    I like :D

    Also, is there a way to have custom GUI's, or was that with texturepacks only? .. as in different healthbar/armor.. maybe that was texturepack only.
    .
    Reason: not my screenies, however, an example would be such as these (or a reference)


    http://dl.dropbox.com/u/11333268/preview_helmet_overlays2.png
    http://dl.dropbox.com/u/11333268/2011-07-27_03.26.11.png

    Or a different gui for hp bar style, such as one to be as diablo2/3 circle hp bar style
     
  18. Offline

    tootybob

    I Typed /Herobrine and Abra-Cadabra:
     
  19. Offline

    Wulfspider

    Please use pastie.org or pastebin.com next time. Are you on CraftBukkit 953?
     
  20. Offline

    Stephen92

    Just wanted to say this is working very well with the latest update of spout and craftbukkit 1060, keep up the great work.
     
  21. Offline

    Hanii Puppy

    You need to assign more RAM then change the settings in the options panel.

    You can assign 2gb of ram if you run through a command script with this, if you have the Spoutcraft jar in the applications folder:

    Code:
    cd /Applications
    java -Xincgc -Xmx2048M -jar Spoutcraft.jar
    
    When you run the command script, it should also bring up a terminal window. When you change the audio preferences in the options panel, you should get an error message in your terminal window - although it should now work. Could you copy paste the error message you get here please?
     
  22. Offline

    ItsQ

  23. Offline

    Wulfspider

  24. Offline

    fragen

    All users on my server downloaded an update from their Spoutcraft client.
     
  25. Offline

    mrvertigo27

    I keep getting this
    Name of project:Spoutcraft Launcher
    Project version/build: your latest RB
    CraftBukkit build: 1060
    Description of issue: wont update keeps crashing midway through
    Steps to reproduce: run the spoutcraft launcher and wait....
     
  26. Offline

    spikeof2010

    Spoutcraft is refusing to connect to this server 46.105.108.72:25569
    It just says unknown host, any reason why?
     
  27. Offline

    Elitedude

    @Hanii Puppy Yes, that fix works on the Spoutcraft launcher, but I was talking about the original minecraft launcher. I manually installed Spoutcraft.
     
  28. Offline

    Wulfspider

    I can connect to it fine. Are you connecting from Quick Join or as a Favorite?
     
  29. Offline

    zipsi

    ugh.. is there ANY way to use worldedit cui with latest version of spoutcraft? I know modloader isnt compatible (thought it worked with an earlier version I kept reverting to after updates to use cui), but now new plugins etc aren't even compatible with older version of spout.. so I updated.. I love spout, but I don't have the desire to build without the cui.. so either both or.. no minecraft at all until I can get em both.. :/ any solutions?
     
  30. Offline

    Wulfspider

    As we've said before, it could be ported and used as a client plugin when the Spoutcraft API is available.

    You can launch the original the same way, but use minecraft.jar instead of Spoutcraft.jar.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  31. Offline

    tootybob

    No Build 1000

    And it said....
    2011-08-19 17:08:33 [SEVERE] java.lang.NoSuchFieldException: perm
    2011-08-19 17:08:33 [SEVERE] at java.lang.Class.getDeclaredField(Unknown Source)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.player.SpoutCraftPlayer.<init>(SpoutCraftPlayer.java:82)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.player.SpoutCraftPlayer.updateBukkitEntity(SpoutCraftPlayer.java:615)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.player.SpoutCraftPlayer.getPlayer(SpoutCraftPlayer.java:647)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.SpoutPlayerListener.updatePlayerEvent(SpoutPlayerListener.java:118)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.SpoutPlayerListener.onPlayerTeleport(SpoutPlayerListener.java:39)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$8.execute(JavaPluginLoader.java:293)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:321)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:373)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.player.SpoutCraftPlayer.updateNetServerHandler(SpoutCraftPlayer.java:594)
    2011-08-19 17:08:33 [SEVERE] at org.getspout.spout.SpoutPlayerListener.onPlayerJoin(SpoutPlayerListener.java:29)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:244)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    2011-08-19 17:08:33 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:321)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:124)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:97)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:74)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.Packet1Login.a(SourceFile:43)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:40)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-08-19 17:08:33 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-19 17:08:44 [INFO] [xAuth] Player 'tootybob' has authenticated
    2011-08-19 17:08:53 [INFO] /173.70.209.5:57397 lost connection
    2011-08-19 17:08:56 [SEVERE] java.lang.NoClassDefFoundError: org/bukkit/permissions/Permission
    2011-08-19 17:08:56 [SEVERE] at java.lang.Class.getDeclaredMethods0(Native Method)
    2011-08-19 17:08:56 [SEVERE] at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at java.lang.Class.getMethod0(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at java.lang.Class.getMethod(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at org.bukkit.craftbukkit.command.ServerCommandListener.getName(ServerCommandListener.java:29)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.ConsoleCommandHandler.handle(ConsoleCommandHandler.java:25)
    2011-08-19 17:08:56 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:307)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:711)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-08-19 17:08:56 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-19 17:08:56 [SEVERE] Caused by: java.lang.ClassNotFoundException: org.bukkit.permissions.Permission
    2011-08-19 17:08:56 [SEVERE] at java.net.URLClassLoader$1.run(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at java.security.AccessController.doPrivileged(Native Method)
    2011-08-19 17:08:56 [SEVERE] at java.net.URLClassLoader.findClass(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    2011-08-19 17:08:56 [SEVERE] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    2011-08-19 17:08:56 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-19 17:08:56 [SEVERE] ... 17 more
    2011-08-19 17:08:56 [SEVERE] Unexpected exception
    java.lang.NoClassDefFoundError: org/bukkit/permissions/Permission
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    at java.lang.Class.getMethod0(Unknown Source)
    at java.lang.Class.getMethod(Unknown Source)
    at org.bukkit.craftbukkit.command.ServerCommandListener.getName(ServerCommandListener.java:29)
    at net.minecraft.server.ConsoleCommandHandler.handle(ConsoleCommandHandler.java:25)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:307)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:711)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: org.bukkit.permissions.Permission
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 17 more


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
Thread Status:
Not open for further replies.

Share This Page