Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    isnt the spoutcraft launcher a bit unsafe?
    we need to give away mc password..
    cant u make something like mod for minecraft?
  3. Offline


    All the source is on GitHub. We have no interest in your password and it's just as safe as using any client mod. The login information is passed the same way as Notch uses in the official launcher and is only sent to Notch's server.

    We offer the client mod as a manual install in the original post as well.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  4. Offline


    I actually would love to block coords and the names over mobs through spout serverside.
    So those without spoutcraft can't use/see them. I hoped spout could do that.
    But I guess I was wrong ;(
  5. Offline


    so that manual without spoutcraft launcher and uses mc original launcher?
  6. Offline


  7. Offline


    I think it seems reasonable. It could be enabled by default and have the server enable/disable it when the player connects.
  8. Offline


    The new Spout is kicking players off my server. Please fix it, or tell what is wrong?
  9. Offline


    2011-08-19 13:56:06 [SEVERE] Could not pass event PLAYER_MOVE to Spout
    java.lang.ClassCastException: org.bukkitcontrib.ContribNetServerHandler cannot be cast to org.getspout.spout.SpoutNetServerHandler
    at org.getspout.spout.player.SpoutCraftPlayer.getNetServerHandler(
    at org.getspout.spout.SpoutPlayerListener.onPlayerMove(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at org.getspout.spout.SpoutNetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
  10. Offline


    Oh, okay, I see - so it's just the server side plugin that needs updating,a s the launcher updates itself? Okay, that's great. Thanks!
  11. Offline


    Remove BukkitContrib.

    The new Spout as in... what builds of the client and plugin?

    You mean you are having trouble with the launcher downloading files?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  12. Offline

    Marcos Cosmos

    Yeah, cool! :D
  13. Offline


    @Wulfspider latest RB of spout with bukkit build 1060 cuases huge lag from some of my players
  14. Offline


    Spout is updating right now .... what's new ? :D
  15. Offline


    Name of project: Spout
    Project version/build: / 134
    CraftBukkit build: 1060
    Description of issue: When loaded the new spout.jar (134) into my server when connecting to my server through spoutlauncher or the normal minecraft launcher it keeps logging in and downloading the files then comes up read timed out. spout and my server worked fine before i put 134 on and cannot find an older spout version to test and make sure it is a spout problem
    Steps to reproduce: worked fine. installed 134 then stopped working

    Im using verygames server and cannot get my console log due to it only showing a small bit of the log

    Many ideas :)
  16. Offline


    The main change in the latest RB is the fix of the texture memory leak :)

    Any stack trace/error log?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  17. Offline


    no not the launcher. i am able to log into the launcher and when i click mulitplayer to connect to my server it will just keep logging in then come up read timed out. was working fine before i updated to the new spout 134

    im tryinig now to get some error files.. might have to dowload it all of verygames server and run on my computer to get error files
  18. Offline


    Hey, how do I use this with McMMO? I have the plugin in my plugins folder, I have McMMO, and I'm using the Spout client. I also do have Spout enabled in the McMMO Config, but I still have no Exp bar or custom sounds, etc?
  19. Offline


    I was having issues with the server spontaneously running out of memory. I updated all my plugins, tried disabling some plugins, and it wasn't fixed.

    I tried running with spout but without logblock, and it still happened. Only when I deleted spout, and downgraded logblock to a non-spout version (LogBlock kept redownloading spout), the memory issues stopped.

    So I have confirmed it IS spout that was causing these memory issues. Any news on a fix?

    EDIT: And I HAVE turned off chunk caching. First thing I tried, didn't fix it.
  20. Offline


    What version of Spout were you using?

    I haven't used mcMMO, so I'm not sure. I'd check with its developer and check for errors by running your client using through the command line.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  21. Offline


    I've tried with many versions, including the latest (134), and others such as 1.0.2 (Release), and other jenkins builds.

    It still happened with all of them.
  22. Offline


    I can't imagine why a host wouldn't give you a way to access server logs. Seems a little useless to me.

    With or without the Spoutcraft client?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  23. Offline


    Without. I was only using spout because the latest version of LogBlock needed it. The server runs out 0f memory spontaneously and abruptly, and crashes.
  24. Offline



    Well as I said in an earlier post, I reported the memory error to as it specified on my spoutcraft client console when the Out of memory error occurred. I think from this response that they are tracking it as a java bug. I cant play using spout until this problem is fixed because my game keeps crashing for Out of memory. I get Out of memory errors on the normal Minecraft client (non spoutcraft), however they are far more infrequent.

    Dear Java Developer,

    Thank you for reporting this issue.

    We have determined that this report is a new bug and entered the bug into our internal bug tracking system under Bug Id: 7080037.

    You can monitor this bug on the Java Bug Database at

    It may take a day or two before your bug shows up in this external database. If you are a member of the Sun Developer Network (SDN), there are two additional options once the bug is visible.

    1. Voting for the bug

    2. Adding the report to your Bug Watch list.
    You will receive an email notification when this bug is updated.

    The Sun Developer Network ( is a free service that Sun offers. To join, visit

    Java Developer Support
  25. Offline


    Can anyone confirm whether a dev client/server spout version is more efficient (less laggy) than the current release?
    Going from cb1000 and 1.01 to cb1060 and spout 1.02 have made things a lot less smooth. However, I don't want to put dev stuff on and completely break it.

    So, any confirmation? Is the current dev stuff stable? Is it better?

    Thanks for any input.


    I take this comment back, 134 is buttery smooth, so far. Rejoice! ;)
  26. Offline


    i'm having a little problem....
    when i try using one of my plugins that requires spout, it says i need the spoutcraft launcher.
    the thing is that i'm already using it...
  27. Offline


    OT but curious:
    Notch is trying to resolve the Scrolls trademark lawsuit challenging Bethesda to a game of Quake 3 :oops:
    Read it here.
  28. Offline


    Hello, really nice Plugin!
    But 1 Bug is there and this Bug was on BukkitContrib too. If you use Spout & AuthMe togheter and you type in /reload (from essentials) you cant login anymore in AuthMe. You get the Error: You are not registered. Then you log out, log in and you can login. It's just when you reload the Server. Then this Bug appear. Is there a way to fix this? I got no Error in the log nothing.
  29. Offline


    AuthMe and Spout have incompatibility Issues.
  30. Offline


    YES! :DD lol thank you.
  31. Offline


    Sounds like a bug with AuthMe itself.
Thread Status:
Not open for further replies.

Share This Page