Dev Bukkit plugin server versions need an update.

Discussion in 'BukkitDev Information and Feedback' started by Sycholic, Mar 10, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    Sycholic

    Simple enough server version 1.8.3 is missing from the pulldown menu for uploading plugins to dev.bukkit highest version currently it still 1.8.1 (which technically never even existed either)
     
    Last edited: Mar 10, 2015
  2. Offline

    Ribesg

    The latest and final version of Bukkit is 1.7.10-R0.1-SNAPSHOT.
     
    AdamQpzm likes this.
  3. Offline

    Bobcat00

    I pointed that out 4 days ago, and my post was deleted.
     
  4. Offline

    LordDarthBob

  5. Offline

    Sycholic

    probally why they had some DT the other day and added it. last plugin I updated due to NMS stuff 1.8.3 wasnt on the list only went up to 1.8.1
     
  6. Offline

    quakemaster1209

    bukkit staff wont help with that they only support 1.7.9
    they will refuse any support for 1.8 since there is NO official 1.8 out there.
    the only 1.8 bukkit out there is made by spigot which is their competition.
     
  7. Offline

    bwfcwalshy Retired Staff

    @quakemaster1209 We do help, that's why we have the Bukkit Alternates thread. I and other moderators help on there and a lot of them threads are 1.8. Please do not portray us as unhelpful because of 1.8 when we do help.
     
    nverdier, timtower and Kilorbine like this.
  8. Offline

    AdamQpzm

    @bwfcwalshy It's a weird situation, but I think that this is one of those times that "helping" is actually unhelpful. The support of Bukkit alternatives on here isn't something I particularly see as helpful, it's just ultimately confusing to the end users. Especially when you consider the BukkitDev situation - which is what this thread is about - considering there is no place for Bukkit alternative plugins there, non-Bukkit plugins are still forbidden in the official guidelines, and yet they're accepted. Support of Bukkit alternatives isn't helpful, correct direction is. :)
     
  9. Offline

    bwfcwalshy Retired Staff

    @AdamQpzm Have you told Curse the guidelines are outdated? I'm not sure a plugin for a server mod like Cauldron will be allowed but 1.8 plugins for Spigot's builds will be, so in a way the guidelines are still right just they need to be made clearer.
     
  10. Offline

    AdamQpzm

    @bwfcwalshy No, I have an outstanding PM with them dating back to December, and a BukkitDev PM dating back to (I think) January. I wouldn't be surprised if Curse have their own rules to what's allowed, but the current situation for uploading from what I can tell is we're playing a game that Curse refuse to tell us the rules to. The only way to find out is to break them, which clearly isn't the right way of doing things. There's no disputing that the guidelines are out of date, as Curse are knowingly accepting plugins which do not work on Bukkit. The alternative is that they don't know the plugins don't work on Bukkit, which is a far more frightening possibility. At that point, it doesn't matter whether the plugin is for Spigot, Cauldron, or The Sims. If it's not a Bukkit plugin, it shouldn't belong.
     
    Lolmewn likes this.
  11. Offline

    Lolmewn Retired Staff

    @AdamQpzm I'm so tempted to make a Sims plugin now and see what happens.
     
    AdamQpzm likes this.
  12. Offline

    tastybento

    1.8.3 is in the list, which is good, but could it be put at the top? I get a lot of "does this plugin support 1.8.3" questions, because currently 1.8.1 is the top listed and only the topper-most gets shown on the main page. Thanks!
     
Thread Status:
Not open for further replies.

Share This Page