[DEAD] Spells v0.996

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 16, 2011.

  1. Offline


    When will there be a update to 617
  2. Offline


    Did something actually happen in 617 that broke Spells or Wand?

    You're on the right track- if you have the latest Spells and the permissions,yml file that I link to in the OP, as an op you should have access to all spells.

    If you're using Permissions, you have to set that up and I can't really help a whole lot with that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  3. Offline


    2011-04-07 16:33:02 [INFO] Starting minecraft server version Beta 1.4
    2011-04-07 16:33:02 [INFO] Loading properties
    2011-04-07 16:33:02 [INFO] Starting Minecraft server on
    2011-04-07 16:33:02 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-609-g39996e1-b612jnks (MC: 1.4)
    2011-04-07 16:33:02 [INFO] Preparing level "Flatgrass"
    2011-04-07 16:33:02 [INFO] Preparing start region
    2011-04-07 16:33:02 [INFO] 144 recipes
    2011-04-07 16:33:03 [INFO] Invalid config file found and converted to proper name/format.
    2011-04-07 16:33:03 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-04-07 16:33:03 [INFO] [MagicCarpet] MagicCarpet version 1.5.1 is enabled!
    2011-04-07 16:33:03 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet or /mc.
    2011-04-07 16:33:03 [INFO] [MagicCarpet] Using Permissions.
    2011-04-07 16:33:03 [INFO] [Permissions] version [2.5.5] (Phoenix)  loaded
    2011-04-07 16:33:04 [INFO] PermissionsSupport: Found Permissions, using it for permissions.
    2011-04-07 16:33:04 [INFO] PermissionsSupport version 0.1 is enabled
    2011-04-07 16:33:04 [INFO] Persistence version 0.63 is enabled
    2011-04-07 16:33:04 [INFO] Spells version 0.996 is enabled
    2011-04-07 16:33:04 [INFO] Loading wand-commands.txt
    2011-04-07 16:33:04 [INFO] Wandmin version 0.32 is enabled
    2011-04-07 16:33:04 [INFO] Done (0,145s)! For help, type "help" or "?"
    2011-04-07 16:33:08 [INFO] Peristence: Can't find callback 'onGrantPlayer for plugin Persistence
    2011-04-07 16:33:08 [INFO] grant player : Grant a player access
    2011-04-07 16:33:08 [INFO]    ex: grant player <player> <permission>
    2011-04-07 16:33:08 [INFO] grant group : Grant a group access
    2011-04-07 16:33:08 [INFO]    ex: grant group <group> <permission>
    2011-04-07 16:33:10 [INFO] Peristence: Can't find callback 'onSU for plugin Persistence
    2011-04-07 16:33:10 [INFO] Use "phelp" for help
    2011-04-07 16:33:12 [INFO] Peristence: Can't find callback 'onHelp for plugin Persistence
    2011-04-07 16:33:12 [INFO] Get help on plugin commands
    placed the permissions.yml in the C:\Minecraft Server\Mapmaking\plugins\Permissions

    still not working thought
  4. Offline


    i only added persmissions cause i could not get it to work at all. Also what should happen if i type in /spells ? as nothing happens right now. i really wish i could use this plugin :|.
  5. Offline


    The reason is because you don't have the plugins/Persistence/permissions.yml setup correctly. It is a broken link in the original post that hasn't really been updated.

    # Defines the "default" profile
    # All players have this profile by default
          spells: true
          - heal
          - blink
          - torch
          - fireball
          - pillar
          - absorb
          - fill
          - cushion
          - undo
          - alter
          - blast
          - mine
          - tree
          - arrow
          - frost
          - gills
          - familiar
          - blob
          - superblob
          - paint
          - recurse
          - transmute
          - recall
          - disintegrate
          - manifest
          - peek
          - fire
          - window
          - lava
          - portal
          - phase
          - invincible
          - fire
          - tunnel
          - bridge
          - rewind
          - ascend
          - descend
          - map
          - stalactite
          - superblast
          - monster
          - sandblast
    # Defines the "admin" profile
    # These players can use "/su" to access any command
          su: true
    I had to add this to get spells to work. Though I still have yet to get /su to work even though I am an admin under the Permissions plugin.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  6. Offline


    For anyone having problems getting spells to work, here is my setup to use as a sample. I'm currently on CB[670], I use Permissions, and I've got a couple different permissions groups that each get their own set of spells. If my setup is similar to yours, then this should work for you, too.

    Here are the applicable plugins:
    Spells 0.996
    Wand 0.69
    Permissions 2.5.5
    Persistence 0.64

    Interesting parts of the Permissions world.yml:
            default: false
                prefix: '&5'
                suffix: '+'
                build: true
                - Citizen
                - 'Spells.commands.cast'
                - 'Spells.cast.torch'
                - 'Spells.cast.blink'
                - 'Spells.cast.day'
    My Spells.properties and Wand.properties are the default (except I changed my wand item to a slimeball to avoid conflicts with another plugin). I don't have a Persistence.yml or any other permissions-type file. The most common mistake I've seen is using Permissions and not loading the PermissionsSupport.jar. It is in the OP. If you don't use it, things will not work!

    Hopefully this'll help some frustrated admin.

    EDIT: was working on [626], still working on [670]
  7. Offline


    k I'm getting tired of whole this permissions/persistence thing for real !

    I checked my yml. it's all 4 spaces indent. I gave my default users '*' , guess what, it does jack sh** . I still can't do /permissions -reload all

    So now what ? It was working yesterday, I changed nothing, but really nothing to the config. And by moving it to a backup folder and back it got broken. For real ... Is there really no better way then this crappy yml ? If it is the config file that is ... And yeah my post ain't polite, and I'm tired of this plugin shit anyway, so sorry, I'm real pissed.

    Looking at the number of posts it's telling something. Or we are all noobs, or this system just ain't working like it should be. ( aka not noob friendly )

    edit: ow yeah the reason I started messing around, was because suddenly I couldn't /su myself back. So I'm stuck as a normal user, and can't become admin anymore, really handy ! And fyi, my world is named OmegaII World and my permissions file is OmegaII\ World.yml ( linux style notation ), so it's correct. It has always been correct, so why not now. And all plugins have been removed to another folder in a dir above the one of craftbukkit so none could be loaded. Only permissions, and permissions + persistence, nothing works.

    edit2: I've renamed OmegaII_World.yml to config.yml, let the plugin rename it to the same name. And now I can reuse /su again... the fuck ... BUT ! If I now use /su again, it states I'm normal user, but I still can everything.

    I allready changed the file again so Default has no permissions, and Admins inherits Default and has '*' permissions.


    09:40:46 [INFO] Preparing level "OmegaII_World"
    09:40:46 [INFO] Preparing start region
    09:40:47 [INFO] 144 recipes
    09:40:47 [INFO] Preparing spawn area: 0%
    09:40:48 [INFO] Preparing spawn area: 44%
    09:40:49 [INFO] Invalid config file found and converted to proper name/format.

    The file is still called OmegaII_World.yml, the config.yml has been removed. Permissions is the only plugin available ... the fuck :confused:
  8. Offline


    thanks for the support i got it to work. funny is...once /su is activated it keeps on working even after removing persmissions unlike before. just perfect for my cause :D
  9. Offline


    Hi all,
    I havent tryed it yet (I uesd to, on 1.3 (I LOVE THE FILL COMMAND!))
    I just had this question, WHen i fill ice with Anythiong it becomes water, then i do it again, and it becomes the correct material. Anyway to fix this? (I know what happens, it first makes the Dirt FE, and then it uses the Ice-Break command to make water, could you make it so, that it first changes to water, and then to the selected material, without having to do it twice? (If you make it so that it doesnt make water, it might get buggy, because i still want to make ice to make water oon break, when i mine it by Hand)

    Thanks in Advantage, downloading it at home when my internet is runnin again -.-
    NathanWolf likes this.
  10. Offline


    that worked :)
    NathanWolf likes this.
  11. Offline


    Once you activate "/su", it's on for good. It's not a great idea to play like this- my plugins will start to behave "strangely" in some cases- such as NG always creating gates for you, even if you're turned that off. It will also bypass casting cost checks, and a host of other things you may or may not want.

    I'm considering making /su deactivate once you move- it's really only meant to issuing admin console commands in-game.

    This sounds like material selection system confusion- until I get some better docs, maybe check out the Magic wiki, or just scan a bit. In short, whatever you're holding on the far right of your active inventory (slot 9) is what you will with... it's odd for this to be water, but I do it all the time. Otherwise, I'm not sure why it would fill with water...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  12. Offline


    Is there a debug option for /su ? Because since 6xx I can't turn it off either. ( Or on for that matter @ random ) It gives no error message. It says the right messages. But I still can do all the admin stuff.
  13. Offline


    No debugging beyond the messages is prints to you.

    It prints a message when you use it- it should either say "Normal Access Restored" or "Full Access Granted". If you get no message when using it, then you should get a "Player Omegall tried command 'su'" in your server log, which would indicate you don't have permission to use the command.
  14. Offline


    It says the "Normal Access Restored" or "Full Access Granted". And can continue to do everything in both situations. Default group has no extra rights. Admin has '*' . User has no extra permissions.
  15. Offline


    Ok, so if admin has "*", why are you expecting to not have all permissions, as an admin?
  16. Offline


    :confused: Wait wait ... so. You have the command /su, it triggers 2 states, right ? The purpous of the command is to switch between super user ( aka admin ) and normal user. And you are saying, that when you are admin, and I want to use the /su command, wich intends to switch between a normal user and admin, I can't because I am admin ?

    So you just are saying that /su never worked and the times it did before it was just a fluke ? Or are you just trolling your own stuff now ? :p

    Or do I have to create a super user group like in linux, make myself a member of that group and then use /su ? Because that hasn't been described anywhere I looked at all. So have no clue how to do that in the slightest way.
  17. Offline


    Uh.... none of the above.

    "su" is command, it has nothing to do with "admin", necessarily. If you're using Permissions, you really don't need it- you've given yourself "*", that's basically like permanent su. Just forget it and move on :)
  18. Offline


    is this going to work with build 670?
  19. Offline


    Don't know, I'm afraid. I haven't tested with anything above 612. I can say that I'm running all my current code against current CB. I'm not seeing anything that would have needed to change.

    If I get a chance, I'll update my public server to latest RB, and update thread titles accordingly.

    Looks good to me on 670, updated my public server (mine.elmakers.com) - let me know if you see different.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  20. Offline


    The only thing I've noticed so far that doesn't work on 670 (and maybe it's working how it should now, I don't know) is that tunnel doesn't start at the block you're pointing at, it starts directly in front of you, whatever level you're on, going to the nearest axis (i.e. I start squarely facing some blocks in front of me, and then I go 5 blocks square down and to the left, type /cast tunnel and it tunnels where I was pointing in the first place).
  21. Offline


    Ok i found one error, idk if its in wand or spells i have both, but i get the error
    it spamed when i tryed to use blink and cycleing :/ idk
    NathanWolf likes this.
  22. Offline


    I have the same problem with WAND.

    I also don't seem to be able to get the SPELL - TRANSMUTE - to work.

    Running b670 of CB, Spells 0.996, Wand 0.69.

    Not really sure if I have the latest version of everything.
    NathanWolf likes this.
  23. Offline


    I'm having an issue with all players of any group being able to use the spells despite downloading and installing the permissions compatibility file, is there something I've missed?

    EDIT: nevermind, it seems to have just been a fluke of some sort
    NathanWolf likes this.
  24. Offline


    Hi,this i put the two plugins in my plugins file,loaded up bukkit and it says it is loaded but then when i try something like "/cast blink" nothing happens!

    EDIT:Fixed! i op-ed my self and used the "elbukkit" you provided,but before this i was using bukkit 670 and this was not working :O
    NathanWolf likes this.
  25. Offline


    Typing anything, even /spells list does not do squat. In the console it says I do the command, but has nothing else. I have Bukkit 670 and a lot of Plugins, so maybe that is the problem?



    I've tried reinstalling it once, I will do it again. This mod sounds and looks well-done :)

    EDIT: Reinstalling did not work, and a correction; whenever I type a command in-game that is related to this mod, (ie. /spells list) absolutely nothing pops up in the Console.
  26. Offline


    A bunch of users on my server are asking how to "fill" with air/empty. they had a method that worked on 1.3 which was filling with cactus and somehow it made it empty. I've had wands glitch on me where randomly the fill wand will erase. anyone know how to use the fill function as an "Eraser"?
  27. Offline


    That is actually how tunnel is supposed to work :D

    Yeah, I do believe that is my fault, and Wand spell/material cycling is broken in latest RB. I really wish they'd stop changing that fracking event.

    Put a material (like a dirt block) in your second-to-last inventory slot, leave the last one empty. You are now "constructing" with air- this turns fill, blob, recurse, etc into "eraser" spells.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  28. Offline


    Is there a spell that can be used like Fill, but is an eraser?

    Edit: Lol, i refreshed the page, saw you online and that my msg wasn't replied to, posted this and your message popped up. thx for clarifying this

    Just tested, and this isn't working. Any suggestions?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  29. Offline


    Oh, How come "/cast monster" does not work ?
    im running the latest version
  30. Offline


    Please fix so I can view the Permissions Sample.

Share This Page