[DEAD] Spells v0.996

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 16, 2011.

  1. Offline


    Check out the properties file.... though I think I disabled the customizable material lists (temporarily) for construction spells, since you can break your world with it. If it's still there, modify at your own risk :)
  2. Offline


    I got this error in my Console:
    16:12:04 [SCHWERWIEGEND] Could not pass event PLAYER_JOIN to Persistence
            at com.elmakers.mine.bukkit.persistence.dao.PluginCommand.checkPermissio
            at com.elmakers.mine.bukkit.plugins.persistence.PersistenceListener.onPl
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.ServerConfigurationManager.a(ServerConfiguration
            at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:87)
            at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:68)
            at net.minecraft.server.Packet1Login.a(SourceFile:46)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:34)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    16:12:08 [SCHWERWIEGEND] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'spel
    ls' in plugin Spells v0.99
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:33)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
            at com.elmakers.mine.bukkit.persistence.dao.PluginCommand.checkPermissio
            at com.elmakers.mine.bukkit.utilities.PluginUtilities.dispatch(PluginUti
            at com.elmakers.mine.bukkit.utilities.PluginUtilities.dispatch(PluginUti
            at com.elmakers.mine.bukkit.plugins.spells.SpellsPlugin.onCommand(Spells
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
            ... 12 more
    So if i type "/spells" in my Chat this pops up in my Server Console, does someone know how to fix this ?

    Greetings Timmy
  3. Offline


    Oops, no :)

    Cooldowns will be part of the variant system, along with reagents- possibly at the same time (first release), maybe a bit after.

    Yah, wish I didn't have to keep promising the immanent arrival of that system :p

    "spells-blast-torch-frequency" is actually an unimplemented feature :)

    Much like tunnel, blast was originally supposed to have an option to automatically put up torches to create a pre-lit cave. It probably won't ever actually do that, since blast is going to go away and be replaced by a variant of construct.
    That's something I'd like to get to work eventually, but only if I can do it in a way that works with any protection plugin- I have no plans, nor am I interested, in depending on any one world protect plugins' API.
    Everyone was getting that error in their console- make sure you've got Persistence 0.56, please, it's been fixed.
  4. Offline


    Quick question am I able to put the spells in a bookcase were if people find them they can right click them to learn them?
  5. Offline


    No, not yet- I don't really have a plan to do this, either, so it'd have to be the kind of thing that waits to see if there's a place for it.

    The main thing this requires is a better permissions system, and one is hopefully on the way.
  6. Offline


    Ok thanks NathanWolf. Love tthe plugin also works great
  7. Offline


    Gonna check it out and try it on the testserver.
    Oh and I just gotta ask why you have the properties files under the serverroot instead of say /plugins/spells and /plugins/wand ?

    Did'nt see anything about blocking some id's in the properties file. Is the row removed aswell or am I blind?
  8. Offline


    Thanks! So glad it's all finally working again!

    Cute baby BTW :)
    Always a good idea! You can really ruin some stuff with spells, if you're not careful- this is not just a matter of permissions/trusting your players, but "whoopsies" as well :)

    That.... is an excellent question :)

    It will move at some point, if it does not go away completely. I'm hoping that most, if not all, of that can be encapsulated per-player (or globally) using permission profiles.

    You mean preventing some materials from being used?

    It would all be in the corresponding material list for the spell you're using- like blob, construct or fill- each should have a list, but like I said that may be gone, until I can bring it back in a safer way.
  9. Offline


  10. Offline


    Any idea when the reagent/cooldown stuff is coming? I use permissions to define classes on my server with a mixture of dropbonuses/mcmmo/towny. Right now I have Fighters/Rangers/Blacksmiths/Wizards. Currently I'm giving wizards commands like /top, /sethome, /home, /jump, etc, and they break all their blocks with sticks (painful for ore but they get good drops). I'd love to incorporate this plugin for them but in the current state they'd be way overpowered.
  11. Offline


    The permission for removing a person's ability to use a spell doesn't seem to work...
    doing "-Spells.cast.lava" doesn't remove their ability to cast the spell lava. Help? xD I'm tired of one of our idiotic semi-griefing moderators spamming lava in random places...
  12. Offline


    That makes allot of sense, i wouldn't want to develop a fix for 4 plugins API's. I had this issue with the developer of blockbonus. He was able to solve the problem and get it working with all protection plugins by changing some simple things in his code. perhaps you should shoot him a pm.
  13. Offline


    Didn't know Permissions had any kind of "deny" feature, I don't think I support it if it requires anything special.
    Done- thanks for the tip!
  14. Offline


    Should 'Window' be working with the current release of NetherGate & Spells? I've tried it a couple times and nothing happens on the first attempt. The second attempt tells me that I need to wait for the first window.

    If it isn't working... please don't take any time away from NG to fix it! I'd rather have named & linked portals first, pleeze![​IMG]
  15. Offline


    Heh :) LOL...

    Uh, yeah, it's not really working :)

    Not very well, anyway- needs a good bit of work, something that is definitely going to wait a while :)

    Since it doesn't break anything, I won't WIP it unless people get obnoxious about it- but honestly I don't think many people know it exists anyway, and it doesn't even show up if you don't have NG :D

    It is a very cool spell, though, and I certainly want to get it working one day....
    0.991 Released

    Ok, yeah, the version numbers are going to be a little goofy for a bit. Hopefully there won't be too many more releases before 1.0!

    If you want to update, get Spells.jar and Persistence.jar - you need Persistence 0.60 as well.

    This version adds a built-in permissions system- so Permissions is no longer required. If you want to use the built-in permissions system, remove PermissionsSupport.jar and then create a "plugins/Persistence/permissions.yml" file.

    Here is an example permissions.yml

    This sets up a default group, giving all players blink and torch. It also sets up "admin" and "wizard" profiles, which you can give to players or groups with the "/grant" command.

    Let me know if you're interested in using this and have questions- it's more here for me, I don't want any "non-NathanWolf" plugins on my public server, and I can't wait any longer for bukkit permissions.
  16. Offline


    Is this mod working with the current version and what not on smp? :3 I'm getting a "Spell 'create' unknown, Use /spells for a spell list" and /spell does nothing at all :v

    I can type /wand and get a wand, but its just a stick and has no features.

    When I started up the server it created "wand.properties" "spells.properties" no spell-classes was made, I found a post you made earlier and copied that text into a .txt file named correctly.

    I have Groups - NetherGate - Persistance - Spells - wand all in the Plugins folder.

    Server relays;
    NetherGate version 0.52 is enabled
    Persistence version 0.59 is enabled
    spells: found NetherGate! Thanks... :p
    Spells version 0.99 is enabled
    Wand version 0.65 is enabled

    Not familiar with bukkit, just starting a bukkit server today :D If you have any recommendations, or suggestions on how I messed it up, lemmeh know :3!
  17. Offline


    I get the same issue. Nothing happens when I try to use any Spells commands. (/spells /cast, etc, tried everything)

    On the other side, /wand gives me response. And the wand magics work. Unfortunately, I can't see the list of spells and what items to use. :(

    CB = 491

    (all of them downloaded from last 5 minutes)

    GroupManager, on debug mode, detects permissions being tested when I summon the command... It even says that the permission test returned successful.... but nothing happens.

    15:23:50 [INFO] GroupManager - FINEST - COMPARING * WITH Spells.commands.cast
    15:23:50 [INFO] GroupManager - FINEST - ROUND * AGAINST Spells
    15:23:50 [INFO] GroupManager - FINEST - WIN
    15:26:07 [INFO] [§cKing§f] AnjoCaido §f[§2||||||||||§8§f]: damn... nothing happened
  18. Offline


    What you guys watching??? Like, seriously old videos I think....

    Check the OP for instructions on how to use each plugin- Wand no longer takes console commands, I'm not sure what you were doing with "create"?

    You will also have to set up permissions of some kind to be able to cast spells- again, it's in the OP :)

    Read up, and then let me know if you still have trouble.
    Hm.... huh.... I'm honestly not sure what all that console output means. It definitely seems like this new GM thing does not work with me, for whatever reason- it certainly implies it's not meant to be a Permissions drop-in.

    Anyway, I'm not seeing the actual nodes get tested (beyond the cast command)- if you do a "/spells", here is what it should look like - there would be a lot of console output, I think:

    And so on, down the list of ALL spells, in alphabetical order. In other worlds, using the "/spells" command should be testing against your right to use every single spell. I'm not seeing that in the log up there, which tells me that your "/spells" command was denied somehow- though it seems to be implying it returned true.

    Is it possible that you don't have permission to actually cast any spell, and that GM is very silent about this for some reason?

    I'm sorry, but I really don't want to have to keep supporting every new permissions system / group manager of the day- Spells has it's own permissions system, which is an attempt to bring a "preview" of bukkit permissions. If you're not using Permissions.jar, and you can't get it to work with your GM of choice, I'm going to have to ask you to just use the internal system.

    If this really becomes some kind of huge deal, I can test out essentials- but I understand that it breaks NetherGate anyway, and I don't see why essentials has permissions integrated in the first place, etc. I'm really not interested...
  19. Offline


    Does this new internal permission system allow for "-Spells.cast.lava" and such? :p Cause I don't wanna have to declare a long list of things for one person and then "Spells.cast.*" for another...
  20. Offline


    I'm afraid I'm having the sorts of difficulties mentioned above.

    On a bare server, using CB 513

    18:02:01 [INFO] Spells version 0.991 is enabled
    18:02:01 [INFO] Persistence version 0.61 is enabled
    18:02:02 [INFO] Wand version 0.65 is enabled

    Swinging my wand around with any material does nothing. Typing /spells gives no output.

    The only thing that seems to be functioning is typing /wand to get a stick, then typing /wand again for instructions.

    typing /wand <any spell name> gives the error Spell '<spellname>' unknown! Type /spells for a list. Even blink!

    I've tried it both with and without permissions.yml, I even attempted to hack together the wizard profile with the default profile to grant full permissions to everyone, same effect.

    Could you perhaps make previous versions available in a separate repository? I stupidly overwrote my old .jars and I'd like to be able to downgrade! I did not have this issue in .97

    EDIT: I'm not as dumb as I look! I did have a spare copy of spells .97, persistence .52, and good old wand .65. installed them again on cb 513 and I'm back in business.

    I was also getting a java error for a while that went away as I continued to mess around, unfortunately it's gone from my buffer and no longer occurs; whenever I tried to wave the wand I got something akin to 'could not pass PLAYER_ANIMATION' to something ultimately related to the permissions system. 'permission' was definitely contained by the java class it was complaining about. This error first occurred directly after installing .991 in my plugin (upgrade directly from .97) and doing a live reload on the server. It seemed to persist through a couple server restarts, then went away.

    Should I delete this post and re-post it on your bug tracker doodad?
  21. Offline


    This is my properties file,

    #Minecraft Properties File
    #Thu Mar 10 00:31:02 EST 2011

    When I download the PermissionsSupport.jar file it errors saying it cannot be supported as it is only the support file or file is incomplete.

    This will sound noob, but I 'ctrl-f' OP and I have no idea what that stands for.. no one else including your other posts refers to an OP :v ((Original post?)) If so I've already set up the properties file and the command /spells does nothing and the wand does not function. so I tried /spells create explore and the spells command (since the spells module is technically installed still) as a work around :<

    I'm using /wand to get the intended item, I have a feather in the first slot, gold sword(wand) in the second and it does nuffin. I am also an op on the server so it should have worked without me adding my name anyways.
  22. Offline


    I believe we are experiencing the same issue. What version of craftbukkit are you running?

    This is mine;

    22:06:48 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-516-gdf87bb3-b531jnks (MC: 1.3)
  23. Offline


    I havent really tried using an item other than the stick for a wand in a long time- I'm not really sure it uses that properties file entry anymore. Does a stick work?

    Also, when I'm speaking of permissions here I mean Spells, not Wand. I'm not talking about the properties file, I'm talking about setting up permissions- see the Permissions section of the Original Post for more info on this.

    There is no longer a default "free for all" mode for Spells- it's locked down now, you have to set up permissions.
    Well, that's a good question. I don't think the permissions system itself supports that, exactly- I'm finding it supports frustratingly little, to be honest. I'm not actually sure how/if I can use wildcards at all in a profile- I'm assuming it works somehow, but I've yet to figure it out myself.

    Nor have I figured out how to make profiles inherit from each other, etc. I'm hoping there's just a learning curve here.

    Anyway, I don't think it supports deny permissions natively, however the user/group system does. So, you could set up a permissions profile that "has" all of the spells you don't want a player to have- then "deny" them that profile.

    However, without a way to set up a wildcard profile, it turns out that this is really pretty useless :p

    In other words, I'm kind of learning this system as I go along, too- I'm really not sure that I'm using it right, or how I'm supposed to be using it, even, to be honest.
    Sorry for all the trouble! I'm hoping most of this is getting better?

    I've tested with Permissions.jar/PermissionsSupport.jar as well as using the internal permissions, and it does seem to be working at least. I think a lot of the difficulty at this point is really going to come down to permissions- especially if you're trying to use the new system.
  24. Offline


    I am not sure if anyone has requested this....but, i it would be awesome if there was some way to add a magic meter or something so that you could cast spells but it had to recharge. It would give the challenge back to the players. I know that's a client side mode and not a server mod but maybe there would be away to implement it via the server side. Like collect apples to regain mp which could be stored server side or directly swap and item out of inv to cast a spell, like a stackable 64 block of apples which would deplete as the user cast that spell. They would then need to go out and farm more apples. I am only using apples as a var, it could be a configs blockid like the rest of the configs. Would also lend this more of an rpg element. Hope that makes sense. Love your work by the way, just started playing with it a few days ago. I wouldn't mind helping dev but don't really know java.
  25. Offline


    We are setting up something very similar soon, but I feel the Permissions file is gonna get really big and complicated with it..
    Any chance I could get a look at yours?
  26. Offline


    Everything works for me....
    Previusly I got the /cast does nothing but and wwand works. I updated soem stuff, and now /cast works, wand works and restrictions by GroupManager works :D

    The only little thing I have is when the first player log into server I get a warning sayind that I have to create something.yml on the persistence folder. I ignore that, as everything seems to work fine for me.

    One little little thing, if I use the wand to cast fire it create that FUCKING AWSOME circle of fire, but if I use /cast fire, it only creates fire on the block im aiming.
  27. Offline


    I re-downloaded everything today.

    Worked on a fresh server with GM, but still same problem on my server.

    I just deleted the Persistence folder and it started working.
  28. Offline


    For sure! There is going to be an MP system layered on top of the reagents system, I think this will do what you're asking.
    You can, but you will be disappointed :) I link to it in the OP, that's basically what I use on my public server for now- it just gives out all the spells to everyone.

    There is a "friend" group as well, but that's mainly there to give out "nether.world.go", not really for spells.

    I don't plan on doing much with Spells and permissions, myself, until I create the Experience plugin to drive it all automatically. Now that there's finally a permissions system in place that can support this, I'm going to start work on right after I "catch up" with the rest of my plugins.

    I'm actually very excited about this Experience plugin- I wish I could clone myself. I really need one of me per plugin- Experience is probably going to have to be the last one I make, purely from a "spread too thin" perspective :(
    Glad you got it working, but it's a bummer that that was necessary.

    The current data migration system is really simple (doesn't even migrate data yet, just schema changes), and I must have made some sort of data change lately that it couldn't handle.

    I continually test with the same data on my public server, so I thought I had avoided this issue- sorry you had to delete your data. Thought we were done with that :(
  29. Offline


    Well, the only Persistence plugins I'm using for now are Spells(I think)... not much of a hassle.

    I just love this plugin, has some useful things for my Miner and Farmer classes.
  30. Offline


    Oh, so we're working with GM again, now? :)

    That's good news.... now if I can just get Essentials to not completely break NetherGate, I'll be in business.

    Yeah- you can safely ignore that, it's just a friendly suggestion ;)

    I was planning on having it not do that if another GM is installed, but that turned out to be more trouble than it was worth, since Persistence spits out that message but doesn't really deal directly with the active group manager.

    Heeeyy, I thought you said the other thing was the only little thing? ;)

    So, probably you have the inferno icon for Wand- that's actual fire. The flint+steel will cast the fire spell. You can, of course, "/cast inferno" - you should get the bigger, more badass and incredibly dangerous version :)

    Speaking of fire, if you frequent my public server, you may notice now that I burned down the entire town accidentally.

    Whoopsies! I was actually just trying to light up a portal, which I built inside of a giant wool effigy of my own head (maybe the whole "false idols" thing is where I went wrong here....)

    Anyway, the portal did not light for whatever reason (I think I made it too tall), and as we all know fire+wool do not mix. Or, rather, they do, I guess- quite well.

    Also highly flammable was the wood/glass/glowstone house I built it on top of, the treehouse next door, the surrounding orchard, the wool "floor" I made around town to coverup all the superblast mess underneath, etc. The whole town burned up- crazy stuff.

    I got it under control using cushion before the whole continent burned up- it was insane, I felt like a magical and very messy firefighter.

    I ended up modifying the recurse spell to handle water better just so I can clean this mess up (I published it, again as a 0.992 "preview" if you're interested....)

    The recurse spell can now be used on water, and it works quite well. If you use air, it's a great way to clean up all the nasty blobs of water that the broken cushion spell (as a for instance...) left all over my world :p

    Anyway, yeah, forest fires- serious business. Careful with that spell :)
    Ahhh- ok, well in that case you've lost absolutely nothing in your data :)

    Once the variant system is here, we won't want to be deleting data, though- assuming you've set up anything custom, that'll all be stored in the db.
    Ok, now I'm confused. Is GM Anjo's GM that Spells works with, or is this Essentialls GM? Too many GMs!

Share This Page