CraftBukkit for Minecraft Beta 1.7.3 now available

Discussion in 'Bukkit News' started by EvilSeph, Jul 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    THIS IS NOT AN UPDATE FOR MINECRAFT RELEASED IN 2013
    Show Spoiler

    A new CraftBukkit Recommended Build (#1000) with Minecraft 1.7.3 support is now available. This new build contains a fix for a huge memory leak (resulting in significantly improved performance), a rudimentary Piston API and a built-in permissions system, among other things (for more information, look at the Recommended Build announcement thread linked below).

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine. However, there are possibly changes included in this build that could break some plugins, though this is highly unlikely to happen.

    Known Issues:
    • Signs, chests, furnaces, etc. sometimes wipe under certain circumstances. This is a vanilla Minecraft 1.7 bug that we're still investigating.
    For more detailed information on what is contains in this update, please see the Recommended Build announcement thread here:
    http://goo.gl/MVtgK

    Updating to this Recommended Build is highly recommended as it contains, among many other things, a fix for a huge memory leak that should result in better performance overall. As always, please backup your server before updating, just in case.

    Download CraftBukkit #1000 here

    To keep up to date on our latest Recommended Builds we have an RSS feed you can subscribe to:
    http://ci.bukkit.org/other/latest_recommended.rss
     
  2. Offline

    lukegb Retired Staff

    They've moved to http://jd.bukkit.org/

    Generating them as part of the standard run is quite taxing and increases build times. Sorry!
     
  3. Offline

    PaleFlyer

    How do i disable the built in permissions, and stay 3rd party? i am having an issue with the built in, and need to remove it as it is pissin off my players.

    i do NOT know why i have two of the minestatus things. if i do....
     
  4. Offline

    Frizzle

    I did a straight update from #953 to #1000 and I'm running iConomy with about 10-15 related plugins, and a datalogger.
    CPU usage (running it on a Xeon X5550 with 4 cpu's) is sitting on 0-5% when I have 20 players on.
    I didn't notice any increase in resource usage whatsoever.
     
  5. Offline

    eirik-ff

    The backup with /backup or an copied world? And do you know how to use the /backup command? Thanks
     
  6. Offline

    coankid

    My Server is eating RAM like never before and the CPU is constantly on 100/110 % and only 9 Players are online. So i think the 1000 Build is a bit buggy ;) Hope there will be a fixed Build soon, so more than 10 Players can join.
     
  7. Offline

    Binder News

    Thanks.
     
  8. Offline

    cjbh1996

    Has anyone even used the new permissions system?
     
  9. Offline

    lukehib

    No, I tried but it's way to complicated for me. There isn't even a proper guide.
    Im sticking with Permissions 3.1 for the time being.
     
  10. Offline

    clitcomander

    DOES THIS MEAN, I DONT NEED PERMISSIONS PLUG IN ANYMORE?????? as its built in????
     
  11. Offline

    Tux2

    Just to let you guys know I've been running my server for several hours straight and it hasn't gotten past the 50% CPU mark yet, while it frequently did with 1.6.6. I do notice that it does eat up more RAM though. I have around 7 worlds on my server and it hovers around 2GB. For those of you noticing 100% CPU usage, try upping the amount of RAM available to Minecraft.
     
  12. Offline

    PaleFlyer

    to up the ram, in the (linux build) minecraft.sh i change the second X code thing to a higher number before the G right? and i am running my server off an old HP laptop with a dual core 1.667 GHz proc, and 3GB physical ram. my players dont complain too often.
     
  13. Offline

    Tux2

    That would be correct. The xmx one.
     
  14. Offline

    7eggert

    The built in permissions are a very simple API, if you need groups, you'll want a plugin managing them. (I'm not even sure the default plugin can read config files ...)
    Besides that, most plugins will interface e.g. the Permissions(Yeti)-specific interface, so you need the bridge plugin.
     
    clitcomander likes this.
  15. Offline

    decebaldecebal

    HELP!
    i have a HUGE problem and idk where to post it
    yesterday while my server was up, a storm with lightnings struck my city and the electricity was down from 1 second, enough for my PC to turn off
    today, when i started the server i got a hole bunch of errors in the console saying that the Chunk (nr here) at coordinates x y z was save at the coordinates x1 y1 z1
    idk what to do because now my hole console is filled with that kind of errors and the server cant handle them so it crashes!
    HELP!I don't want my world to be gone it had huge cities and an LCD screen i worked very hard!Please i want my world back!(i dont have any backup)
     
  16. Offline

    Kenzor108

    Im pretty sure its not CraftBukkit causing this but, It only started to happen when I started my server on Build #1000. The problem is that HOSTILE mobs can't spawn but Neutral mobs spawn fine. The server tells me:

    [SEVERE]Could not pass event PLAYER_INTERACT to SpawnMob

    Someone tell me if CraftBukkit f*cks with plugins or something! Many Thanks!
     
  17. Offline

    Tux2

    Chunkster should do the trick. If you can't figure out how to use it just PM me a link to a copy of your world and I'll do it for you. I do this once in a while on my own world when the power goes out as well.
     
  18. Offline

    DamienMine

    This does seem like a broken world (bad files), minecraft regularly saves the world (or parts of it) AFAIK and if your computer crashes while doing that errors are pretty common (I had this problem myself yet as I make a few backups a day that wasn't a setback for me). There are a few things that may help you in restoring a world: if you have a backup, overwrite the contents or your old world folder (in your server directory\[Worldname], like serverdir\WORLD\ or serverdir\WORLD_NETHER\ with those from the backup); this would be the most sure fire and easy way.
    Another thing that could help you would be to edit the world with a level editor to find and fix the error if it is loadable. I'd recommend MCEdit as it's the one I've used rarely when problems occured.
    Maybe the tool "Chunkster" could help you to repair bad chunks, but I doubt it would be able to rebuild what once was in the defective regions. You can get it here: http://forums.bukkit.org/threads/admin-chunkster.8186/.

    Good luck to you!
     
  19. Offline

    Soulblitz

    I've just updated the world to 1.7.3, and I was playing fine with a 1.7.2 client. However, now that I've updated my client to 1.7.3, I can't connect to the server, and nobody else who has the 1.7.3 client can log in either. We're all getting a simple connection lost error, or "Internal client error: java.net.ProtocolException: Server redirected too many times (20)"

    So yeah, no idea why this is happening. I've tried downgrading the server back to 1.7.2 and that hasn't done anything either, so I don't understand that the problem is or how to fix it. Any advice would be appreciated!

    EDIT: ...and now it works. ¬_¬
     
  20. Offline

    Dinnerbone Bukkit Team Member

    "java.net.ProtocolException: Server redirected too many times (20)"

    Sounds like minecraft.net was having issues, not bukkit related :)
     
  21. Offline

    nala3

    or you could load your world into MCedit and it has a chunk fixing tool. very handy
    EDIT: lol should have read your entire post >.> fail on my part
     
  22. Offline

    Munkyman587

    Just tossing in my 2 cents-- Server is working great on build 1000. Not sure why people are reporting high cpu/ram, I have seen a performance increase (xms 1024, xmx 1536, avg load ~8 people). Good work guys, can't wait for the next update.
     
  23. Offline

    Qwertyuiop8

    Can someone help? My server won't let anyone connect. it was fine until i got build #1000. i can get on, but when ever someone else tries to connect, it just says "connection timed out". plz help!
     
  24. Offline

    nala3

    make sure ports are still forwarded? Maybe something dumb happened. might as well check
     
  25. Offline

    Qwertyuiop8

    it's still forwarded.
     
  26. Offline

    Mike120

    Several players on my server have got the point where the block lag and movement lag is 'unplayable'. Is there any update comming any time soon? Server ram is so high as well, 850mb for 3 people online... really?
     
  27. Offline

    Crysillion

    Someone asked if there was a way to disable the built-in permissions and keep using the Permissions plugin. I agree whole-heartedly, how can this be done? Is it even an option? Don't tell me you guys forced the built-in permissions on us....
     
  28. Offline

    PaleFlyer

    i had everything working based on permissions, then the new server came out, and the permissions broke mine, so my players are up in arms about it, and my admins miss having their rank infront of their name.
     
  29. Offline

    Netto Hikari

    We're currently suffering from the wipe bug... But I can't complain about the new permissions. I don't use it and my Permissions 3.1.6 works flawlessly (except some permissions just not working, but that's an old bug).
     
  30. Offline

    DamienMine

    Hi! As for me I left the built in permissions.yml file empty and it just gets skipped by the bukkit server. Works fine with me still running Permisssions 3.1.6.

    If you're using DynDNS it can take some time til the redirection works properly. I did encounter a problem like this when I reset my internet connection via FritzBox WLAN 7170 and DynDNS. After a while (about 5-20 minutes I think) everything was ok again.
    Does the console put out some error?
     
  31. Offline

    Evenprime

    The new permissions system didn't replace the old system(s) and there is no need to deactivate it, because it doesn't do anything by itself, if it doesn't get used.

    If your Permissions suddenly stopped working, your Permissions plugin or the plugins using it broke.
     
Thread Status:
Not open for further replies.

Share This Page