CraftBukkit for Minecraft 1.7.2 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Nov 30, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    Since Minecraft 1.7.2 was released on October 25th we've been putting in a ridiculous amount of work non-stop towards a CraftBukkit for Minecraft 1.7.2 and I am happy to finally be able to announce that we now have development builds available. We strongly suggest that you only use this build if you would like to help us get a Beta build out sooner and are experienced with using unsupported development builds.

    WARNING: Minecraft 1.7.2 is an update that requires clients to update before being able to connect.

    What is a Development Build?
    A Development build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support requests of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Will plugins break with this build?
    Minecraft 1.7 is one of the most involved updates to date, with Mojang having touched a reported ~220k+ lines of code. As a result, a significant amount of the code base has shifted making it difficult to ensure any stability with regards to our API. That being said, it is difficult to determine if plugins will be breaking with our 1.7.2 update and the state of the API in our earlier development builds should NOT be relied upon in any way.

    Known Issues:
    • None
    Download the development build CraftBukkit 1.7.2-R0.1-SNAPSHOT here
     
  2. Offline

    masre

    Bug report
    • I used this on my server but I couln't use any of the normal 1.7 commands not in the chat, commandblock or the console
    • When I run the server it doesn't show any thing from the server like what people say in chat etc. it only shows that it tried to launch the craftbukkit.jar. Nothing more, I can however type commands in the console and execute it but it still doesn't shows what I type.
     
  3. Offline

    adamwbb

    Bug Report
    seems like my bug report got deleted
    There is a big issue for those who use ip Masks
    Upgrading to 1.7 causes your IP mask to stop working.

    I ran this in a Test Server and set up the IP Mask as i would on my Real Server
    i gave it 48 hours and the results were that the ip mask was not working. Everything was port forwarded Properly. I wont download 1.7 for my main server if this bug Persists.
    I was using 1.7 to test it for bugs and stability. I want to have my main Server on 1.7 ASAP but I need to test these out and see what issues there are so that they are fixed before the main Beta Release.

    on other note: It seems to have an issue with the AV too. Avast and Norton Flagged the 1.7 jar as a PUP.

    TO BUKKIT STAFF:

    TAKE THIS REPORT SERIOUSLY DO NOT DELETE IT LIKE YOU DID BEFORE!
     
  4. Offline

    TnT Retired Staff

    adamwbb
    We cannot reproduce the problem you report with DNS names. Nor does my Avast flag any of our downloads from dl.bukkit.org as a PUP.

    No need for all caps. This is not a bug report thread. Use Bukkit Help for assistance.
     
    Black Hole, mcnibs96 and Lay295 like this.
  5. Offline

    iSayCr4pAlot

    So, thats all they do? Im pretty sure vanilla minecraft has bugs in it..
     
  6. Offline

    ZachBora

    They don't fix vanilla bugs.
     
  7. Offline

    xXHeardyXx

    Nice Work Mate Wish I could of helped was busy that day sorry :p
     
  8. Offline

    ccrama

    Not really a "bug" per se, but I have found that the server list (from a non 1.7 game) shows 1.3 as the server version for 1.7 servers. It sometimes says 1.7.2, but normally shows 1.3 :p
    [​IMG]
     
  9. Offline

    djchewmacca

    I've decided to stick with 1.7.2 for the time being however, I have reduced the size of my map. So far I don't believe anyone has encountered that particular biome as my server hasn't crashed yet. :) Server seems quite stable so far, occasionally it kicks everyone but I believe that is down to the amount of RAM I have.

    Thanks for replying BTW! :)
     
  10. Offline

    Monkeyboystein

    Good work coming from team me!
     
  11. Offline

    spblat

    Heartfelt thanks to EvilSeph and the team. These dev builds have been fabulous. The only issue I experienced was fixed within 24 hours. Essentials and GriefPrevention seem to be working flawlessly. You guys rock.
     
    danw3st likes this.
  12. Offline

    EvilJackCarver

    Page late, I know...
    AuZor :
    [In reply to this post]
     
  13. Offline

    AliofUSA

    Yes! Finally! Good work Bukkit Team. I've been waiting for this moment for soo long...

    thanks again :p
     
  14. Offline

    gerardvanschip

    So far so good, only two plugins that really played up were Dynmap and Prism but the other 36 plugins we use seem fine, minor errors, nothing stopping gameplay.

    Btw, plugins is down to the plugin coders, not bukkit. Many plugins are not even official 1.6 yet and seem stuck on 1.5 or lower.
     
  15. Offline

    ZachBora

    As a plugin developper, if something isn't broken it doesn't need to be fixed. Plugins that always break on new version use NMS code. All the plugins I've made that do not use NMS haven't needed an update since a couple update.

    Right now though, there is a lot of depracated code in 1.7. I expect these to be removed in 1.8 or 1.9, so they will probably be updated.
     
  16. Offline

    EdwardBailie

    I tried 1.7 Bukkit. WorldEdit and WorldGuard works fine. I didn't try MultiVerse. Most of the plugins still work ;)
     
  17. Offline

    Gallion

    Should I expect the same slowdowns caused by the new structure system? Or has it been fixed?
    I'm still on 1.6.3 and I don't think my server can handle the additional load.
     
  18. Offline

    fcernese


    I'm using MultiVerse (along with WE and WG) and it works fine.


    I downloaded the latest Dynmap (1.9.1-869) and it works fine with 1.7.2

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 5, 2016
  19. Offline

    Bobcat00

    Prism 1.6.8 seems to be working fine for me.
     
  20. Offline

    xSh4kerx

    Can you please fix the 1.7 commands /summon, /setblock and /tellraw until Christmas? That would be really nice but anyway thanks for your hard work. :)
     
  21. Offline

    MrInspector

  22. Offline

    GriffonDefender

    Excellent work team! I will get to testing for small bugs and the like as soon as I can!

    220 thousand+ Lines of code for a non-profit organization to change in the span of a month is amazing. Take a break team, you guys have earned it. Let the community take some of the load.
     
  23. Offline

    ~Bmx

    okedokey thats good multiworld works:)
     
  24. Offline

    veins_vgf

    It's my first time upgrading from a previous Craftbukkit version.

    Is it normal to see this in the logs when starting...?

    Or did I forget to upgrade somewhere.. Not understanding why the server version is still 1.6.4

     
  25. Offline

    Wolvereness Bukkit Team Member

    That's the name of the most recent API release (as in, the associated Bukkit API for the last recommended / beta CraftBukkit implementation).
     
  26. Offline

    kazblox

    Crap... 1.7.3 will have chicken jockeys... will this take a really long time to add them in for the next update?
     
  27. Offline

    MrInspector

    Great work guys! :D

    A lot of people will be really happy now that they can update their servers to 1.7!
     
  28. Offline

    Bobcat00

    Yes, why is 1.6.4 part of the version string? This is build #2940:

    git-Bukkit-1.6.4-R2.0-22-g40a262b-b2940jnks (MC: 1.7.2)
     
  29. Offline

    Necrodoom

    2 posts above.
     
  30. Offline

    veins_vgf

    so...the 1.6.4 thing is ok then ? (we're still on 1.7.2 bukkit?)
     
  31. Offline

    KawaiiNeko

    Correct.
     
Thread Status:
Not open for further replies.

Share This Page