CraftBukkit for Minecraft 1.4.4 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Nov 13, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    With the news that the Minecraft 1.4.4 update will be released tomorrow, we've decided to push out a developer quality build (i.e. "it compiles and runs", no guarantees) to help us get to a Beta release faster. As of this post, we've shifted development over to Minecraft 1.4.4 compatibility and now have development builds available with Minecraft 1.4.4 support. While we would love to be able to do this for every Minecraft update, the speed at which we can update is determined by the size and complexity of the update and this varies with each release.

    Please only use this build if you're familiar with the Minecraft snapshot process and would like to help us get a Beta Build out soon after Minecraft 1.4.4 is officially released. This build is COMPLETELY UNSUPPORTED and if you do not know how to acquire Minecraft 1.4.4 early to use it, you should not be running it. We will be deleting any questions asking how to get this usable. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    WARNING: Minecraft 1.4.4 is an update that requires clients to update before being able to connect. Running this build will render your server inaccessible until Minecraft 1.4.4 is officially released.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine. Unless we specifically have to break plugins or the plugins you are using are employing inappropriate practises, most plugins should work without needing an update whenever we put out a new release.

    What is a Developer Build?
    A Developer build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support request of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Known Issues:
    • Torch flame graphical glitch resulting in a torch's flame flickering randomly on the screen. This is a Minecraft bug that can't be fixed by Bukkit.
     
  2. Offline

    Gravity Retired Staff

    Not the Bukkit Team's fault in theeee slightest.
     
  3. Offline

    doglover129

    I have found that it works great aside from one problem. The chat log has a slow response as well as using mods. Everything else works great. How do I know my server isnt lagging it self? I can fly, run, walk anything without a problem. I get these same results from others on my server.
     
  4. Offline

    RebzO1

    :( they patched the sand generator and powered rail lol
     
  5. Offline

    CompeteToDefeat

    Apparently you don't get the concept of development builds...
     
    Sharkykzn and Tooner101 like this.
  6. Offline

    RNba

    cant wait to use it
     
  7. Offline

    Damien711

    Works great on my server running over 40 plugins and no bugs right now. Thanks for the quick update!
     
  8. Offline

    Rima

    Yay!
     
  9. Offline

    Lumix_1

    ok so basically we just gotta wait till the build comes out
     
  10. Offline

    jacklin213

    is 1.4.4 a minecraft development build(snapshot) as well?
     
  11. Offline

    keithtp

  12. Offline

    budfly

    Great job Bukkit team! Can't wait for the Recommended Build/Beta Build! :D Keep up the good work!
     
  13. Offline

    Dr_Bunsen

    I get outdated server version in my minecraft?
    I downloaded this but it seems not to be working, when I do version, it says 1.4.2
     
    Rebecca12K likes this.
  14. Offline

    Rorro

    I am currently running the latest dev build, have been running it since 2 days and i got around 35 plugins and i got no lags and no problems found so far. Hard work, nice result :p thank you
     
  15. Offline

    Tomrocks99

    Text seems to go out of the chat box. Also a lot of people are saying its got laggy.
     
  16. Offline

    EvilJackCarver

    Not a bug.
     
  17. Offline

    dahv

    Is it safe to use the 1.4.4 on my Bukkit server?
    Can i use the same plugins as i use in the 1.4.2?
     
  18. Offline

    TwistedMexi

    cast event.getWhoClicked() to player and get their exp using getExp(); if it's not at the required level, prevent them from grabbing from the result slot, or change the slot to null.

    You can use NBTCompounds to get the string of the item's name, search plug-in development for "Name Changing Class"

    Would an API be beneficial? Sure - is it needed to do what you need? Not at all.
     
  19. How do you keep up with Minecrafts insane release cycle? I cant even keep up with updating bukkit sometimes lol. Maybe someday they will get it right.
     
  20. Offline

    CoZmicShReddeR

    This is awesome news!
     
  21. Offline

    Rebecca12K

    i have the same problem. it just says outdated server when i try to log into a server:(

    then what is it? if not a bug?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
  22. Offline

    macgyverdgi

    ok, so when I start craftbukkit 1.4.4 r0.1 (the latest dev build #2465) I get a error that shuts the server down. I'll post a screen shot. and I also included the crash report file it lists at the buttom. thanks and have a great day. and I love craftbukkit since 1.2.5 r1.0
     

    Attached Files:

  23. do i need to delete the map??!!!
     
  24. Offline

    SnowGears

    Im not asking how to get the name of a changed item. Im saying, how would I cancel the craft event if the items future name (i.e. the name change box on an anvil inventory) was, for example, "Stupid Sword". This currently is not possible without an API event for it so yes, an API would be necessary.
     
  25. Offline

    midnightfang22

    Its an outdated client. Update both the server and the client. 1.4.4 server needs 1.4.4 client to login and 1.4.2 server needs 1.4.2 client to login. The only 1.4.4 craftbukkit out at the moment are developer builds from build #2459 and higher.
     
  26. Offline

    Firebeats121

    Lol it seems when bukkit has finally got a version down minecraft makes a new version XD
     
  27. Offline

    TheRealZuriki

    This is a developer build, not everything is going to be ready yet. An API will come eventually (probably for a full release).
     
    Tooner101 likes this.
  28. Offline

    sammehthedragon

    That is all.
     
    TwistedMexi likes this.
  29. Offline

    durand1w

    Quick question: over time are there fewer differences between vanilla and bukkit?
     
  30. Offline

    Rockslide

    If you're not going to tell people where to download it, whats the point of posting this? People who do know the download location don't need this announcement.
    I think you should let people decide for themselves if they want to use a devbuild, instead of deciding for them.

    Anyway, all of the 1.4.4 devbuilds so far give me 100% CPU usage. Anything I can do to help you pinpoint the cause of this?
     
  31. Offline

    rhino109

    they say it was supposed to be out 3 days ago and it still isnt. why didn't we have a recommended build for 1.4.2
     
Thread Status:
Not open for further replies.

Share This Page