CraftBukkit for a really old version of Minecraft Beta 1.7.2!

Discussion in 'Bukkit News' started by Dinnerbone, Jul 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Dinnerbone Bukkit Team Member

    THIS IS NOT AN UPDATE FOR MINECRAFT RELEASED IN OCT 2013



    Show Spoiler

    Update - July 1, 2011 at 3:01PM EST:
    Minecraft 1.7.2 contains a dupe exploit that will ruin your economy or could create other issues. We strongly recommend waiting for a fix from either Mojang or ourselves before updating.

    ---------------------------------------------------------

    We're pleased to announce our fastest update ever, and we've just made our 1.7.2 compatible build of CraftBukkit available to download as a recommended build here.

    For those who are interested, we had a 1.7 update ready for testing within 15 minutes of 1.7 being launched. That's compared to hours or even days we usually take! 1.7.1 was ready within 10 minutes, and 1.7.2 was ready in just under 10.

    We'd like to thank you all for helping us test these out, and rest assured we're trying everything we can to make these even faster for the future!
     
  2. Offline

    Seth Walton

    Thanks for not helping in any way shape or form.

    After re-reading the errors I received upon joining, and a block placed, the server is still crashing with

    Can anyone provide me with any useful tips on why this is occurring?
     
  3. Offline

    jayri

    you're still posting this in the wrong place. post it in this forum http://forums.bukkit.org/forums/bukkit-help.6/
     
  4. Actually, it was pointed out. Look at the first line of the error, I'll even highlight the relevant part:

    "08:29:01 [SEVERE] Could not pass event PLAYER_JOIN to BukkitContrib java.lang.NoSuchFieldError: a"

    I'm not trying to be an ass here, but it's right there, and if you had looked closer in the thread, there has been a lot of people posting errors that are due to BukkitContrib. You need to check with the dev for that plugin, this isn't a CraftBukkit error.
     
  5. Offline

    Jadedwolf

    Same here. Which is just sad that jeb and notch fixed this but think it's not a big deal. :(
     
  6. Offline

    Seth Walton

    I was unaware that bukkitcontrib was a plugin. Thanks for the help
     
  7. Offline

    misutaanime

    Having problems with my server crashing after a few hours of people playing..

    [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2011-07-04 20:21:22 [SEVERE] at net.minecraft.server.NBTTagByteArray.a(SourceFile:21)
    2011-07-04 20:21:24 [SEVERE] at net.minecraft.server.NBTBase.b(SourceFile:64)
    2011-07-04 20:21:25 [SEVERE] at net.minecraft.server.NBTTagCompound.a(SourceFile:24)
    2011-07-04 20:21:26 [SEVERE] at net.minecraft.server.NBTBase.b(SourceFile:64)
    2011-07-04 20:21:26 [SEVERE] at net.minecraft.server.NBTTagCompound.a(SourceFile:24)
    2011-07-04 20:21:26 [SEVERE] at net.minecraft.server.NBTBase.b(SourceFile:64)
    2011-07-04 20:21:27 [SEVERE] at net.minecraft.server.CompressedStreamTools.a(SourceFile:46)
    2011-07-04 20:21:28 [SEVERE] at net.minecraft.server.ChunkRegionLoader.a(SourceFile:29)
    2011-07-04 20:21:30 [SEVERE] at net.minecraft.server.ChunkProviderServer.loadChunk(ChunkProviderServer.java:136)
    2011-07-04 20:21:31 [SEVERE] at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:65)
    2011-07-04 20:21:31 [SEVERE] at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:31)
    2011-07-04 20:21:32 [SEVERE] at net.minecraft.server.PlayerManager.a(PlayerManager.java:45)
    2011-07-04 20:21:34 [SEVERE] at net.minecraft.server.PlayerManager.movePlayer(PlayerManager.java:141)
    2011-07-04 20:21:34 [SEVERE] at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:138)
    2011-07-04 20:21:35 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:362)
    2011-07-04 20:21:35 [SEVERE] at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    2011-07-04 20:21:35 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-07-04 20:21:36 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    2011-07-04 20:21:36 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-07-04 20:21:36 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-07-04 20:21:36 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-07-04 20:21:37 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-04 20:21:40 [SEVERE] Unexpected exception
    java.lang.OutOfMemoryError: Java heap space
    at net.minecraft.server.NBTTagByteArray.a(SourceFile:21)
    at net.minecraft.server.NBTBase.b(SourceFile:64)
    at net.minecraft.server.NBTTagCompound.a(SourceFile:24)
    at net.minecraft.server.NBTBase.b(SourceFile:64)
    at net.minecraft.server.NBTTagCompound.a(SourceFile:24)
    at net.minecraft.server.NBTBase.b(SourceFile:64)
    at net.minecraft.server.CompressedStreamTools.a(SourceFile:46)
    at net.minecraft.server.ChunkRegionLoader.a(SourceFile:29)
    at net.minecraft.server.ChunkProviderServer.loadChunk(ChunkProviderServer.java:136)
    at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:65)
    at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:31)
    at net.minecraft.server.PlayerManager.a(PlayerManager.java:45)
    at net.minecraft.server.PlayerManager.movePlayer(PlayerManager.java:141)
    at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:138)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:362)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)


    Wasn't doing this with 1.6 and I havent added new plugins just updated some of them.

    here is my start up sequence if that helps..

    2011-07-04 22:37:05 [INFO] Starting minecraft server version Beta 1.7.2
    2011-07-04 22:37:05 [INFO] Loading properties
    2011-07-04 22:37:05 [INFO] Starting Minecraft server on *:25500
    2011-07-04 22:37:05 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-04 22:37:05 [INFO] Preparing level "MyriadGamers3"
    2011-07-04 22:37:05 [INFO] Preparing start region for level 0 (Seed: 1388795880311575700)
    2011-07-04 22:37:06 [INFO] Preparing spawn area: 81%
    2011-07-04 22:37:06 [INFO] [AnyoneSleep] Starting! (version 1.3 by R3ality)
    2011-07-04 22:37:06 [INFO] [AnyoneSleep] Found a permission system, using it!
    2011-07-04 22:37:06 [INFO] DailyBonus is running!
    2011-07-04 22:37:06 [INFO] [DeathTpPlus] 5 Kill Streaks loaded.
    2011-07-04 22:37:06 [INFO] [DeathTpPlus] 5 Death Streaks loaded.
    2011-07-04 22:37:06 [INFO] [DeathTpPlus] Using Permissions
    2011-07-04 22:37:06 [SEVERE] Another plugin is trying to enable GroupManager manually. Don't do this! It's probably com.lonelydime.DeathTpPlus.DeathTpPlus
    2011-07-04 22:37:07 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10 minutes!
    2011-07-04 22:37:07 [INFO] GroupManager version 1.0(alpha-5) [Zombie-Version, please switch to Permissions 3] is enabled!
    2011-07-04 22:37:07 [INFO] [DeathTpPlus] Using GroupManager
    2011-07-04 22:37:07 [INFO] [DeathTpPlus] version 1.86 by lonelydime is enabled!
    2011-07-04 22:37:07 [WARNING] Old nether is disabled until multiworld support in bukkit is fixed.
    2011-07-04 22:37:07 [INFO] Preparing start region for level 1 (Seed: -7211489416243965191)
    2011-07-04 22:37:08 [INFO] Loaded Essentials build 2.4.1 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    2011-07-04 22:37:08 [INFO] [Essentials] Payment method found (iConomy version: 5)
    2011-07-04 22:37:08 [INFO] Loaded EssentialsChat build 2.4.1 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    2011-07-04 22:37:08 [INFO] Loaded EssentialsProtect build 2.4.1 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    2011-07-04 22:37:08 [INFO] Loaded EssentialsSpawn build 2.4.1 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    2011-07-04 22:37:08 [INFO] [FireLord] 0.6 using Permissions system
    2011-07-04 22:37:08 [INFO] [FireLord] version 0.6 enabled!
    2011-07-04 22:37:08 [INFO] FlowControl version 1.0 loaded.
    2011-07-04 22:37:09 [INFO] [iConomy] Logging is currently disabled.
    2011-07-04 22:37:09 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    2011-07-04 22:37:09 [INFO] [iConomy] Developed by: [Nijikokun]
    2011-07-04 22:37:09 [INFO] [DeathTpPlus] hooked into iConomy.
    2011-07-04 22:37:09 [INFO] [MailBox] New thread running.
    2011-07-04 22:37:09 [INFO] [MailBox] hooked into Permissions.
    2011-07-04 22:37:09 [INFO] [MailBox] hooked into iConomy.
    2011-07-04 22:37:09 [INFO] MailBox version 2.1 is enabled! (MySQL is disabled.)
    2011-07-04 22:37:09 [INFO] Loading Config File...
    2011-07-04 22:37:10 [INFO] [mcMMO] Permissions enabled.
    2011-07-04 22:37:10 [INFO] mcMMO version 1.0.29 is enabled!
    2011-07-04 22:37:10 [INFO] [MultiVerse] Permissions Found
    2011-07-04 22:37:10 [INFO] [MultiVerse] - Version 1.7.2 Enabled
    2011-07-04 22:37:10 [INFO] [MultiVerse] Found iConomy, enabling payments.
    2011-07-04 22:37:10 [INFO] [MultiVerse] Loading World & Settings - 'MyriadGamers3' - NORMAL
    2011-07-04 22:37:10 [INFO] [MultiVerse] Loading World & Settings - 'World2' - NORMAL
    2011-07-04 22:37:10 [INFO] Preparing start region for level 2 (Seed: 3032124137180004647)
    2011-07-04 22:37:11 [INFO] [MultiVerse] 2 - World(s) loaded.
    2011-07-04 22:37:11 [INFO] [MultiVerse] Loading Portals
    2011-07-04 22:37:11 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    2011-07-04 22:37:11 [INFO] [uQuest] Loaded with Flatfile!
    2011-07-04 22:37:11 [INFO] [uQuest] v1.5 enabled! With 53 quests loaded!
    2011-07-04 22:37:11 [INFO] [Vouchers] 1.2.2 is enabled!
    2011-07-04 22:37:11 [INFO] Fake Permissions version 2.7.2 is enabled!
    2011-07-04 22:37:11 [INFO] [iConomy] hooked into Permissions.
    2011-07-04 22:37:11 [INFO] [MultiVerse] Found Permissions, enabling commands.
    2011-07-04 22:37:11 [INFO] [Citizens]: Loaded 0 quests.
    2011-07-04 22:37:11 [INFO] [Citizens]: Permissions enabled.
    2011-07-04 22:37:11 [INFO] [Citizens]: version [1.0.9a] (Odyssey) loaded
    2011-07-04 22:37:11 [INFO] [Citizens]: Payment method found (iConomy version: 5)
    2011-07-04 22:37:11 [INFO] Done (0.595s)! For help, type "help" or "?"
    2011-07-04 22:37:11 [INFO] [Citizens]: Loaded 0 NPCs.
    2011-07-04 22:37:21 [INFO] [uQuest] Successfully linked with iConomy.
    2011-07-04 22:37:21 [INFO] [uQuest] Successfully linked with Permissions.
    2011-07-04 22:37:21 [INFO] [uQuest] Successfully linked with Essentials.

    using recommended batch file...
     
  8. Offline

    4am

    You're running out of memory.

    I know it all looks so cryptic guys, but the first line describes the error that was thrown. The remainder of the lines show where in the program you where (and how you got there) when the error happened.
     
  9. Offline

    misutaanime

    I understand the running out of memory but has that much changed between 1.6 and 1.7.. and during 1.6 I would run my server for weeks with out a restart.. I havent added new plugins to the server was just wondering if anyone had an idea why..
     
  10. I know how you guys could fix the duping exploit. I tried pming evil 3 times, but kept failing so I gave up. Just do a check for pistons in that arrangement, then check for block placements. If the pistons are in that arrangement that allows duping, do not allow blocks to be placed inside of that arrangement. The duping issue is then fixed at least temporarily, and effectively. If the API supported it, a plugin could stop it.
     
  11. Offline

    OrtwinS

    Yea, I want the bug fixed so I can update my server.
    I also like solving redstone problems set between certain limits, and as long this works I dont mind working with such a machine, and trying to improve it, just for the technical challange. I just dont want it on my worlds :p.





    They wont do that, flimsy improvised work-arounds is not the Way of the Bukkit.
    They wait for 1.7.3, and the proper fix that comes with it.


    If you have Worldguard you could add pistons to the blacklist.
     
  12. Offline

    ledhead900

    You and me both but that's what happens with gamecompanys that don't care about you and only the money.
     
  13. Offline

    4am

    Problem is that Jeb stated there isn't going to be a 1.7.3. Bukkit, however, isn't going to do a workaround fix, they'll fix the actual issue. When pistons push blocks, the blocks become entites (like mobs) so they may animate free of the block grid; then when they get into position they become blocks again so that interaction occurs correctly (i.e. can be broken, jumped on, etc.

    What is likely happening here is that since the block is being interacted with by two pistons, an object reference is being held by both; when the first piston starts pushing the block forward (converting it into an entity to allow animation; blocks dont' actually move but turn into entities like mobs, they just look like blocks so you can't tell the difference), the reference to the block object isn't removed from the second piston. This second piston (the one on the side) pulls the block back before the first piston has moved the block into position (which destroys the original Block and creates a new one at the ending position). The second piston then destroys the original Block record (suprised this doesn't result in an NPE - maybe it's caught and ignored?) when it's moved into position and boom; two blocks are created from a single block, and you have a major block dupe bug.

    Not sure if the way I explained that is accurate or explained correctly, but I'm sure that's just about the jist of it; which is to say that it is a race condition. All that need to be done is to unlink/destroy the original block *before* a piston starts movement; that way the second piston doesn't think it has a target block to move and just retracts empty.

    Of course, I haven't actually looked over the code so I could be completely wrong on how this is coded; watching the video though this would be my assumption on the cause and the fix. Also, changing the code in such a way may have unintended consiquences with piston interaction elsewhere; which is why it gets complicated and bug like this end up happening in the first place. Imagine every combination of pistons/sticky pistons interacting with every type of block and entity in every position with every redstone configuration including factors such as block type, accessory blocks (snow, torch, etc) and you'll quickly go crosseyed and fall into convulsions.
     
  14. Makes perfect sense. Though my idea was something they could do until they fixed the actual problem.
     
    Oroboro likes this.
  15. Offline

    OrtwinS

    Yes, I just read Jebs tweet that he 'wasn't sure it would motivate another patch'.

    Unbelieveble, a game where resource collection is the only goal (besides rearranging those resources in fancy shapes); and he isn't sure if a duplication bug is worth another patch...

    If I had a twitter account I would tell em that once... every hour.
    When 1.6 was broken people spammed the hell out of Notch and Jeb on twitter, I'm suprised so little people bug them about this...
     
  16. Offline

    deshadowc

    From IRC.

    <Searge> any eta on 1.7.3?
    * _303 pokes jeb
    <titegtnodI> Lol
    <titegtnodI> :confused:
    * Surround has quit (Read error: Connection reset by peer)
    <jeb> probably thursday
     
    4am likes this.
  17. Offline

    4am

    No offense, but you do have stopgap solutions like to use WorldGuard or PistonBlocker to prevent these bugs from affecting your server. That way people can still play with an updated client. Block the pistons, add a note to the MOTD stating it's being worked on by Mojang and until then at least people can play, and if they're still so petty they leave then you don't deserve the aggrivation and you're better off without them.

    You can only do so much for your users before it's ridiculous of them to blame you.
     
  18. Offline

    ledhead900

    Your too late I blocked the pistons via Essentials Protect 3 days ago :p. Just holding out as long as possible but it appears we won't be getting a fix anytime soon that I know about.
     
  19. Offline

    deshadowc

    That's exactly what I told someone last night who was complaining my server is still in beta and hasn't released yet.
     
  20. Offline

    Raqn

  21. Offline

    LeetPowerCraft

  22. Offline

    4am

    Right now there a mumblings of a Thursday release of 1.7.3 which will fix this (amongst other things?). If not, I'm sure the Bukkit team will do something about it, but they're likely waiting to see what color smoke blows out of Mojang's chimney on the issue.

    EDIT: I am posting from work and therefore am a little slow keeping up - look one post up:)
     
  23. Offline

    deshadowc

  24. Offline

    Blueskadoo

    It's not working for me.... i double click the RUN.bat file, then once it's finished loading the map, i try to log in, and it just gets stuck at the Connecting to the Server page.... eventually it says connection timed out.
     
  25. Offline

    CruzBishop

    @Blueskadoo Are you sure you're connecting to the right location? It's localhost for your own computer
     
  26. Offline

    Bronski

    Yeah that's pretty... inexcusable >.>
     
  27. Offline

    Blueskadoo

    Oh wow!!!! Thanks sooooo much! You saved my ass, dude. THANK YOUUUU
     
    CruzBishop likes this.
  28. Offline

    4am

    Anytime you are doing something with networking, connecting to your own machine you use "localhost" or "127.0.0.1". Just an FYI:)
     
    CruzBishop likes this.
  29. Offline

    Blueskadoo

    Ran into another problem.... Now i can get on my server using the localhost thing, but when i type in my actual server IP, i can't log into it. is that because i'm on the computer my server is running on?
     
  30. Offline

    freman

    I've built a notification service to let you know when there's a new recommended build.

    You can sign up here http://bukkit.fremnet.net

    (Edit: Just realized I have no idea which forum to post this to...)
     
  31. Offline

    emcitement

    Sounds like the IP isn't the right one or your ports aren't open. You should be able to log on with your IP just fine if it's all set up.
     
Thread Status:
Not open for further replies.

Share This Page