CraftBukkit 1.3.2-R0.1 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Aug 24, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Beta Build (1.3.2-R0.1) that provides Minecraft 1.3.2 compatibility and includes experimental changes that hopefully improve performance and stability is now available. Please only use this build if you'd like to help us get a new Recommended Build out and don't mind running a preview build to help us test things. If you were running the previous Beta build, please update to this one as it includes some important fixes.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    What is a Beta Build?
    A Beta Build is in between a developer build and a Recommended Build. These builds simply work and are promoted much more frequently than a Recommended Build. While we will do some testing before promoting a beta build, we will not be running it through our extensive test process. As such, there are no guarantees that they will not contain minor bugs. If we do find out they are broken, we will mark it as such on DLB and promote a new one. A beta build may contain incomplete API and new features but they should not interfere with running the build in any way.

    Notable fixes from Minecraft 1.3.2 include:
    + Added sideways logs in trees
    * Fixed a bug that caused players to fall out of the world when going into the Nether
    * Fixed a bug that caused random suffocation damage in water

    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.3.2-R0.1 here
     
    Rick_Ace, chakyl, ewized and 13 others like this.
  2. Offline

    Pr07o7yp3

    Look, I respect Bukkit's team works but there is some truth in his words.
    1.3.1+ is full of bugs. I still get errors and crashes. Fix one bug then came a new one.
    Also big problem are these lag spikes. Every some minutes my server lags for 5-10 sec without reason. It has more that 15 TPS. My CPU is 35-40% uses when the server is full 150 players.
     
  3. Offline

    Derek S

    I am also having problems with this build. Specifically, players take random falling damage just walking or running around. Also, when falling from a minimal height (3 blocks), falling damage was great enough to kill players, even one wearing feather falling armor. I was able to replicate this while running with and without all of my plugins. It seems to happen more to players that have higher latency, but I observed in on my client as well just in walking around and "falling" off 1-high terrain features. I had to revert to the RB to resolve it. Thanks for all you guys' hard work.

    Edit: the problems I am receiving do not appear to be cause by a faulty server clock. Throughout these lag issues, when I used CommandBook's /debug clock feature, I noticed the clock was working within acceptable parameters (-0.3% to 0.3% error rate).

    Also, I should mention that when I was running plugins during testing, they were Commandbook, WorldEdit 5.4, Factions, Hawkeye, Foundiamonds, Spectate, PermissionsBukkit, Bartersigns, and dynmap. I will reiterate however that their presence did not affect this problem; it existed with our without loaded plugins.

    idym, if you are going report problems, maybe you should be a little more specific and say something more than "THE LAG!!" and "put it back the way it was." Not really very helpful to anyone.
     
  4. Offline

    TnT Retired Staff

    Derek S
    Try on a vanilla server. It looks like a vanilla bug.

    Pr07o7yp3
    Any of the lag issues we could identify have been fixed. Try without plugins.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 28, 2016
  5. Offline

    dog.big

  6. Offline

    crunkatog

    We also have this. Have had it since updating to 1.3.1R1.0 and it never went away. Server will run fine for about 30 seconds, then freeze for about 10 seconds, then run fine again, repeat every 30 seconds.

    Players may move around in the world and place blocks while the server appears paused. However, sound, server chat, entity movement, item pickup, damage, block light updates, and timed abilities (e.g. mcMMO's Super Breaker) will be suspended for 10 seconds. When the server resumes processing these, players are not bounced back to their pre-latency positions. They may take cumulative damage in one bunch rather than spread out over separate attacks. If they are breaking or placing blocks during the latency, the "missing" sounds made by these actions are summated all-at-once as soon as the server resumes, so you get a louder-than-normal "dirt" sound from placing dirt blocks, or "stone breaking" sound from continuing to mine stone during a pause.

    There's no dialog or warning in the console to show when this might be happening. I've tried disabling various plugins one by one to see which if any are causing this, e.g. a conflict between plugins or an old version having issues with periodic savestates or writing to a log file. The only plugin that seems to be implicated is Orebfuscator but it is central to our basic security suite.

    I've tried using a different client (Tekkit client) to join the normal server and the lag is still there, but is ABSENT from the two Tekkit servers I've visited.

    Current setup: 1.3.2 running CB 1.3.2-R0.1 beta, Dynmap 0.70, mcMMO v1.3.05, Orebfuscator 1.6.2, DisguiseCraft 3.3, Vault 1.2.17, CreeperHeal 5.0.1, GriefPrevention 6.2, Dynmap-GriefPrevention, Multiverse-Core v2.4, Multiverse-Portals v2.4, Factions 1.6.8, CommandPointsEssentials v0.6

    Server performance shows 25-30% of 6 GB RAM used at peak times with 10-16/50 players. That said, even at 7:15 am when it's just me, the periodic lag freezes are still there with the same frequency, duration, and characteristics.
     
  7. Offline

    TnT Retired Staff

    crunkatog
    When you test without plugins, on the latest RB, do you see the same concerns?
     
  8. Offline

    williewillus

    I love how DlBO shows all the commits since the previous beta :p
     
    TnT likes this.
  9. Offline

    crunkatog

    Bare back CB 1.3.2R0.1 doesn't have lag spikes. I re-added MV-Core so I could test teleports and portals for void-dumping and suffocation errors, and again no lag spikes.

    RB no plugins only has steady (not periodic) sound-lag

    It's probably either Orebfuscator or Dynmap - or perhaps a conflict between either of these and another plugin.
     
  10. Offline

    yogsfan1

    How do you get people on your minecraft server?without port forwarding
     
  11. Offline

    Zimzam

    Awesome, keep up the good work! :D
     
  12. Offline

    dgmindcraft

    I LOVE BUKKIT
     
  13. Offline

    4am

    No lag here, not sure what you're on about.
     
  14. Offline

    bob7

    Any reason why a few of the entities are now deprecated...?
     
  15. Offline

    Devil Boy

    crunkatog
    That lag was likely from the current conflicts between DisguiseCraft and Orebfuscator. I'm still trying to gather more reports so that I can start figuring the best thing that can be done to fix it.
     
  16. Offline

    FloxzzGame


    I do know that. I just wrote it, because I cant wait for the RB! OML
     
  17. Offline

    polkunus

    Excellent stuff guys! I really appreciate this!
     
  18. Offline

    bob7

    That's funny, i posted a large error log proving there were deprecations and other issues and you removed my message.. How mature of you bukkit..
     
  19. Offline

    TnT Retired Staff

    The issue you had was with MCMMO, and not a bug in CraftBukkit.

    This is not a support thread. Use the Bukkit Help forums for assistance.
     
    diannetea likes this.
  20. Offline

    bob7

    No it was not JUST a McMMo issue, Numerous amounts of plugins were reporting the same event. It's obviously an issue with CB. Whether you agree/disagree it has to be a craftbukkit issue, I'm not going to sit in other threads reporting issues none of the staff bother to read/fix so might as well warn the people here (who are downloading it) to watch out for these kinds of errors.
     
  21. Offline

    zazra

    Running this build on an old dual core laptop with 2GB of mem, and it's running just fine, i say make it a recommended build.
     
  22. Offline

    frostmute

    Just because more than one plugin were reporting the same event does not necessarily mean that its a CB issue. >.>

    He's telling you to report it in the respective plugins support areas... so that their developers can see the problem. How is anyone supposed to take a look and fix the issues if you don't post them in the correct places?
     
  23. Offline

    CreeperDude22

    Help! Im not sure if I'm breaking a rule for telling you this but a guy who says work for bukkit says he is ip banning me because I wont make him staff on my server! Help!
     
  24. Offline

    MyPictures

    Properly a fake just ignore/ban or do whatever you want.

    Also the real Craftbukkit team has no control how you host your server. There is no hidden password which gives them OP or whatever ;P

    Agree with frostmute, I have no idea why peoples use this thread for help and whatever (maybe lock the thread next time? I dont know...). Also did you see what happens if the API changes? (Bukkit for MC 1.2). If Craftbukkit changes how a event work then every plugin will error with that change of course and need to be updated to work probably.
     
  25. Offline

    Master Gabe

    They deleted my report as well. I had a report explaining my issues with this beta-build, even issues encountering without my plugins. If you're having issues with this, use the development build #2351. I'm using that, and not having issues besides lag spikes.
     
  26. Offline

    JustNyanCat

    Tested it. No plugins and just gaming. Looks like all right.
     
  27. Offline

    CarlosCandyMan

    I Got This Update For My New Server And When I Go To USE On My Server Nothing From The Craft Bukkit 1.2.5 Server Is There Can Some One Help Me
     
  28. Offline

    TnT Retired Staff

    Master Gabe
    Here's the thing. Most of the reports we get are people testing with plugins and saying they're having issues. While we do not doubt there is a concern, it helps us a great deal to know if the issue occurs without plugins, and taking it a step further, with a vanilla MC server.

    Often times plugins can really impact server performance.

    bob7
    1.3.x required many plugins to update. Async chat events are new, and if you haven't updated your plugins to a version that supports it, you will have problems. This is not a bug in CraftBukkit, it is a bug in your plugins, which you would have found had you used the Bukkit Help forum for assistance.
     
    MyPictures likes this.
  29. Offline

    MyPictures

    I have no idea how you guys always get lag spikes. Yesterday I played a zombie survival map with friends and it was smooth like butter, I didn't get any lag spikes when we were playing, even with 70 zombies in one chunk.
     
  30. Offline

    EpicTrance

    are they now closing the gap between them and spout?
     
  31. Offline

    flyingtacoz

    Will the TPS issue ever be fixed? TPS drops dramatically within an hour..And when TPS does drop, cpu goes higher..
    Any idea why? Tested with no plugins, full server of 25 people.
     
Thread Status:
Not open for further replies.

Share This Page