CraftBukkit 1.3.1 Log in Crash

Discussion in 'Bukkit Help' started by Locx, Aug 2, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Anyone no what is going on? Even though I know it is still a development build.

    09:09:09 [INFO] ed58[/] logged in with entity id 60 at ([world] 2
    40.5, 65.62000000476837, 249.5)
    09:09:09 [INFO] [VanishNoPacket] ed58 disappeared.
    # A fatal error has been detected by the Java Runtime Environment:
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006923d42c, pid=472, ti
    # JRE version: 7.0_04-b09
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (23.0-b11 mixed mode windows-amd64
    compressed oops)
    # Problematic frame:
    # V [jvm.dll+0x4d42c]
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    # An error report file with more information is saved as:
    # C:\Users\Owner\Desktop\Duika Server 1\hs_err_pid472.log
    # If you would like to submit a bug report, please visit:
    Press any key to continue . . .
  2. Offline


    I've had similar issues. Also, I get "Internal Error: java.lang.ArrayIndexOutOfRange"

    Though, no errors in console.
  3. Offline


    Did you try without plugins?

    Moved to the correct forum.
  4. Offline


    I have, yes. No plugins, latest dev build (3rd version) and still the same problem, "Internal Error: java.lang.ArrayIndexOutOfRange"
  5. Offline


    Try it with brand new worlds.
  6. Offline


    Had a feeling it was the worlds, I'm the dev for a server and the owner didn't want to make new worlds. Testing it now.

    Alright, it worked, but we kind of need the old map with the same positions, any way to get the old worlds working correctly?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  7. Offline


    Not sure what is in your world that would block it. Have you tried running Minecraft Region Fixer, or Chunkster to see if they can resolve the world issue?
  8. Offline


    Trying minecraft region fixer, chunkster is outdated. Will report back with results.

    Minecraft Region Fixer found nothing corrupted. Everything was fine.

    We are going to use the old world again, but with the new player info on the world, since we have joined and it has saved the new player data files on us, this will tell us if that's the issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  9. Offline


    Post your server.log from the last try when you attempted to load your world.
  10. Offline


    2012-08-02 09:37:58 [INFO] Starting minecraft server version 1.3.1
    2012-08-02 09:37:58 [INFO] Loading properties
    2012-08-02 09:37:58 [INFO] Default game type: SURVIVAL
    2012-08-02 09:37:58 [INFO] Generating keypair
    2012-08-02 09:37:59 [INFO] Starting Minecraft server on
    2012-08-02 09:37:59 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R5.0-5-g9bcd5fe-b2269jnks (MC: 1.3.1) (Implementing API version 1.3.1-R0.1-SNAPSHOT)
    2012-08-02 09:37:59 [INFO] Preparing level "Wild"
    2012-08-02 09:37:59 [INFO] Preparing start region for level 0 (Seed: -8583706626843560221)
    2012-08-02 09:38:00 [INFO] Preparing start region for level 1 (Seed: 2015428632268834925)
    2012-08-02 09:38:00 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2012-08-02 09:38:00 [INFO] Done (0.640s)! For help, type "help" or "?"
    2012-08-02 09:38:01 [INFO] ----- Bukkit Auto Updater -----
    2012-08-02 09:38:01 [INFO] It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    2012-08-02 09:38:01 [INFO] If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
    2012-08-02 09:38:01 [INFO] With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    2012-08-02 09:38:01 [INFO] If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    2012-08-02 09:38:01 [INFO] ----- ------------------- -----
    2012-08-02 09:38:22 [INFO] Chocofro[/] logged in with entity id 103 at ([Wild] 421.4343672949222, 65.0, -234.17573046920285)
    2012-08-02 09:38:22 [INFO] Chocofro lost connection: disconnect.endOfStream
    End of stream is when the client got the error.

    So our test worked, sort of. We know where the error is happening now. On a player's first join we do a 'cutscene' in a different part of the world.

    Once we enter the actual prison (we are running a prison server) we get disconnected.

    Same issues with no plugins. :/ Not quite sure what's happening. We need that world D:

    This is the problem
    at java.lang.System.arraycopy(Native Method)
    at wk.a(SourceFile:805)
    at asu.a(SourceFile:821)
    at cp.a(SourceFile:135)
    at bb.b(SourceFile:333)
    at asu.d(SourceFile:81)
    at asx.c(SourceFile:69)
    at net.minecraft.client.Minecraft.l(SourceFile:1080)
    at net.minecraft.client.Minecraft.J(SourceFile:583)
    at Source)
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  11. Offline


  12. Offline


    i have the same thing :(
  13. Offline


    Best to not update until they have an Recommended Build...
  14. Offline


    I removed all plugins and it seemed to let me log on. despite the slow amount of time it takes to log in since 1.3.1. I've put back in some of the important plugins like Permissions, Essentials, etc. and it still works. So for me, one or more plugins are causing this error for me. I guess i'll have to take the time to see which one.

    edit: I also do use a new map.
  15. Offline


    I have the same problem what plugin was or are you guys using we can maybe find the Corrupt Plugin
  16. Offline


    Orebfuscator causes this problem, just delete it ;)
    my30808 and TobyG123 like this.
  17. Offline


    Thank you so much!
  18. Offline


    yesssssssssssss it workedddddddddddddd
Thread Status:
Not open for further replies.

Share This Page