CraftBukkit 1.2.5-R5.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Jul 27, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Recommended Build (1.2.5-R5.0) that provides Minecraft 1.2.5 compatibility and fixes issues in CraftBukkit 1.2.5-R4.0 and earlier is now available. As this RB contains a significant number of important changes and fixes, upgrading is highly recommended.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    Notes:
    This Recommended Build includes an upgrade to the jLine we use in Bukkit. As a result, Windows servers need the Visual C++ 2008 redistributable if you want to be able to see text formatting in your console (or use -nojline to disable jLine if you don't want to).

    Unlike a previous Recommended Build (1.2.5-R2.0), this new RB does not need anything special like ANSICON.

    Known Issues:
    • None.
    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.2.5-R5.0 here
     
  2. Offline

    Hugibanana

    Have you started making the 1.3 bukkit version or are you waiting for the official release? I think you should start making the 1.3 since there's a pre-release that is exactly like the official version that will be released next week.
     
  3. Offline

    feildmaster Retired Staff

  4. Offline

    jef202

    than do in update 1.3 XD
     
  5. Offline

    Prominer228

    My server doesn't work with the new serverversion... Why?!
     
  6. Offline

    webserfer

    localization don't working on this version :(
     
  7. Offline

    Ne0nx3r0

    To be fair the phrase is ambiguous; not that it's an easy phrase to word.

    It's also a semantics issue. Most people think of bug fixes as "here is what we fixed", whereas on dl.bukkit.org they are listed as "this was the title of the issue we fixed."

    Maybe it might be worthwhile to consider renaming the more vague or confusing titles as they are submitted to clear these things up?
     
  8. Offline

    d33k40

  9. Offline

    masa

    Hmm, once again the md5sum doesn't match the one provided. What is going on with it lately?
    The one given in is: c1f14c33d965a39fed79c1623ff48cb1 and I'm getting:

    Code:
    masa@ivy ~ $ md5sum craftbukkit-1.2.5-R5.0.jar
    dbc83c5d2e17f30089ad035537cda87e  craftbukkit-1.2.5-R5.0.jar
    
    Is something bugged with whatever generates those, or is someone doing something nasty? The R4.0 release didn't match either until someone fixed it manually after I whined about it on the forums. R3.0 seems to match (now), I don't know if it had the same problem when it came out and someone else whined about it?
     
  10. Offline

    feildmaster Retired Staff

    The process of how the jars are compiled has changed slightly, and the md5 gets generated too early. Sadly, we do not have the ability to fix it.

    Rest assured the file that you download is 100% correct and safe, it's a known issue but can't be fixed at this time.
     
  11. Offline

    superpeanut911

  12. Offline

    TDDxD

    I don't like this build very much =/ Mainly because it gives me too many time outs, but R4.0 didn't gave me them at all! Going back to R4.0
     
  13. Offline

    feildmaster Retired Staff

    Please please please give reports on http://leaky.bukkit.org of any problems with all details contained in it.

    If you are having problems with this build, chances are the same problems just might be in 1.3.
     
  14. Offline

    TDDxD

  15. Offline

    EvilSeph Retired Staff

    We are meant to be renaming tickets that have been addressed to better present as the changelog and usually try to our best to do so. We were too busy working on 1.3 and trying to push out this RB to worry about that this time.
     
  16. Offline

    elias79

    I don't trust this.
     
  17. Offline

    applecpugeek

    You forgot to add 1.3 support! I can't connect with my 1.3 pre release! I was so excited. D:

    Please update this to Craftbukkit 5.1 or 6.0 to support 1.3
     
  18. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    That's not how it works. CraftBukkit 1.3-R1 will be the first release that you can join with 1.3 on. This build adds support for disconnecting 1.3 clients with a proper message. Before this release, 1.3 clients would join and error out and would assume the server was down.
     
  19. Offline

    shiphorns

    I updated today, and had to roll back. Our 1.2.5 server went from being stable under R4.0 to disconnecting all players every few minutes with "disconnect.endOfStream" errors after the R5.0 update. No other changes were made at this time, and our only plugins are Essentials and MobDisguise. Is this due to incompatibility with either of these plugins?
     
  20. Offline

    Don Redhorse

    thanks for putting out an RB before going for the next minecraft version
     
  21. Offline

    TnT Retired Staff

    Its possible. I do not use either of those plugins, so I cannot be sure.
     
  22. Offline

    grid21

    I started using this today and no bugs and no plugin breaks. The likely hood of a plugin breaking even if it is 1.2.3 is very slime. At least from I've used and tried.
     
  23. Offline

    Chevyman4life

    If i replace my craftbukkit.jar with this updated one will this delete my server or anything like that?
     
  24. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Shut down server, replace jar, start server, all done! :D
     
  25. Offline

    VitaminBoy

    Why does it say "OutDated Server" when i try to join the Server whit MC 1.3 and CB 1.2.5-R5.0 ?
     
  26. Offline

    spydercanopus

    Because this is not a 1.3 build...
     
  27. Offline

    Godwar101

    Cool, thanks :)
     
  28. Offline

    VitaminBoy

    BUKKIT-1952: 1.3 Clients are not disconnected with outdated server
    It should work...
     
  29. Offline

    iKeirNez

    Thanks for the update, didn't have to change much in CommandsEX. Just a few methods added and changing 2 deprecated methods.

    I also cannot wait for 1.3 and the 1.3 Bukkit update. I haven't used any of the recent 1.3 snapshots so I will get a nice surprise.

    That was to FIX 1.3 clients connecting and then getting weird errors, now that has been fixed and anybody who tries to connect with 1.3 will be presented with a much nicer message rather than Java errors.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 27, 2016
  30. Offline

    Derjyn

    Sweet. Been running 1.2.5-R5.1 since yesterday, and so far everything is running nicely. Good job!
     
  31. Offline

    travja

    So are you guys working on 1.3?
     
Thread Status:
Not open for further replies.

Share This Page