Corruption caused by craftbukkit 1.1-R2 build 1940.

Discussion in 'Bukkit Help' started by Dooderdo, Mar 8, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    So here is the problem. One day I decided to update to the newest recommended build which happened to be 1940. It was new, I didn't know It could corrupt my worlds. Once 1.2 came out, I tried to update to the recommended beta build, it didn't work. R6... failure. R5... nothing. R4... same exact error. I tried Chunkster, no success. I am running my server on a Studio XPS 435? OS=Vista, 64bit. Ram=3-4GB. Also installed is Java 6 (64bit of course). Here is the exact error;
    Last login: Thu Mar  8 16:54:51 on ttys000
    /Users/*my name*/Desktop/Minecraft\ Maintnance/Minecraft_Server/LaunchServer.command ; exit;
    (do not read my info) /Users/*my name*/Desktop/Minecraft\ Maintnance/Minecraft_Server/LaunchServer.command ; exit;
    174 recipes
    27 achievements
    20:18:37 [INFO] Starting minecraft server version 1.1
    20:18:37 [INFO] Loading properties
    20:18:37 [INFO] Starting Minecraft server on *:25565
    20:18:37 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    20:18:37 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    20:18:37 [WARNING] To change this, set "online-mode" to "true" in the file.
    20:18:37 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R6-b1988jnks (MC: 1.1) (Implementing API version 1.1-R6)
    20:18:37 [SEVERE] java.lang.NullPointerException
    20:18:37 [SEVERE]    at org.bukkit.plugin.PluginDescriptionFile.loadMap(
    20:18:37 [SEVERE]    at org.bukkit.plugin.PluginDescriptionFile.<init>(
    20:18:37 [SEVERE]    at
    20:18:37 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    20:18:37 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    20:18:37 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.<init>(
    20:18:37 [SEVERE]    at net.minecraft.server.ServerConfigurationManager.<init>(
    20:18:37 [SEVERE]    at net.minecraft.server.MinecraftServer.init(
    20:18:37 [SEVERE]    at
    20:18:37 [SEVERE]    at
    20:18:37 [SEVERE] Unexpected exception
        at org.bukkit.plugin.PluginDescriptionFile.loadMap(
        at org.bukkit.plugin.PluginDescriptionFile.<init>(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    Any help would be much appreciated!

    Edit: Note that this error is displayed on and recreated on a macintosh. The error appears on both my server, and my test computer server.
  2. Offline


    Did you remember to change the name of the builds in the startup file?
  3. Offline


    Tried to run R6 with this.
    cd ~/Desktop/Minecraft\ Maintnance/Minecraft_Server
    java -Xincgc -Xmx768M -jar craftbukkit-1.1-R6.jar
    So to answer your question... yes.
  4. Offline


    Do you have a backup from before your update?
  5. Offline


    Before my update to R2? Then yes. But since then everyone on my server has made a lot of progress, which would be lost. Correct?

    Bumpity Bump-Bump

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  6. Offline


    I have this same error, would loading a backup world fix it?
  7. Offline


    I am not sure, I do not have backup that old.
  8. Offline


    I have realized that it is due to the corruption of my maps, which I have fixed with MCedit.
Thread Status:
Not open for further replies.

Share This Page